WordPress.org

Ready to get started?Download WordPress

Forums

404 when inserting media to post (5 posts)

  1. tom@tom11.com
    Member
    Posted 1 year ago #

    I can upload images to the gallery, but when I hit the button to add an image to a post, it gives me:

    You don't have permission to access /blog/wp-admin/media-upload.php on this server. Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.

    Banged my head against this problem for 3 hours today, and am writing in hopes of finding some help. I've seen others with the same problem, but none of their solutions worked for me.

    The file that it's erroring on media-upload.php does indeed exist.

    I'm installing on a shared hosting service- was ehostpros.com, now is called fastwebhost.com. Using Apache and PHP 5.2.9

    I've re-installed WP3.3.2 twice now, once manually and the other time w/ fantastico, and the problem persists.

    I've tried changing the permissions on all folders inside blog to 777.

    I've tried changing permissions on just the blog, wp_admin, and wp_content folders.

    I've tried about 10 variations on adding a .htaccess file to override mod_rewrite.c and mod_rewrite.so

    I've tried a custom and default permalinks.

    I noticed that wordpress never makes it's own .htaccess file, and there are no other .htaccess files in my website.

    My thoughts are:
    1) some server setting that the ISP needs to fix?
    If so, what should I ask them to fix? Something with mod_rewrite.c? I also so a post that referred to mod_rewrite.so instead of .c Have tried that way too with no luck.

    2) Something different about php5?

    Any help would be appreciated.

  2. Matthew Gedeon
    Member
    Posted 1 year ago #

    My bet is on server setting. I would provide them with the error and ask them to check permissions. Be sure to mention the part about wordpress not being allowed to create a .htaccess file.

  3. tom@tom11.com
    Member
    Posted 1 year ago #

    I didn't know that wordpress supposed to be creating a .htaccess file. Thanks.

  4. tom@tom11.com
    Member
    Posted 1 year ago #

    Update- the ISP said "we changed some of your server settings" and now it works. I also see that now WordPress does generate a .htaccess file, just has:

    1
    2 # BEGIN WordPress
    3
    4# END WordPress

    I'm assuming the ISP made a change to allow scripts to generate their own .htaccess files?

  5. Matthew Gedeon
    Member
    Posted 1 year ago #

    WordPress generates a .htaccess file unless there is already one. It doesn't use it unless you change the permalink structure or a plugin uses it (or you network enable wordpress). Most people prefer to change the permalink structure to something more readable.
    I'm not an expert on server settings but I vaguely recall having a similar issue that was only resolved by contacting my host.

Topic Closed

This topic has been closed to new replies.

About this Topic