WordPress.org

Ready to get started?Download WordPress

Forums

NextGEN Gallery
404 When clicking on thumbnail from main page (11 posts)

  1. asp1910
    Member
    Posted 7 months ago #

    Hello,
    I've applied several updated in the last six months, and just now noticed this issue. I've not been on the site a lot, so I'm not sure when it happened. When I click on a thumbnail on the main blog page it takes my to a 404 page, but if I load the individual post for the gallery and click on it, it loads fine.

    I noticed that the directory is missing on the bad link, it gives this -
    http://www.hereafter.com/pics-kruger-national-park-south-africa/nggallery/image/mg_2593_edited-1/
    when it should give this:
    http://www.hereafter.com/blog/pics-kruger-national-park-south-africa/nggallery/image/mg_2593_edited-1/

    You can see this problem now by going to my site at http://www.hereafter.com and scrolling down to the first gallery. If you click a thumbnail it doesn't work, but then click on the gallery title, then a thumbnail, and it does.

    I noticed that there were new options in the gallery setup, where you can choose different templates. I tried selecting one for each type, and then neither thumbnail worked. I restored it back to blank entries for the template types and it returned to my current behaviour.

    Any suggestions?

    - WordPress up to date? Yes.
    - NextGEN up to date? Yes.
    - What version of NextGEN Gallery did you upgrade from?
    I've had many upgrades, not sure when the problem started. I'm currently at 2.0.40

    (please confirm the following, with your server host tech) :
    - MySQL up to date (at least 5.2.4)? 5.5.34-log
    - PHP up to date (at least 5.0)? 5.2.17
    - The mod_rewrite Apache module activated? Yes
    - PHP Safe Mode OFF? Yes (I think)

    Additional information that will help us find a solution:
    - Who are you hosted with? justhost.com
    - What theme are you running? Twenty Ten
    - Which plugins do you have installed and activated? A few, nothing I can see that would cause this. Already tested with all disabled,
    - Does this error still occur if you switch your theme to the WP default, and deactivate all plugins except NextGEN Gallery? (*be sure to clear your browser cache and reload your site after deactivating) Yes.

    Thanks!

    Andrew

    http://wordpress.org/plugins/nextgen-gallery/

  2. asp1910
    Member
    Posted 7 months ago #

    No suggestions?

  3. photocrati
    Member
    Plugin Author

    Posted 7 months ago #

    @asp1910 - Did you move the site to a sub-directory installation, or have you chosen a static page for your blog posts?

    The sample page you are offering is password protected as well so this makes it a bit difficult to troubleshoot as is.

    - Cais.

  4. asp1910
    Member
    Posted 7 months ago #

    Hi Cais,

    The whole site is in a subdirectory.

    It's odd that that page is not visible, now I have TWO bugs! The page is listed as public and published, not sure why it can't be seen. I normally look at the site on the same browser I'm logged in with, so I didn't see that problem.

    I'll try to figure out why it's login protected and update here when that's done.

    - Andrew

  5. asp1910
    Member
    Posted 7 months ago #

    Hi again,

    Now it should be visible to all, I had some settings in wp-members to change. Thanks for letting me know about the issue!

    The original problem is still there if you can look at it, though... I'm going to poke around more and see if I can find some likely settings that could cause that.

    - Andrew

  6. photocrati
    Member
    Plugin Author

    Posted 7 months ago #

    @asp1910 - Andrew, it appears you are using the ImageBrowser Gallery display but there is something affecting at least the first few images that are being displayed before the gallery renders "correctly".

    This is an odd issue, but it does not appear to be anything to do with a sub-directory installation as that has not been an issue previously or with our testing. Have you checked if your other active plugins could be conflicting with NextGEN Gallery?

    - Cais.

  7. asp1910
    Member
    Posted 7 months ago #

    As recommended on the submission page here I did try disabling all the other plugins and going to the default theme, then did a test after clearing my browser cache. The problem looked exactly the same. I also played around with permalinks and didn't see anything change.

    I appreciate you looking at this issue, by the way. Thanks!

    - Andrew

  8. photocrati
    Member
    Plugin Author

    Posted 7 months ago #

    @asp1910 - We may need to get a closer look at your site, could you submit a Bug Report (http://www.nextgen-gallery.com/report-bug/ ... please reference this topic) and include a set of log in and FTP credentials for your WordPress installation on the Bug Report, too.

    Thanks!

    - Cais.

  9. asp1910
    Member
    Posted 7 months ago #

    Hi,

    I'm a bit wary of giving away credentials to my site to people I don't know, so I think I'll dig around a bit first and see if I can track down the error.

    I already found something interesting. The link on the main page is this:

    href="http://www.hereafter.com/blog/pics-kruger-national-park-south-africa/nggallery/image/mg_2593_edited-1"

    And on the post page is this:

    http://www.hereafter.com/blog/pics-kruger-national-park-south-africa/nggallery/image/mg_2593_edited-1/"

    If you look at the end of the URL there is a missing slash on the one from the main page. That causes a 301 error that redirects it to the URL without the /blog/. I'm going to hunt this down a bit more.

    - Andrew

  10. esmi
    Forum Moderator
    Posted 7 months ago #

    @asp1910: Whilst I commend your admirable caution, I can assure you that photocrati & the NextGen team can be trusted. :-)

  11. MarySunshine
    Member
    Posted 7 months ago #

    I am having the same problem. Is there a resolution?

    http://www.skilarchhills.ca/loppet2

Reply

You must log in to post.

About this Plugin

About this Topic

Tags