WordPress.org

Ready to get started?Download WordPress

Forums

404 Status code needed on header page for Mcafee (10 posts)

  1. LanceCla
    Member
    Posted 4 years ago #

    I wanted to report myself as the web site owner to Mcafee but got the following message from them: Anyone know how to resolve it, whether I should change anything and what the drawbacks would be. I would like to be accreditted as a trustworthy site - Thanks:-

    Posting Web Site Owner Comments
    Error Submitting Site for Verification
    It appears that the Web site defiant-child.com (or http://www.defiant-child.com) is returning an HTTP 2xx or 3xx status response code in the header of 404 pages.

    We cannot verify a Web site that is configured this way because it allows anyone to verify themselves as the owner of your site. Please update your Web site server configuration to return 404 status codes in the headers for pages that do not exist. Once your site is configured this way then you can return and request a file name verification.

  2. lisaa610
    Member
    Posted 4 years ago #

    I have been searching for this answer for a couple of hours. I have the same problem when trying to report myself as the web site owner of http://DNAartonline.com. Does anyone have a resolution yet?

  3. milprod
    Member
    Posted 4 years ago #

    I, too, would like a solution, because I'm having the issue too.

  4. cdogg
    Member
    Posted 4 years ago #

    I am having the same issue verifying my sites with McAfee site advisor. I host my websites on Angelfire except for one which is on godaddy. The GoDaddy site was verified successfully by McAfee site advisor. I am only having the issue with the sites hosted by Angelfire.

  5. hqapps
    Member
    Posted 3 years ago #

    please help me I have the same problem It appears that the Web site hq-apps.com (or http://www.hq-apps.com) is returning an HTTP 2xx or 3xx status response code in the header of 404 pages.

    We cannot verify a Web site that is configured this way because it allows anyone to verify themselves as the owner of your site. Please update your Web site server configuration to return 404 status codes in the headers for pages that do not exist. Once your site is configured this way then you can return and request a file name verification.

  6. classifiedsup
    Member
    Posted 3 years ago #

    it should be removed from .htaccess & httpd.conf.
    I am in trouble to my classifieds site

  7. hqapps
    Member
    Posted 3 years ago #

    Please help, if anyone know?

  8. Wil
    Member
    Posted 3 years ago #

    Could be something to do with the contents of your .httaccess file, especially if you are using any 301 redirects.

    On your web server, try renaming .htaccess to .htaccess.old and retry the McAfee verification.

    If that works then follow the verification process then at the end rename your .htaccess.old file back to .htaccess

    It worked for my site and I do make use of 301 redirects.

    If you're interested in testing the header response to a 404 request on your site the easiest way is to download a copy of curl for your OS and at the command line type:
    curl -s -D - -o /dev/null http://gravitationalfx.com/there-is-no-spoon

    substituting your own domain name and non-existant web page to force a 404.

    Here's the response I got using curl.exe on Win 7 64-bit:

    HTTP/1.1 301 Moved Permanently
    Date: Tue, 10 Aug 2010 14:51:21 GMT
    Server: Apache/2
    X-Powered-By: PHP/5.2.13
    X-Pingback: http://www.gravitationalfx.com/xmlrpc.php
    Expires: Wed, 11 Jan 1984 05:00:00 GMT
    Cache-Control: no-cache, must-revalidate, max-age=0
    Pragma: no-cache
    Last-Modified: Tue, 10 Aug 2010 14:51:22 GMT
    Location: http://www.gravitationalfx.com/there-is-no-spoon
    Content-Length: 0
    Content-Type: text/html; charset=UTF-8

    It was apparent in my case that the header was returning a 301 redirect and not the expected 404.

    If this doesn't help, then please check your plug-ins for any type of redirects. This could also include a search redirect.

    I noticed that for the classifiedsup.com website which somebody mentioned further up the post, it redirects any 404 requests internally to a google site search and hence returns a 302 header for the redirected search page. This is also a form of redirection and disabling the site search plug-in will allow for McAfee verification.

    Again, curl pointed to the culprit i.e.

    curl -s -D - -o /dev/null http://classifiedsup.com/nobody-here-but-us-chickens-cluck-cluck
    
    HTTP/1.1 302 Found
    Transfer-Encoding: chunked
    Date: Tue, 10 Aug 2010 15:24:18 GMT
    Server: Apache/2.2.3 (CentOS)
    X-Powered-By: PHP/5.2.9
    Set-Cookie: SESS772e044315b2861d06cea0f3074c3bb4=v5hf3t51iperfu22smm0jcacu0; exp
    ires=Thu, 02-Sep-2010 18:57:38 GMT; path=/; domain=.classifiedsup.com
    Expires: Sun, 19 Nov 1978 05:00:00 GMT
    Last-Modified: Tue, 10 Aug 2010 15:24:18 GMT
    Cache-Control: store, no-cache, must-revalidate
    Cache-Control: post-check=0, pre-check=0
    Location: /search/google/nobody-here-but-us-chickens-cluck-cluck
    Vary: Accept-Encoding
    --------------: ----
    Content-Type: text/html; charset=utf-8

    If you're unsure about which plug-in may be causing the problem,
    1. rename the .htaccess file anyway
    2. disable all plug-ins
    3. run the McAfee verification process
    4. enable plug-ins
    5. rename .htaccess back

    Curl can be downloaded from:
    http://curl.haxx.se/download.html

    Hope this helps y'all.

    Cheerz,
    Wil.

  9. osuntok
    Member
    Posted 3 years ago #

    Hey guys, thanks for bringing this issue up. In resolving the same problem with my site http://delightsometraders.com, I changed the .htaccess to .htaccessold and after verification, I changed it back to .htaccess and that solved the problem for me.
    Thanks,
    Dr. OK

  10. longnh
    Member
    Posted 3 years ago #

    Thanks Wil, you provided a great solution. Check my site: http://www.askguyonline.com

Topic Closed

This topic has been closed to new replies.

About this Topic