WordPress.org

Ready to get started?Download WordPress

Forums

Events Planner
[resolved] 404 page when YOAST seo is active. (4 posts)

  1. Charles Winders
    Member
    Posted 1 year ago #

    After pulling my hair out for a few hours I've found that the issue was Events Planner and Yoast SEO don't play well together. Anytime I have yoast enabled the events list page and any links that go to a single event come up with a 404 page.

    http://wordpress.org/extend/plugins/events-planner/

  2. Abel S
    Member
    Plugin Author

    Posted 1 year ago #

    Hi Charles.

    Oh boy. Sorry for the trouble that you have been having. That is odd though. I have not had others report issues with Yoast SEO. The 404 on single pages usually means that the permalink rules need to be flushed (this is the case for most Custom Post Types). So, reactivate Events Planner, then in WP Admin, visit Settings > Permalinks and hit Save Changes. This should do the trick.

    Hope this helps.

    Thanks, Abel

  3. Charles Winders
    Member
    Posted 1 year ago #

    Thanks for the reply Able, but I've already done that.

    Cleared cache,
    Cleared WP cache via phpMyAdmin
    Resaved permalinks
    deleted htaccess then resaved permalinks
    changed permalink structure then resaved
    changed default page that has shortcode
    changed URL's for category 'events' to 'event posts'
    changed URL for events from 'events' to 'event-list'
    resaved permalinks along the way.

    None of these fixed the issue except turning one of the two plugins off.

    No error via Firebug console either.

  4. Charles Winders
    Member
    Posted 1 year ago #

    Good news Abel,

    I found the issue. Why it was only happening when Yoast and EPL was active I have no idea. But it was an add_action I had in my functions.php. I ended up finding it because it was causing a problem with the media uploader showing an error when I uploaded an image too.

    Seems playing with the functions for woocommerce I was removing actions and adding actions to change out the before and after content areas and didn't need the last piece I wrote in there. While looking for the media upload issue I fixed that. Now I've gone back to Yoast SEO and activated it, the events pages come up fine.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic