WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] 404 Page not working - just shows code (3 posts)

  1. wambamboo
    Member
    Posted 1 year ago #

    Hi
    I have recently moved a WordPress site from a test domain to the proper one.

    However, my 404 page is no longer working. Instead I just get a page of HTML which begins at a seemingly random point in my main menu.

    Following research into how others have solved the problem, I have:

    1) Deactivated and reactivated all plugins

    2) Checked .htaccess. This is what it says:

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>
    
    # END WordPress

    3) Changed my permalinks from /%postname%/ to default and back again

    4) Validated my site with W3C

    5) Reinstalled WordPress

    6) Cleared my cache after each step

    None of these things has had an effect.

    Can anyone help?

    Thanks

  2. aryan554
    Member
    Posted 1 year ago #

    Thehtaccess file which you pasted is completely ok but if not working contact your host...

    Regards
    Aryan
    Bulkjar.iN
    Dil Ki Baat shayari Ke saath

  3. wambamboo
    Member
    Posted 1 year ago #

    Thanks - I have contacted Fasthosts but not heard back yet.

    However it does seem to be a bit of a problem for Fasthosts.

    I eventually created my own 404 page and redirected by this method:

    http://www.southwoodsalt.com/wordpress-404-page-fix-for-streamline-and-fasthosts/#.UUzG_FecO9F

Topic Closed

This topic has been closed to new replies.

About this Topic