WordPress.org

Ready to get started?Download WordPress

Forums

404 Page Not Showing (7 posts)

  1. invisionblue
    Member
    Posted 6 years ago #

    My 404 page is now showing up at all, I have the 404.php with the rest of the files. Does anyone know what could be causing this?

  2. anthem216
    Member
    Posted 6 years ago #

    Under Settings/Reading what happens when you change Front page displays --> Your latest posts?

    I just was having an invisible 404 problem and did that, and suddenly my 404 works fine.

  3. invisionblue
    Member
    Posted 6 years ago #

    thanks all fixed, I had it set to a static page.

  4. Mellco
    Member
    Posted 6 years ago #

    Yes however I use a static page for my front page so I can not use that fix.

    Any ideas how to get the 404 page to work properly with a static page? Right now any non existent url is producing a hodgepodge of wp pages on one page.

    Thanks
    Mell

  5. Mellco
    Member
    Posted 6 years ago #

    I made a selection for a static posts page and that fixed the problem.

    # Front page:
    # Posts page:

    You have to choose a page for each selection for "static page" to get 404 to work properly I guess.

  6. Ed73
    Member
    Posted 6 years ago #

    The problem with that though Mellco is the post page you select will then fail and turn into a 404 so it appears you have little choice but to forfeit the 404 in order to have a working website.

    It clearly needs to be revised.

  7. Ed73
    Member
    Posted 6 years ago #

    Well, I've found a solution. If you're using pages and you've want a static home page then try the following to get the 404 working anything like normal.

    1. Create a page called DO NOT DELETE and publish it.
    2. Make a note of the ID of the DO NOT DELETE page.
    3. Go to DESIGN / THEME EDITOR / SIDEBAR.
    4. Find wp_list_pages and add the parameter "exclude=11"
    5. In my instance the ID was 11 but change yours to the ID noted in step 2.
    6. Go to SETTINGS / READING and select STATIC PAGE.
    7. Set FRONT PAGE to 'home'.
    8. Set POSTS PAGE to the DO NOT DELETE page.

    This should now allow you to have pages only, set a static home page and have the 404.php page show up faithfully on error. Because of step 4 above the DO NOT DELETE page will not show up in the navigation system so your visitors will be unaware of it.

    I know it seems convoluted but it works.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags