WordPress.org

Ready to get started?Download WordPress

Forums

404 Page Not Found after changing URL (16 posts)

  1. Oneofthe88
    Member
    Posted 2 years ago #

    I am having problems with my site disappearing when I change the URL through WordPress settings.

    I use GoDaddy hosting, and installed WordPress. I set the site up through WordPress.com, had it up and running, and then the problems hit.

    When I go to settings > general, the default URLs are:

    WordPress: http://www.sitename.com/wordpress
    Site: http://sitename.com/wordpress

    Everything was fine, as long as the web address I went to was http://www.sitename.com/wordpress. I wanted the site to appear at just http://www.sitename.com, so I changed the site URL to http://www.sitename.com, and now when I went there it said page not found. I went back, put it back to how it was, and so then sitename.com/wordpress worked fine.

    Here's where I think I screwed up. I changed the WordPress URL to http://www.sitename.com, minus the (/wordpress), and got a huge 404 page not found error. Went back and tried to change it, and now everything seems to be gone - changed it back and hit save, and got 404 page not found. Went back a page, and tried to go to the other pages in my Dashboard, and everything just takes me to 404 page not found.

    Help!

  2. Ross Hanney
    Member
    Posted 2 years ago #

    Hello,

    You'll probably need to following the instructions here. Specifically those under the "Using a pre-existing subdirectory install" heading.

    The error messages described in step 3 are most likely what you're seeing now (the 404s), so you should be able to continue from step 4.

  3. FishDawg
    Member
    Posted 2 years ago #

    I have the exact same problem as "Oneofthe88" and I used those instructions BUT I'm still getting the 404 error when trying to access the Admin site as well as the site address? I have tried to back out of the changes but still the same results. At this point I can't find any other solution but to reinstall? Any ideas?

    Signed,
    Fo-Barred!

  4. judering
    Member
    Posted 2 years ago #

    I just did the exact same thing as Oneofthe88. How do I get it all working again?? I can't access anything of my wordpress site anymore. Surely if shouldn't be so easy to screw it up!

    I hope somebody has some clear instructions on how to get it back up and running.

    Thanks,
    J

  5. Ross Hanney
    Member
    Posted 2 years ago #

    Perhaps try adding the following to your wp-config.php file:

    define('WP_SITEURL', 'http://example.com/wordpress');
    define('WP_HOME', 'http://example.com/wordpress');

    Where example.com is your domain, and wordpress is the name of your sub-directory.

    This overrides the "WordPress address" and "Site address" options, and should hopefully allow you to access your site again.

    Then go to Settings > General and change the WordPress address back to http://example.com/wordpress (again, replacing the relevant parts with the details for your site). Now you should remove the two lines added to wp-config.php previously.

    You should then be able to continue with the instructions.

    The WordPress address should always point to the directory that contains the WordPress core files.

  6. judering
    Member
    Posted 2 years ago #

    I got this message when I did the above:

    Parse error: syntax error, unexpected $end, expecting T_STRING or T_VARIABLE or '$' in /home/judering/public_html/blog/wp-config.php on line 94

    Have I placed those two lines in the wrong place in the wp-config.php file?

  7. Ross Hanney
    Member
    Posted 2 years ago #

    Here's a sample wp-config.php that contains the two lines (lines 83 and 84) as an example.

  8. judering
    Member
    Posted 2 years ago #

    Thanks you so much for that. I'm back at my dashboard and now when I go to settings -> general the wordpress address (URL) and site address (URL) boxes are greyed out so I can't change them. Any ideas?

    THanks again!

  9. Ross Hanney
    Member
    Posted 2 years ago #

    Ah, I see.

    Well, you could leave the following line in your wp-config.php file:

    define('WP_SITEURL', 'http://example.com/wordpress');

    and remove the other line (assuming you're going to continue with the instructions).

    Or, if you have access to phpMyAdmin via your hosting control panel, you can change the URL in the database directly (siteurl, in the wp_options table). If you're not sure about how to do this, you're probably better off leaving the line in your wp-config.php, as described above.

  10. judering
    Member
    Posted 2 years ago #

    Ok thanks for all your help Ross! The wordpress address (URL) is still grayed out but the other one is now open.

    I'll try to move on with the "instructions" now or tomorrow and see how I get on.

    Delighted to be back on track! You've saved me many frustrated hours :)

    Thank you!

  11. tamsinhewer
    Member
    Posted 1 year ago #

    thank you so much for this - have been totally panicking and reading lots of complicated posts - yours is the only one that makes sense!

  12. samcomer
    Member
    Posted 1 year ago #

    Hello,

    I changed my blog URL from http://4toplubes.com/MyAMSOILBlog/ to an updated URL of http://4toplubes.com/4TopLubesBlog/ and now I get a 404 page not found error.
    I use iPower web hosting and built the blog through my iPower dashboard. When I Google the 4TopLubesBlog I get a no results found response.
    I can still see the MyAMSOILBlog in my profile but cannot access it, and cannot get to my blogs dashboard to change any settings, how can I fix this?

    Thanks,
    Sam

  13. mimischiffman@gmail.com
    Member
    Posted 1 year ago #

    Hi!
    I viewed my profile and switched both sites to the domain name I wanted and I can't even get to my dashboard anymore. It now says that I just created my account yesterday.
    Do you know how to get to the dashboard when your account was seemingly deleted?
    :) Ne'er shoudla messed with it!

  14. kmessinger
    Volunteer Moderator
    Posted 1 year ago #

    @mimischiffman@gmail.com
    You will get more help by not adding to a old post but starting your own. This should help you.

    http://codex.wordpress.org/Changing_The_Site_URL

  15. montwin67
    Member
    Posted 1 year ago #

    Hi Oneofthe88:
    Were you able to come to any resolution to your issue mentioned above. I'm having the SAME EXACT issue that you did. Any tips on rectifying this would be greatly appreciated!!!!!

    RE:
    I am having problems with my site disappearing when I change the URL through WordPress settings.

    I use GoDaddy hosting, and installed WordPress. I set the site up through WordPress.com, had it up and running, and then the problems hit.

    When I go to settings > general, the default URLs are:

    WordPress: http://www.sitename.com/wordpress
    Site: http://sitename.com/wordpress

    Everything was fine, as long as the web address I went to was http://www.sitename.com/wordpress. I wanted the site to appear at just http://www.sitename.com, so I changed the site URL to http://www.sitename.com, and now when I went there it said page not found. I went back, put it back to how it was, and so then sitename.com/wordpress worked fine.

    Here's where I think I screwed up. I changed the WordPress URL to http://www.sitename.com, minus the (/wordpress), and got a huge 404 page not found error. Went back and tried to change it, and now everything seems to be gone - changed it back and hit save, and got 404 page not found. Went back a page, and tried to go to the other pages in my Dashboard, and everything just takes me to 404 page not found.

    Help!

    The link reference that i'm having issues with is:

  16. kmessinger
    Volunteer Moderator
    Posted 1 year ago #

    @montwin67
    Read the post directly above yours.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.