WordPress.org

Ready to get started?Download WordPress

Forums

404 on subcategory link (4 posts)

  1. Anonymous
    Unregistered
    Posted 5 years ago #

    Hi,

    I've got a Subcategory, "Apples" in a main Category, "Fruit" and using the permalinks thus: /%category%/%postname%/
    The Subcategory shows up on the main page correctly, with the link
    http://www.site.com/fruit/apples/
    which is good. Except that it returns a 404 when I want it to go to a page with a list of the posts in that subcategory. If I click the Category "Fruit" on the front page, the link is
    http://www.site.com/fruit/
    and I am taken to a page with a list of the posts in the "Fruit" category, which is the behavior I'm after. (I also want it to show me the Subcategories broken out by sub, but one step at a time...)

    I've surfed this forum for answers, but none seem to be quite addressing this issue.

    many thanks,
    Richard

  2. Anonymous
    Unregistered
    Posted 5 years ago #

    Hi, this basically means that you do not have any posts in these categories.

    To add a post to a certain category, choose create new post, and make sure you select the proper category.

  3. jonisolis
    Member
    Posted 5 years ago #

    I am getting a 404 for a subcategory link, but I checked and I do have 3 posts listed under that category (child/subcategory).

    domainname.com/category/marketing-tips/blogging/
    main category is "Marketing Tips" and the subcategory is "Blogging"

    when I click on the "Blogging" child/subcategory link I get
    Sorry, Page Not Found but...

    Any idea why and how to fix it?

    I have WordPress 2.7

  4. fabianv
    Member
    Posted 5 years ago #

    I have the same problem as jonisolis. If I access a subcategory through my url structure of /%category%/$postname%/ I get 404, wasted 3 days on it, tried everything.

    Im losing my mind

Topic Closed

This topic has been closed to new replies.

About this Topic