WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] 404 on post permalink only, *not* pages (2 posts)

  1. iangeek
    Member
    Posted 1 year ago #

    OK, this is driving me kind of insane now, so any input would be appreciated.

    The background: Site has been up and running for a few months now with pages, custom theme based on Automattic's Underscores, WP-Ecommerce and a few other well-proven plugins. Nothing crazy, nothing outrageous.

    The problem: Permalinks on posts have recently started 404-ing. Pages are fine, but aside from the primary blog listing page the blog permalinks are not playing ball on any setting aside from the default.

    I'm fairly well versed with WordPress, and have done all the usual tests - specifically:

    - The standard plugin witch-hunt
    - Template switch
    - rewrite_rules table flush
    - .htaccess regeneration
    - Default permalink structure (which works as it should)

    The site is running a tad slow, but that's down to the shared hosting - I've checked that avenue also and am happy that isn't the problem. I could update to 3.5, but I've just had to roll back to 3.4.2 for a couple of clients as there seem to be some buggy aspects still so don't wish to do that. Particularly as the problem has only just manifest after working fine.

    Page in question is http://www.honeywellbakes.com/blog/

    Anyone got any thoughts?

  2. iangeek
    Member
    Posted 1 year ago #

    Ah, the power of the post....

    OK, resolved on the off-chance anyone has similar. My client had removed the store shortcode from their shop page for Christmas closure, which for some reason meant all hell seemed to be breaking loose in the permalink department. Added this back in and all is back to normal. Not quite sure on the logic there, but resolved nevertheless.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags