WordPress.org

Ready to get started?Download WordPress

Forums

Sideways8 Custom Login and Registration
404 on multisite child site (2 posts)

  1. iltdevunit
    Member
    Posted 6 months ago #

    Hi,

    Great plugin. I've had everything working just fine using static IPs, but I'm having some issues now I'm using domain mapping.

    I used this tutorial to get things working:
    http://ottopress.com/2010/wordpress-3-0-multisite-domain-mapping-tutorial/

    Here's what I've done so far:

    • Installed WordPress 3.6.1
    • Enabled multisite with domain mapping
    • Installed the WordPress MU Domain Mapping plugin
    • Set up DNS entries of site1.domain.com, site2.domain.com
    • Added site1.domain.com in the domain mapping plugin's CNAME option
    • Checked 'Permanent redirect' and 'User domain mapping page'
    • Create site2.domain.com mapped to the correct site's id

    Everything works fine regarding the domains. If I go to site1.domain.com I end up at site1 and the same for site2.

    However, when in site2, if I click on register or login, I get the 404 "This is somewhat embarrassing, isn’t it?"
    The URL is:
    http://site2.domain.com/login/?redirect=http%3A%2F%2Fsite2.domain.com%2F

    The login on site1 works fine.

    Interestingly, before installing the Sideways8 plugin, if I clicked on login/register when in site2, it would redirect to the login page on site1.
    According to the above tutorial, this shouldn't happen if remote login is unchecked.

    EDIT
    The redirect issue without the s8 plugin is no longer happening. Not sure why. But the 404 issue with the s8 plugin still exists.

    I'm stumped!
    Any ideas?

    http://wordpress.org/plugins/s8-custom-login-and-registration/

  2. iltdevunit
    Member
    Posted 6 months ago #

    How strange.
    I've done a network deactivate on the s8 plugin, then activated it at site level. Everything seems to be working!
    I'll continue to test :)

Reply

You must log in to post.

About this Plugin

About this Topic