WordPress.org

Ready to get started?Download WordPress

Forums

404 on ALL pages after updating WP (11 posts)

  1. JavierP3
    Member
    Posted 9 months ago #

    Hello,

    After updating to WP 3.5.2 everything seemed to work fine but the links to all the "Pages" on my site (not post) show a 404 when trying to enter. Posts work fine. What's wrong? My site is now completely broken and can't figure out how to fix it.

    The pages are still on the CMS, with the content and links OK, it's just when I enter any page it shows a 404 instead of the content, even though the link is fine.

    I disabled all plugins and tried with different templates, same result.

  2. esmi
    Theme Diva & Forum Moderator
    Posted 9 months ago #

    Have you tried setting your permalinks back to the default setting?

  3. JavierP3
    Member
    Posted 9 months ago #

    Yes, same result.

    I also tried creating new pages with new urls and nothing...

  4. esmi
    Theme Diva & Forum Moderator
    Posted 9 months ago #

    Site url?

  5. JavierP3
    Member
    Posted 9 months ago #

    http://www.sanpersport.com

    Should have said it on the first post, sorry :)
    And thanks for your help.

  6. esmi
    Theme Diva & Forum Moderator
    Posted 9 months ago #

    What is in your root .htaccess file?

  7. JavierP3
    Member
    Posted 9 months ago #

    ## Default .htaccess file

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>

    # END WordPress

  8. esmi
    Theme Diva & Forum Moderator
    Posted 9 months ago #

    That looks fine. Can we see the site using the default permalink structure?

  9. JavierP3
    Member
    Posted 9 months ago #

    If I change the permalinks to the ?p=ID type, they work, the moment I change them to /post-name/... 404.

    Please help.

  10. JavierP3
    Member
    Posted 9 months ago #

    Tried with a few new .htaccess files I found to fix this same problem with no luck at all.

    It seems that there are a lot of people having this very same problem.

    Anyone knows how to fix it?

  11. ubaidullahbutt
    Member
    Posted 9 months ago #

    I have faced the problem on all my sites 2 weeks before when I was moving VPS to dedicated.

    What I did, backup the htaccess on my laptop and then delete the file from root, then visited Settings -> Permalinks, set the permalinks to default and update.

    Then again set the permalink to post_name and update.

    All URLs were working for me. Let's see it will work for you or not. Comment if not works for you.

Reply

You must log in to post.

About this Topic