WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] 404 on all newly created network sites (18 posts)

  1. Michael Fields
    Themer
    Posted 4 years ago #

    Hi,
    I'm working on revamping my website and want to use the multisite functionality in 3.0 but this is new to me as I never really got my feet wet with MU before the merge. I installed WordPress 3.0 to web root and the "main blog" appears to be working fine. I've tried to create 3 other sites on the network, but each time that I do, I get a 404 error when trying to view the live site or the backend. Please see the following links: http://mfields.org/test/ - http://mfields.org/test/wp-admin/

    I've tried installing + configuring WordPress twice following the directions to the "T" and the same thing happens each time. I am on shared hosting and and using the "directory structure" method with no domain mapping.

    Any insight into why this is occurring would be greatly appreciated.

    Thanks!
    -Mike

  2. Subfolder blogs work on the basis of mod_rewrite reading the htaccess file.

    If they don't show up, the file is not being read. On shared hosts, just tell support you're making changes to the htaccess file and it's not showing up.

    (please note the codex page on creating a network noted this in the "before you begin" section)

  3. Michael Fields
    Themer
    Posted 4 years ago #

    andrea_r,
    Thanks for the fast reply. I'm on the phone with support right now. and I think that your right with the .htaccess being the root of the problem. What is the bare minimum code that should appear in .htaccess? I don't seem to have enough in there. Also permalinks are not working on my main blog: http://mfields.org/. Here's what it looks like: http://wordpress.pastebin.com/Mh470EuW

    Thanks!

  4. worldblogosphere
    Member
    Posted 4 years ago #

    Not sure if this might help, but since you mentioned permalinks I will share an issue I have and how I fix it just in case it might help.

    I setup the permalink structure to something other than the default. Mine is set as /%post_id%/%category%/%postname%/ and is set to that on all new sites.

    When a new site is started it gives a 404 not found error for between 72 and 96 hours if I do nothing. If I sign into the dashboard of the new blog site however and go to the permalinks page and simply click the Save button it fixes the problem and the site and all its links show instantly.

  5. Michael Fields
    Themer
    Posted 4 years ago #

    worldblogosphere,
    Thanks, but I can't even get there :) In your htaccess file, do you have the 'normal' code the WordPress adds for "single site"? Mine does not.

  6. worldblogosphere
    Member
    Posted 4 years ago #

    No, I have never used the single site versions, always MU.

  7. Michael Fields
    Themer
    Posted 4 years ago #

    Would anyone be will to post an example of their .htaccess to pastebin? Not all of it just the bit pertinent to WordPress? If not, could you compare what's in mine to what is in yours and let me know if I am missing anything? I really think that I am because no permalinks are working.

  8. You can go get what's supposed to be in your htaccess file right in the tools -> Network menu.

    The fact that the regular permalinks aren't working is a huge clue. they shoudl work even before you do anything with the network.

  9. Michael Fields
    Themer
    Posted 4 years ago #

    You can go get what's supposed to be in your htaccess file right in the tools -> Network menu.

    Great! but it's exactly the same as what is currently in my ,htaccess file :( Oh, well.... I have verified that the file is being read by the server though.

    On another note, the codex article said that I should remove define('WP_ALLOW_MULTISITE', true);. This will romove the tools -> network link from the admin menu. Just thought that I would bring this up.

    The fact that the regular permalinks aren't working is a huge clue. they shoudl work even before you do anything with the network.

    I thought that this was strange as well. To be honest, I never setup permalinks, WordPress did this automatically somehow, when I went to tools -> permalinks to set them up, they were already set to "Day and name". Changing them to default seems to enable the main blog to work, but all of the children are still hidden.

    Thanks for your help.
    -Mike

  10. Click on the htaccess tag on the side of this forum thread. that'll bring up other threads tagged with the same and I am certain many (many) people have posted what there htaccess file contains when running a network.

  11. Michael Fields
    Themer
    Posted 4 years ago #

    @andrea_r,

    Just did that and it looks like my .htaccess contains exactly what it should. A few questions:

    1. Should WordPress automatically change my permalink settings after I enable multisite?

    2. Does multisite expect that I have permalinks set up before activating?

    I've just reinstalled with a fresh download and clean database and have had no luck... one more time :)

  12. Michael Fields
    Themer
    Posted 4 years ago #

    Ok,
    I think that it is up and running after about 5 attempts :)
    On my last update attempt, here are all of the steps that I took to resolve:

    1. Delete all WordPress files from ../public_html/
    2. Delete all WordPress tables from my database.
    3. Upload fresh files.
    4. Install WordPress.
    5. *Manually choose "Day and name" permalink structure.
    6. Set up multisite following the instructions.
    6.1. *Before uploading the modified .htaccess file, I changed the permissions on the live copy to 777. After I uploaded the modified version, I changed the permissions back to 644.

    Hope someone finds this useful,
    -Mike

  13. esason
    Member
    Posted 3 years ago #

    Hi

    I am trying to get my network work ,but no luck ,i have followed all the steps and even installed every thing from scratch on a clean Linux machine ,I am able to create new sites but I am unable to access them , I get the page not found error message .
    Am i missing something ?

    Thanks Eliad

  14. Yes.

    your htaccess file is not being read. Put

    AllowOverride FileInfo Options

    in the httpd.conf file.

  15. esason
    Member
    Posted 3 years ago #

    Hi

    Thanks for the quick respond

    I am new in the field ,can you please tell me where should I put this line ?

    Thanks

  16. esason - If you're being hosted, ask your WebHost to do that. If you're doing it yourself (like you have full root access to the server), just open the file and look for the AllowOveride section (search the file, it'll be there, even if it's commented out).

  17. orebaughse
    Member
    Posted 3 years ago #

    I am having a similar issue. I use Godaddy shared hosting w/ windows and do not have a htaccess file so I followed other directions from the forum and created a web.config file to add the rules text. I was able to add sites to my network but when I try to access the dashboard on one of my added sites i get a 404 error.

  18. orebaughse - You're using WINDOWS.

    Make a new topic please, cause that makes it a whole new ball of wax :/

Topic Closed

This topic has been closed to new replies.

About this Topic