WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] 404 Not Found Eror when saving post with hyperlink added (21 posts)

  1. taffyc
    Member
    Posted 3 years ago #

    Hi There,

    This just started happening to me today. When I create a new post I can enter content and save fine (I haven't published yet) but when I add a link (any kind - internal or external) when I try to save the page redirects to one with a URL of:

    My URL/wp-admin/post.php

    And I get this message on the page:

    404 | Page Not Found!
    Sorry, but the page you were looking for is not here.

    When I go back to the previous page I am returned to the post-writing page and the link has not been saved.

    I've tried logging out and back in, clearing browser cache, etc but no change. I can save any changes fine - just not links.

    I've been running this site for years and have never seen this problem. Any clues appreciated!

    Thanks .... TC

  2. esmi
    Forum Moderator
    Posted 3 years ago #

    Have you tried:

    - deactivating all plugins to see if this resolves the problem. If this works, re-activate the plugins one by one until you find the problematic plugin(s).

    - switching to the Twenty Ten theme to rule out any theme-specific problems.

    - resetting the plugins folder by FTP or PhpMyAdmin. Sometimes, an apparently inactive plugin can still cause problems.

  3. taffyc
    Member
    Posted 3 years ago #

    Thanks esmi. I tried everything you mentioned except resetting the plugins folder - not sure how to do that with FTP? Deactivating plugins and switching the theme to Twenty Ten didn't make a change.

    A new piece of data I've discovered. If I write only a short post with a few links everything works OK, but once I go beyond a certain number of links it starts to happen. I'm not sure exactly how many but the limit seems to be 4 or 5 links. I haven't written a long post for a while so I can't be sure when this started to happen.

    I've also tried increasing PHP memory to 128M but no improvement.

    I'm wondering if this is possibly a WP 3.13 issue?

    Appreciate any further thoughts.

    Thanks ... TC

  4. esmi
    Forum Moderator
    Posted 3 years ago #

    not sure how to do that with FTP?

    Please see the link I gave above.

    I'm wondering if this is possibly a WP 3.13 issue?

    No - this appears to be specific to your site.

  5. taffyc
    Member
    Posted 3 years ago #

    Thanks esmi. Tried that and no change. I've opened a support ticket with my server host to see if they have any input.

  6. taffyc
    Member
    Posted 3 years ago #

  7. Viktor Nagornyy
    Member
    Posted 3 years ago #

    Hey thanks for letting me know.
    Can you list plugin that you use? Maybe we can cross-match and identify what plugins might cause that. I got a live site and can't deactivate them.

    Thanks,
    Viktor

  8. taffyc
    Member
    Posted 3 years ago #

    I have deactivated all my plugins and still have problem.

  9. Viktor Nagornyy
    Member
    Posted 3 years ago #

    Who is your hosting provider and do you use CloudFlare by any chance?

  10. esmi
    Forum Moderator
    Posted 3 years ago #

    Seems like a related topic here

    The issues are quite different & unrelated. Have you tried resetting the plugins folder by FTP or PhpMyAdmin yet?

  11. taffyc
    Member
    Posted 3 years ago #

    esmi - yes - I reset the plugins folder with FTP exactly as per your link

  12. Viktor Nagornyy
    Member
    Posted 3 years ago #

    The issues are quite different & unrelated. Have you tried resetting the plugins folder by FTP or PhpMyAdmin yet?

    That's exactly what happened to me, but I wrote it up differently in the forum.

  13. taffyc
    Member
    Posted 3 years ago #

    viktorix - re webhost. No - I am on a liquidweb VPS

  14. taffyc, have you looked at mod_security? You can ask Liquidweb to set it to allow WordPress through it, and that may help. I had the same problem ages back.

  15. esmi
    Forum Moderator
    Posted 3 years ago #

    Wow - they must have the servers tied down tight if a single link creates a problem! The other poster's issue looks more like a server problem. It's intermittent - and possibly random (?) - for a start

  16. taffyc
    Member
    Posted 3 years ago #

    lpstenu - thanks - they suggested modifying wp-admin/post.php to exclude mod_security rule id 300015

    Is that the same as what you are suggesting? Or should they be tweaking the server settings??

    esmi - they do seem to be pretty security conscious.

    Thanks ... TC

  17. esmi - It's ... not the single link, it's a word in the link, and .. yeah, they do ;) Spent a week agonizing why the word 'FROM' killed me.

    taffyc - Are you sure they said to modify the post.php file and not to edit the mod_security rule to exclude post.php? That's what we did on my box.

    I edited /usr/local/apache/conf/modsec2/whitelist.conf to have this:

    ## WordPress
    <LocationMatch "/wp-admin/post.php">
    SecRuleRemoveById 300015 300016 300017
    </LocationMatch>
    <LocationMatch "/wp-admin/admin-ajax.php">
    SecRuleRemoveById 300015 300016 300017
    SecRuleRemoveById 300013
    </LocationMatch>
    <LocationMatch "/wp-admin/page.php">
    SecRuleRemoveById 300015 300016 300017
    </LocationMatch>
  18. taffyc
    Member
    Posted 3 years ago #

    Thanks a bunch - I have asked them to make this change. I guess I should figure out how to do this for myself.

    Question - with these changes did you stop seeing wp security issues? I have another problem which comes up sometimes when using the flash media uploader - I see a red "HTTP Error" when I'm trying to upload. But only from some browsers. I seriously love the liquidweb service and support but this wp security on their servers is a bit like peeling back an onion.

  19. taffyc
    Member
    Posted 3 years ago #

    Ipstenu - those changes did the trick perfectly - thank you SOOO much!! They also whitelisted Shockwave Flash user-agent for wp-admin/async-upload.php to kill my flash media uploader "http Error" problem.

    TC

  20. esmi
    Forum Moderator
    Posted 3 years ago #

    esmi - It's ... not the single link, it's a word in the link

    Ah! Now I understand. Thanks.

  21. Mod_security is my nemisisis. ;)

    They also whitelisted Shockwave Flash user-agent for wp-admin/async-upload.php to kill my flash media uploader "http Error" problem.

    Now that's a fix I'm saving in my bag 'o tricks! I only have the problem from work (where my firewall doesn't like flash).

Topic Closed

This topic has been closed to new replies.

About this Topic