WordPress.org

Ready to get started?Download WordPress

Forums

Subscribe2
[resolved] 404 message when trying to subscribe (3 posts)

  1. newbiewriter
    Member
    Posted 1 year ago #

    Noticed we hadn't had any new subscribers lately to the blog and then started receiving emails from people trying to subscribe.

    I verified this too by entering in an email. Once you hit subscribe it gives me a 404 message. My site is: Newbie Writers

    For some reason it directs me to http://www.newbiewriters.com/subscribe (which doesn't exist.

    Two things have changed recently: new theme and installing Jetpack.

    What I can't understand is why Subscribe2 is redirecting to ./subscribe. What is it meant to point to? I can't find any setting or file that outlines the "check your inbox" message.

    I have noticed that even though it gives the 404, it sends the email anyway but it ends up in the spam folder.

    Any suggestions?

    http://wordpress.org/extend/plugins/subscribe2/

  2. mattyrob
    Member
    Plugin Author

    Posted 1 year ago #

    @newbiewriter,

    You have a link to the /subscribe/ page in you sites footer so I suspect it has existed at some point.

    You need to change where Subscribe2 directs to in the Plugin settings at Subscribe2->Settings under the Appearance heading. There is a dropdown of pages on your site, change to one that contains the Subscribe2 form (currently this looks like it's your About page)

    If you use the Widget you need to do the same in the Widget settings.

  3. newbiewriter
    Member
    Posted 1 year ago #

    Thanks! All sorted out.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.