WordPress.org

Ready to get started?Download WordPress

Forums

404 in preview, write post problems (6 posts)

  1. tvsnacks
    Member
    Posted 7 years ago #

    1. I always seem to be getting "Error 404 - Not found" in my preview window (theme shows, main post does not). This did used to work at one point.

    2. Changing the size of the post window in Options makes no difference. It stays the same size.

    I did change the permalinks to %category%/%postname% and then back again but this doesn't seem to have done anything.

    I only have a few plugins installed: Autometa, Customised Post Listings, and Related Posts.

    Any ideas?

  2. tvsnacks
    Member
    Posted 7 years ago #

    Hmmm...I've now changed permalinks back to date/postname and preview is working again. This is on Apache 2.4...hmm...

  3. tvsnacks
    Member
    Posted 7 years ago #

    OK, here's what I think is happening. Somehow, WordPress is not updating the permalink when it previews the site. So if I return WP to the default permalink setup, the preview works. But if I change it to something else that should work (i.e. it's syntactically correct), preview breaks.

  4. tvsnacks
    Member
    Posted 7 years ago #

    While I'm the only one in here, I might also note that I used to have a thing for my sister.

  5. jabash
    Member
    Posted 6 years ago #

    I am having the same problem but I never met your sister.

  6. Drewminstry
    Member
    Posted 6 years ago #

    OK. I have no solution, but I have more information about the same problem.

    I can change settings to turn this problem on and off. But the off breaks a lot of other things.

    I describe my set up and the problem in replies 8 and 9 here:
    http://wordpress.org/support/topic/135854?replies=9

    Summary:

    With my setup described in the OP I have a working preview
    In options setting the Blog URL to: "http://ministryofmanipulation.com/blog"
    Custom permalinks name: "/%postname%/"
    it looks for the preview at:
    http://ministryofmanipulation.com/blog/?p=703&preview=true
    and finds it ok
    but that broke the admin "manage posts" link as described in other thread

    Changing to the later setup described in reply=8 of that thread fixed that admin manage link.
    But broke my preview! I cannot preview a blog post, or (pre)view an unpublished page.
    In options setting the Blog URL to: "http://ministryofmanipulation.com"
    Custom permalinks name: "/blog/%postname%/"
    it looks for the preview at:
    http://ministryofmanipulation.com/?p=703&preview=true
    Does not find it and defaults to index

    Suggestions?
    Thanks
    Drew

    ________________________________________________________________
    Here are 2 other threads which seem to describe the same problem as you have above, also with no solution:
    http://wordpress.org/support/topic/127363?replies=1
    http://wordpress.org/support/topic/102267?replies=2

Topic Closed

This topic has been closed to new replies.

About this Topic