WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] 404 everywhere after moving to new server (10 posts)

  1. stefanrechsteiner
    Member
    Posted 7 years ago #

    hi folks!

    i have moved my site to a new server (debian) ... it looks like everything is fine: http://www.macprime.ch/ticker/

    BUT - no, it isn't! :-( ... there is everywhere a 404 if you klick on a Link (Permalink, next-site-link, category-link, comment-link or or or ...) ... does anybody know a solution to this VERY HUGE problem?

  2. maerk
    Member
    Posted 7 years ago #

    Have you set up permalinks on your new server?

    Has the .htaccess file been updated on your new server?

  3. stefanrechsteiner
    Member
    Posted 7 years ago #

    yes - to both of your questions! :-/

  4. DJDannyS
    Member
    Posted 7 years ago #

    I'm having same problem i installed everything, was all running sweetly, went for some dinner came back tried loggin in again 404 errors all around!

    my site is djdannys.co.uk

    The path to log in is http://www.djdannys.co.uk/wordpress/wp-admin/admin.php

  5. moshu
    Member
    Posted 7 years ago #

    DJDannyS,
    You should start your own thread since your issue is absolutely not related to thsi topic.

    Seemingly, you were fooling around with the 2 URI values in the Options > General and now your blog doesn't work.
    Set the values back to the normal:
    http://www.tamba2.org.uk/wordpress/site-url/

    EDIT. There never was or is such a path:
    http://www.djdannys.co.uk/wordpress/wp-admin/admin.php
    Correct:
    http://www.djdannys.co.uk/wordpress/wp-admin/

  6. stefanrechsteiner
    Member
    Posted 7 years ago #

    ... :-/ ... can it be that my problem is also a db-problem?

  7. moshu
    Member
    Posted 7 years ago #

    It can be a server setting problem.
    Is mod_rewrite enabled? Is AllowOverride enabled? - Questions to ask from your host...

  8. stefanrechsteiner
    Member
    Posted 7 years ago #

    my host did now enabled mod_rewrite ... now it looks like everything works! ... which AllowOverride should be enable? http://httpd.apache.org/docs/2.0/mod/core.html#allowoverride

  9. Chris_K
    Member
    Posted 7 years ago #

    Since everything's working you can assume your host got the AllowOverride setup right too. :-)

  10. stefanrechsteiner
    Member
    Posted 7 years ago #

    hmm, he asked me which AllowOverride he should enable ... :-/ :-)

Topic Closed

This topic has been closed to new replies.

About this Topic