WordPress.org

Ready to get started?Download WordPress

Forums

Subscribe To Comments Reloaded
[resolved] 404 errors when subscribing without commenting (20 posts)

  1. caravan5
    Member
    Posted 3 years ago #

    I've noticed a lot of 404 errors in our Google Webmaster Tools reports for comment-subscriptions page.

    When testing the comment form, I'm getting a 404 error when clicking the link to subscribe without commenting.

    Any idea what I've done wrong?

    Thanks in advance

  2. camu
    Member
    Plugin Contributor

    Posted 3 years ago #

    What's the URL of your site?

  3. caravan5
    Member
    Posted 3 years ago #

    It's caravanguard.co.uk/news/

  4. camu
    Member
    Plugin Contributor

    Posted 3 years ago #

    Is the virtual management page enabled under the options?

  5. caravan5
    Member
    Posted 3 years ago #

    Yes it's enabled

  6. camu
    Member
    Plugin Contributor

    Posted 3 years ago #

    What's the value for the Management Page URL? Do you have any SEO plugins active?

  7. caravan5
    Member
    Posted 3 years ago #

    The management page URL is caravanguard.co.uk/news/comment-subscriptions (the one getting a 404)

    We have Platinum SEO plug-in running too.

  8. caravan5
    Member
    Posted 3 years ago #

    Just read the bit about the management page URL following permalink structure. Our permalink structure is custom and set to: /%postname%-%post_id%/

    Could this be the issue?

  9. camu
    Member
    Plugin Contributor

    Posted 3 years ago #

    Yes :) Try using /comment-subscriptions-9999999

  10. caravan5
    Member
    Posted 2 years ago #

    Sorry for delayed response - been out of the office for a week.

    Changing the management page URL to /comment-subscriptions-9999999 worked for me.

    Thanks for your help!

  11. camu
    Member
    Plugin Contributor

    Posted 2 years ago #

    Not a problem, thank you for the status update!

    A vote for my plugin would be a nice way to thank me!

    Camu

  12. fquiquet
    Member
    Posted 2 years ago #

    Hi Camu,
    I have the same issue
    I can't reach the Virtual administration Page !
    URL of my website is : http://www.unmondedaventures.fr

    When I click on the plugin link , I'm going to => http://www.unmondedaventures.fr/http:/www.unmondedaventures.fr/?page_id=9999999/

    My permalink structure is : /%postname%/
    Can u help me please ?
    thx in advance
    Cheers

    Fran├žois

  13. camu
    Member
    Plugin Contributor

    Posted 2 years ago #

    Change it to

    /manage-subscriptions/

    Best,
    Camu

  14. fquiquet
    Member
    Posted 2 years ago #

    it's not working . same error message :-(

  15. camu
    Member
    Plugin Contributor

    Posted 2 years ago #

    Well, then it may be a conflict with another plugin. You may want to try to create a "real" management page, as described in the FAQs.

    Camu

  16. fquiquet
    Member
    Posted 2 years ago #

    I have the WordPress SEO by Yoast Plugin !
    IS there a problem with this plugin ?
    Is there a workaround to resolve the issue ?

  17. fquiquet
    Member
    Posted 2 years ago #

    Now It's working by unchecking " Redirect ugly URL's to clean permalinks." in the WordPress SEO by Yoast Plugin

  18. camu
    Member
    Plugin Contributor

    Posted 2 years ago #

    Good to know! This will definitely be useful to other people!

    Cheers
    Camu

  19. David Radovanovic
    Member
    Posted 2 years ago #

    404 errors persisted until changed my url to /comment-subscriptions.html. Notice the the .html at the end? This is because of my permalink structure set at /%postname%.html. And, lastly I unchecked the "Redirect ugly URL's to clean permalinks." in the WordPress SEO by Yoast Plugin.

    Thanks for a great plugin... will vote for it right now.

  20. camu
    Member
    Plugin Contributor

    Posted 2 years ago #

    Thank you, I see more and more people are having problems with this specific step, so I'm working on completely redesigning the Management URL configuration process :)

    Best,
    Camu

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic