WordPress.org

Ready to get started?Download WordPress

Forums

404 Errors (all but Homepage) after Change to Post Name Permalinks (2 posts)

  1. Waup
    Member
    Posted 4 months ago #

    After changing permalinks, except for the homepage, all URLs now display:

    The requested URL /LOCALHOST/ExampleSite/index.php was not found on this server.

    Running on MAMP, WP 3.9... anyone experienced and solved this?

  2. nabil_kadimi
    Member
    Posted 4 months ago #

    Check that you have a .htaccess file, ifnot copy this one: https://codex.wordpress.org/htaccess#Basic_WP and place it in the root of your installation, next to index.php, wp-config.php, etc...

    Now that you have you .htaccess, try this:
    1- Re-save permalinks
    2- Check that your server has mod_rewrite enabled
    3- Check that your server allows overriding directives with .htaccess (it probably does if it has mod_rewrite enabled).

Reply

You must log in to post.

About this Topic