WordPress.org

Ready to get started?Download WordPress

Forums

404 Errors after upgrading to 2.7 (34 posts)

  1. Dave P.
    Member
    Posted 5 years ago #

    Just did the automatic upgrade to 2.7 and now all my pages are getting not found errors:

    http://www.davepit.com/

    Any ideas what may be the problem? It's not showing any posts, pages, etc.

  2. thisisedie
    Member
    Posted 5 years ago #

    Did you update your permalinks?

  3. Dave P.
    Member
    Posted 5 years ago #

    I did, just reverted back to 2.7 for now.

  4. Chijo
    Member
    Posted 5 years ago #

    I just upgraded from 2.6.5 to 2.7 and now get 404 errors on all pages and posts.

    Anyone discover a solution to this?

    I'm going back to 2.6.5 for now.

    thanks

  5. whooami
    Member
    Posted 5 years ago #

    I just upgraded from 2.6.5 to 2.7 and now get 404 errors on all pages and posts.

    Did you update your permalinks?

  6. Chijo
    Member
    Posted 5 years ago #

    By update, do you mean to set the permalinks the way I want them? Yes, it was actually setup the same as I had it in 2.6.5 but I went ahead and hit save changes.

  7. ktowson
    Member
    Posted 5 years ago #

    I am having the same problem too. Since upgrading all links to posts give 404 errors.
    I have tried editing and republishing posts, as well as manually changing permalink addresses, but the problem persists.

    I too am unclear about what you mean by 'updating' the permalinks. I also tried changing the format of permalinks to see if that would update them correctly, but with no luck. Help!!

    The site is:
    http://historyhelp.ca/blog/

  8. ktowson
    Member
    Posted 5 years ago #

    Changing the permalinks to the default setting appears to have fixed the problem but this is not an ideal solution as setting the permalinks to my preferred format - day and name: /%year%/%monthnum%/%day%/%postname%/ recreates the problem.

    If anyone can help this newbie figure this one out, I'll be forever grateful!

  9. gm10gm10
    Member
    Posted 5 years ago #

    There is nothing wrong with your upgrade. The same happens on a clean installation. LOOKS LIKE IT'S A BUG.

    http://wordpress.org/support/topic/228040?replies=1#post-934505

    GM

  10. mrmist
    Forum Janitor
    Posted 5 years ago #

    There is nothing wrong with your upgrade. The same happens on a clean installation. LOOKS LIKE IT'S A BUG.

    I'm not sure what draws you to that conclusion?

    I have a couple of 2.7 blogs that work perfectly fine with a /%year%/%monthnum%/%day%/%postname%/ structure (also shown as day and name).

    I think more info is needed really. What sort of hosting setup is it? Windows or Linux? Is there a .htaccess file in the root directory that could be conflicting?

  11. gm10gm10
    Member
    Posted 5 years ago #

    This is a Linux server.

    There is no .htaccess in the root directory.

    Thanks.

  12. gm10gm10
    Member
    Posted 5 years ago #

    If it of any help. I checked error_log file in the root directory. It has a record repeated many times:
    --------------------
    [22-Dec-2008 15:18:51] PHP Warning: PHP Startup: Unable to load dynamic library '/usr/local/lib/php/extensions/no-debug-non-zts-20060613/pdo.so' - /usr/local/lib/php/extensions/no-debug-non-zts-20060613/pdo.so: cannot open shared object file: No such file or directory in Unknown on line 0
    ---------------------
    Unfortunately I know nothing about Linux and servers to go any further with troubleshooting.

  13. MichaelH
    Member
    Posted 5 years ago #

    gm10gm10 - that would be a good reason to call your host.

    Also posting this related and unresolved thread for continuity:
    http://wordpress.org/support/topic/226591

  14. gm10gm10
    Member
    Posted 5 years ago #

    Michael,

    Thanks a lot for the help.

    gm

  15. MichaelH
    Member
    Posted 5 years ago #

    gm10gm10 - please let us know what your host says or report back any resolution.

  16. bilos
    Member
    Posted 5 years ago #

    It's amazing !

    I solved this problem manually :-)

    If you have access to your database, log to phpMyAdmin, then go to wp_options table and find permalink_structure .

    You just have to change the value by the structure that you want ( /%postname%/...)

    I hope it would solve your prolem

  17. bitterrootbob
    Member
    Posted 5 years ago #

    I am having the same problem with two sites. This is the last time I upgrade or I'm moving to Joomla. I'm tired of these problems about every two months.

  18. Samuel B
    moderator
    Posted 5 years ago #

    This is the last time I upgrade or I'm moving to Joomla

    so you think joomla doesn't do regular upgrades? :>)

    did you rest permalinks?
    admin - settings - permalinks

    or try generating a new .htaccess?
    http://codex.wordpress.org/Using_Permalinks#Creating_and_editing_.28.htaccess.29

  19. elizam
    Member
    Posted 5 years ago #

    I just upgraded a new blog (4 posts) to 2.7 last night from 2.6 and have a problem with custom permalinks, but mine is a little different. I have some javascript that sets up a random image in my headers.

    When I tried to change from default permalinks to /%category%/%postname%/ all my images in my header disappeared except on the homepage of my blog. My posts also came up 404 under categories, though showed correctly when clicked from the homepage.

    I was able to get posts and header images to reappear when I reverted to default and did a quick edit on all posts.

    Any suggestions on what could have caused that and what I can do to have both header images and permalinks working? That's so key to SEO, and I want to get it resolved before I have dozens or hundred of posts to manually reset.

    thanks,
    Liz M

  20. billhood
    Member
    Posted 5 years ago #

    I am having the same problem.

    I am using the Arthemia Premium Theme, with WP v2.7.1 at http://solutionsjournal.com. At the end of the articles or news posts, there is a "Related Post" section with several other articles mentioned. Although, when clicked on the user is presented with the following:

    Error 404 - Not Found

    Ooops, We cannot find you the page you are looking for. You may try to search our site for another keyword or use the navigational tools in this website.

    I cannot located where the problem might lie other than the link from the "Related Posts" do not include the "?" before the page number, i.e.

    http://universaldomainexchange.com/sjmsplash/p=394, which doesn't work versus http://universaldomainexchange.com/sjmsplash/?p=394, which does work.

    Where can I make the change that will add the question mark into the equation? I checked the Permalinks Settings and it is clicked to "Default" which shows the example with a "?".

    I tried changing the Permalinks to Day/Name and that doesn't work either.

    Any ideas? Thanks in advance,

    Bill Hood

  21. elizam
    Member
    Posted 5 years ago #

    Bill...thank you. You have no idea how much better I feel just knowing someone else is having the same problem. I will hope we get an answer soon.

    As far as your problem of the 404 persisting after you revert, I went through and did a "quick edit" on each of my posts (just clicked the update button) to reset it to the default, but then again, I only have a few posts.

    Liz

  22. elizam
    Member
    Posted 5 years ago #

    Sorry, Bill, I didn't read you correctly. I would suggest going to the option page for the related posts plugin and reentering your parameters, then saving them. That should force a "refresh" of the command.

    Liz

  23. andyfarmerboy
    Member
    Posted 5 years ago #

    I also got 404 errors on everything except the main and admin pages after moving from 2.7 to 2.7.1. However all I did to fix the problem is navigate to the permalinks settings page in the admin panel and change my custom permalink to the default –save changes, and then set it back to my custom permalink and again –save changes. This fixed it for me. Hope this helps.

  24. billhood
    Member
    Posted 5 years ago #

    Andyfarmerboy, what custom permalink did you use to make it work? I have not been successful so far.

    Elizam, what related post plugin are you using?

    Thanks, Bill

  25. billhood
    Member
    Posted 5 years ago #

    I went through a list of available "related posts" plug ins and none have been checked against WP v2.7.1 yet.

  26. elizam
    Member
    Posted 5 years ago #

    I was using "Related Posts" in other blogs, but I haven't activated it yet in this one. Still trying to get the permalinks and pictures thing worked out.

    AndyFarmerBoy, I wish it were that simple. I could set my custom permalink to /%category/%postname%/ as usual, and the post does show up correctly, but I lose the images in my header! When I reverted to the default ID, my images come back, but I get 404 errors all over until I go through and manually reselect the category of each of my posts.

    I need to start moving ahead with this blog. My previous version was 2.6 and I'm not sure how to rollback to it (or even if I could), but I'm really beginning to regret doing this upgrade.

    Any other suggestions, or do you guys know how to revert to a previous version?

    Thanks,
    Liz

  27. billhood
    Member
    Posted 5 years ago #

    Liz, you can simply ftp the previous version to overwrite the new version. But, that would not be advisable. It is far better to find a resolve for this problem and go forward, rather than giving up and going back.

    I am still looking for someone with an answer as to why my links do not have the "?" mark before the page number, i.e.

    http://universaldomainexchange.com/sjmsplash/p=394, which doesn't work versus http://universaldomainexchange.com/sjmsplash/?p=394, which does work.

    Does anyone know where can I make the change that will add the question mark into the equation?

  28. andyfarmerboy
    Member
    Posted 5 years ago #

    Andyfarmerboy, what custom permalink did you use to make it work? I have not been successful so far.

    I use the "Day and name" format selectable from the permalinks menu. All I did is change it from that to the “default” setting and then change it back.

    As for the rest of you still having problems I really don’t have any great suggestions. If you haven’t done so already I would make sure to disable all plugins, change the theme to the default, make sure all the wordpress files uploaded correctly and then see if you can get the permalinks to work. Once you have that fixed then switch back to your main theme, activate the plugins etc. This can be a big help if there is an issue with a theme or plugin.

  29. cridge
    Member
    Posted 5 years ago #

    Thank you so much Andyfarmerboy for posting your fix - it worked perfectly! I'm currently running WP 2.7.1 and last night I got a notice from within admin saying my SQL database needed to be upgraded. I proceeded to upgrade and when I came back, despite a long list of "WordPress database error: [MySQL server has gone away]" (which I'm assuming were just timeout errors) my database had upgraded successfully. THEN... I went to my site and found that only the homepage and admin could be accessed, all other links within the site were getting a 404. I freaked out and was on hold with my host when I found this thread. I simply went to "Permalinks" under the Settings menu, changed to "Default", saved, checked the site and everything was back to normal again! Then, since I don't want use the default structure, I went in to Permalinks again and changed it back to my preferred "Custom Structure": /%category%/%postname% Whalah! my site was back to normal. Thank you again!

  30. AlanthonyC
    Member
    Posted 5 years ago #

    I'm not sure know what it is that I did to fix my site, but I'll post the steps here in case it can help anyone:

    Baseline:
    - Brand new install, WP 2.7.1
    - Permalinks don't work although I know that mod_rewrite is on because my other blogs on my same server work. .htaccess has been updated and is pretty standard.

    My steps:
    1. Added "cat" and "tag" as the base values in permalinks. Save.
    1a - Checked it, still didn't work.
    2. Switched back to default links.
    3. Switched back to default theme.
    4. Switched on permalinks
    4a - Checked it, still didn't work.
    5. Switched back to my custom theme.
    5a - I may have checked my site and found it still didn't work.
    6. Signed onto phpMyAdmin and accessed (as in didn't do anything, just looked at) the wp_options table.
    7. Checked my site again - voila, it's working.

    So obviously, it may have been fixed by 5a, but it may have been fixed after step 6. I can't remember, but I don't see why just signing into the database would do anything.

Topic Closed

This topic has been closed to new replies.

About this Topic