WordPress.org

Ready to get started?Download WordPress

Forums

404 errors after changing permalinks (4 posts)

  1. Ben Dunkle
    Member
    Posted 6 years ago #

    Hi, I have a standard installation of the latest wordpress on my experimental site, and wanted to try "pretty" permalinks. Unfortunately, my links are broken now. I searched the forum and google, and followed the instructions here:
    http://www.squidoo.com/wordpress-not-found-error-fix

    but it doesn't work. I've put an httpd.conf in my public_html folder on my server with
    <Directory /public_html>
    Options Indexes MultiViews SymLinksIfOwnerMatch
    AllowOverride Options FileInfo
    </Directory>
    as I read something about maybe that would work, but no luck. Maybe I have the path wrong.
    I know this has been covered ad nauseam on this forum, but everything I've read is either too confusing or hasn't worked. Can someone help? Thanks!

  2. richarduk
    Member
    Posted 6 years ago #

    What parameters did you enter for the permalinks?

    I'd try and undo the htaccess and anything else and start from there

    If you have other mod_rewrite rules to include put them BEFORE WordPress's rules

    I think the standard htaccess is:

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>
    
    # END WordPress
  3. Ben Dunkle
    Member
    Posted 6 years ago #

    Richard,
    That did it. Thanks. Where did you get that code? I wonder why isn't there more documentation on it. I've tried literally dozens of "solutions" found here and on google, but nothing has worked until now.

  4. richarduk
    Member
    Posted 6 years ago #

    I just looked at the .htaccess that was produced by my site :-)

    Glad it worked

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.