WordPress.org

Ready to get started?Download WordPress

Forums

404 error,500 Internal Server Error & Fatal error: Out of memory in my wp!! (23 posts)

  1. B_Dark
    Member
    Posted 2 years ago #

    Hello,
    I moved my site from an American server to a European and since then when I open multiple pages from my site separately, example: 16 pages all opened the same time or sometimes when I upload external media or when I upload a photo to a post i get this message:

    1."Internal Server Error

    The server encountered an internal error or misconfiguration and was unable to complete your request.

    Please contact the server administrator, webmaster@site.com and inform them of the time the error occurred, and anything you might have done that may have caused the error.

    More information about this error may be available in the server error log.

    Additionally, a 500 Internal Server Error error was encountered while trying to use an ErrorDocument to handle the request."

    3. I get a Fatal Error messages. Some examples are dispalyed below.

    Fatal error: Out of memory (allocated 11534336) (tried to allocate 30720 bytes) in /home/site/public_html/site.com/wp-includes/comment.php on line 1412

    Fatal error: Out of memory (allocated 36175872) (tried to allocate 76 bytes) in /home/site/public_html/site.com/wp-includes/pomo/entry.php on line 43

    4. Also there are times that I click on page and when it loads it says that the page doesn't exist, this also happens when I create a post.

    i have "memory_limit = 256M"
    19 activated plugins
    and in my .htaccess this:

    suPHP_ConfigPath /home/site/public_html/site.com
    
    # BEGIN Better WP Security
    
    # END Better WP Security
    
    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>
    
    # END WordPress

    Does anybody know what all of these mean? and how i can fix it?!

  2. jonradio
    Member
    Posted 2 years ago #

    MichaelH provided the "official list" nearly a year ago in this post http://wordpress.org/support/topic/memory-exhausted-error-in-admin-panel-after-upgrade-to-28?replies=67

    1. If you have access to your PHP.ini file, change the line in PHP.ini
    If your line shows 32M try 64M:
    memory_limit = 64M ; Maximum amount of memory a script may consume (64MB)

    2. If you don't have access to PHP.ini try adding this to an .htaccess file:
    php_value memory_limit 64M

    3. Try adding this line to your wp-config.php file:
    Increasing memory allocated to PHP
    define('WP_MEMORY_LIMIT', '64M');

    4. Talk to your host.

  3. B_Dark
    Member
    Posted 2 years ago #

    If you see my post above you will see that I have more php memory. I tried the mark 3 and I think the problems with the "Fatal error: Out of memory" but I still keep having "404 Error" and "500 Internal Server Error"...

  4. jonradio
    Member
    Posted 2 years ago #

    Your post indicates you are sometimes dying on less than 12MB of memory:
    Out of memory (allocated 11534336)

    500 errors can also be the indirect result of memory errors, as they often indicate the "task" was canceled by your host's automated "process killer".

  5. ourweb
    Inactive
    Posted 2 years ago #

    This is your host problem

  6. B_Dark
    Member
    Posted 2 years ago #

    maybe they fixed 500 Internal Server Error but now it started to have every time that i try to enable some plugin or upload image or video in a post..

    503 Service Unavailable
    The server is temporarily busy, try again later!
    ________________________________________
    Powered By LiteSpeed Web Server
    LiteSpeed Technologies is not responsible for administration and contents of this web site!

    ?!?!?

  7. jonradio
    Member
    Posted 2 years ago #

    Even a casual search of "503" in this support forum indicates that a 503 is "always" an indication that your web hosting is not working properly: overloaded or some parameter or other not set big enough to handle all the usage of all their customers. More details on a 503 here:
    http://www.checkupdown.com/status/E503.html

    My advice is to find a new web hosting company, and try and get a refund from this one.

  8. ourweb
    Inactive
    Posted 2 years ago #

  9. jonradio
    Member
    Posted 2 years ago #

    It just took 3-5 minutes to get your host's home page to respond. If they can't even get their own site to respond, they are hardly capable of providing reliable fast service to their customers.

    This confirms my previous advice: move to another web host.

  10. ourweb
    Inactive
    Posted 2 years ago #

    @adiat Arbers?

  11. jonradio
    Member
    Posted 2 years ago #

    Yes, Arbers. I just tested it again and their home page is still painfully slow.

  12. ourweb
    Inactive
    Posted 2 years ago #

    @adiant, thanks, what kind pipe are you on? maybe it is the chat? we are using wp supercache too

  13. jonradio
    Member
    Posted 2 years ago #

    I am on "Broadband 100" with 100Mbps download and 5Mbps upload. I tested other sites at the same time as I was waiting for Arbers, and they all responded more or less instantly.

    I found that a free account on Pingdom.com really opened my eyes as to what my site visitors were seeing, in terms of response time.

  14. ourweb
    Inactive
    Posted 2 years ago #

    So you really didn't goto the site? You just did a Pingdom test?

  15. jonradio
    Member
    Posted 2 years ago #

    No, I tested from my browser at home. Typing http://arbershosting.com

  16. B_Dark
    Member
    Posted 2 years ago #

    @ourweb Yes I tried it too and it is too slow.

  17. Tim S
    Member
    Posted 2 years ago #

    Remember, that load times can be directly related to your location in relation to the actual servers. I tested the site and it loads fine. However, I've found a few tools I like to use to test:

    http://gtmetrix.com

    http://just-ping.com

    At any rate, the hosts site is immaterial to your issue. You may be updating the wrong php.ini file. It needs to be set to be recursive or it will only affect the folder it's in. Also, can you provide a link to your website so we can troubleshoot it further for you.

  18. B_Dark
    Member
    Posted 2 years ago #

    Awstats this month says that I have average 340-780 unique visitors per day.
    Google said for this month that I had average 110-170 unique visitors per day and my highest for one day was 490 (And I didn’t have a single problem or maybe I didn’t notice anything)
    I can understand that my site is getting evolved and it has more requirements now, so more or less I must my hand in my pocket, but it doesn’t even let me activate or deactivate or save some settings of a plugin(trying to do some optimization) …. I see that this moment I have 4 visitors(including me) at the and 4 bots and when I try to any of the above I get this:
    503 Service Unavailable
    The server is temporarily busy, try again later! Powered By LiteSpeed Web Server
    LiteSpeed Technologies is not responsible for administration and contents of this web site!
    This isn’t logical.

    the setup is
    Intel(R) Xeon(R) CPU E5506 @ 2.13GHz/24GB ddr3
    CloudLinux Server release 5.7 64 bit/litespeed webserver
    I have a reseller host and the told me that I have 25 concurrent connections and 1GB of memory 1GB of memory per account

    But in my Cpanel on the Stats tab
    Memory Usage 2097152 KB=2gb
    Entry Processes 30

    Do I see something weird or I am wrong?

    Also see my Current Usage CPU Usage from yesterday.

    Part1

    Part2

  19. jonradio
    Member
    Posted 2 years ago #

    I think you missed the most important word in the web hosting that you currently have: SHARED. Which means what you (i.e. - your total workload) do is not what matters. It is what everyone who shares that same web server does.

    The charts you showed me in the Part 1 link "cry out" the answer: the processor is so highly utilized (almost all the time) that there is no chance of getting reasonable response time.

  20. B_Dark
    Member
    Posted 2 years ago #

    hello again aftes 1 month

    Again I have problem...when am going to apply or save the setting of a plug in or when am going to publish or save as a draft a post I get same message:
    503 Service Unavailable

    The server is temporarily busy, try again later! Powered By LiteSpeed Web Server
    LiteSpeed Technologies is not responsible for administration and contents of this web site!

    Also it takes a lot of time for my site load. It doesn't load the virtual editor of the post. And the only thing that my hosting provider suggests to optimize my site(But, I already use plug ins (CloudFlare,W3 Total Cache, WP Smush.it & WP Smush.it NextGEN Gallery Integrationor) in order to optimize my site) to move to a Cloud server. What do you think about that? Should I move to a Cloud server or use CDN to my current reseller account or move to new host? Also, does the problem really starts from me or my hosting has done a lot of overselling? Please suggest me anything that will be useful for my problem and if it's necessary to give you some information(That I might have forgot to mention) to help you understand.

    My last 7 days from Resource Usage Details

  21. @B_Dark said:

    ...or move to new host?

    Move to a new host.

  22. B_Dark
    Member
    Posted 2 years ago #

    @songdogtech
    And what do I have to look to a new hosting provider so I won't go through the same thing?

Topic Closed

This topic has been closed to new replies.

About this Topic