WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] 404 error - wp-login.php was not found on this server. (13 posts)

  1. sharon lee
    Member
    Posted 6 years ago #

    Hi

    I have recently upgraded to WP 2.5.1 which went without a hitch.

    I then began to play around with permalink structures, htaccess and php.ini. It was all working fine until I decided to change the url in the general settings from http://mydomain.co.uk/wordpress to http://mydomain.co.uk/. This then give me the the 404 error stating that wp-login.php was not found on this server!

    I am pretty new to WP so I hope I'm making sense here. I hope somebody can help me as I can't even login now so I am at a total stand still!

    Thanks in advance guys

  2. RosieMBanks
    Member
    Posted 6 years ago #

    Hey, there, Sharon. Did you follow the instructions here?

  3. sharon lee
    Member
    Posted 6 years ago #

    Hey Rosie:) yes I followed these intructions when I first installed. However, I can't even get to my admin panel now as it keeps throwing up a 404 saying wp-login.php cannot be found on the server.

    I've tried replacing wp-settings.php with a local copy - no joy :(

    WordPress content is located here /var/www/html/wordpress/ on my server until I am familiar with the application.

    I think the error is something to do with me writing a custom permalink: /index.php/%year%/%monthnum%/%day%/%postname%/

    I then changed the wordpress and blog URL to http://www.mydomain.co.uk - this seemed to throw something out but I cannot figure out what it is. Do you think it could be a DB error?

  4. sharon lee
    Member
    Posted 6 years ago #

    Is there any more info I can provide for somebody to try and help me? I am at a total stand still and trying to search for solutions but can't find anything:(

  5. kmessinger
    Volunteer Moderator
    Posted 6 years ago #

    What is the URL to where you actually installed WordPress?

  6. Samuel Wood (Otto)
    Tech Ninja
    Posted 6 years ago #

    It was all working fine until I decided to change the url in the general settings from http://mydomain.co.uk/wordpress to http://mydomain.co.uk/. This then give me the the 404 error stating that wp-login.php was not found on this server!

    You can't just put in whatever values you like for those. They have to be the correct settings.

    Read this:
    http://codex.wordpress.org/Changing_The_Site_URL

  7. sharon lee
    Member
    Posted 6 years ago #

    Hi kmessinger:)

    The url is http://cyonix.co.uk/wordpress/.

    I have since overwritten the wp-admin directory and a few of the root files from my local drive to the web server. Still not working. Ive also noticed that the styles and formatting have disappeared. I previously set the homepage as a static page and included the header, sidebar and footer.

    The error seemed to appear when I changed the wordpress url and wordpress blog in settings/general to http://cyonix.co.uk from http://cyonix.co.uk/wordpress...(silly of me I know :) I had also been playing about with permalinks and .htaccess - but it seemed to work fine at first.

    I do appreciate your input kmessinger - hope you can shed some light on this...

  8. sharon lee
    Member
    Posted 6 years ago #

    Hi Otto42 - I expected it was that but hadn't a clue where to start to fix the error manually. Thanks for that link - I'll take a look.

  9. kmessinger
    Volunteer Moderator
    Posted 6 years ago #

    This works http://cyonix.co.uk/wordpress/wp-login.php so try to login and fix your problem. Turn permalinks at least for now to default, correct your blog name and site.

  10. sharon lee
    Member
    Posted 6 years ago #

    Hi kmessinger - I tried to login but get a 403 error :(

    I am going to access the db through phpMyAdmin and try and change the url that way. I will let you know how it goes...

    Thanks

  11. sharon lee
    Member
    Posted 6 years ago #

    Can anybody tell me where to find the wp-content/cache folder?

    I followed this article to the bullet point :)
    http://codex.wordpress.org/Changing_The_Site_URL

    I managed to do everything apart from clear the cache (last point) as I couldn't find it.

    I can now view the blog (its not perfect but its there) but can't login as still getting a 403)

    http://cyonix.co.uk/wordpress/

    Could this have anything to do with not clearing the cache? Or could it be bacause the admin directory was overwritten with a local copy yesterday?

    I'm thinking it may be easier for me to re-install and but not over write the WP-content folder...

    Thanks

  12. sharon lee
    Member
    Posted 6 years ago #

    Well - what do you know!

    I just deleted the admin directory from the server and re-uploaded a local copy and I can now login to my admin dashboard! I think between resetting my URLS for wordpress and re-installing the admin directory worked wonders! Thanks to Otto42 for that excellent link (http://codex.wordpress.org/Changing_The_Site_URL ;)

    Phew - thanks so much for all your help guys . I'd be grateful if somebody can tell me where the wp-content/cache is still :) I'm sure you will be hearing from me in the not too distant future!

  13. strife
    Member
    Posted 5 years ago #

    You can't just put in whatever values you like for those. They have to be the correct settings.

    Read this:
    http://codex.wordpress.org/Changing_The_Site_URL

    this saved my life..um blog. I had the same issue as thread starter and could not solve the problem...followed the above guide to fix the issue and it worked perfectly.

    thank you so much for posting that link Otto42!

Topic Closed

This topic has been closed to new replies.

About this Topic