WordPress.org

Ready to get started?Download WordPress

Forums

Get Post List With Thumbnails
404 Error wp-content/plugins/get-post-list-with-thumbnails/ajaxhandlergplwt.js (12 posts)

  1. bizint
    Member
    Posted 2 years ago #

    First off...fantastic plug in. I use it everywhere, its brilliant.
    But I have a small problem.

    I've trawled my website using Screaming Frog and Xenu to find broken links etc... and the one big one left is a 404 page not found for this url:

    http://www.businessinteriors.co.uk/wp-content/plugins/get-post-list-with-thumbnails/ajaxhandlergplwt.js

    Its a link within most of my pages that isnt going anywhere...and I dont know how to fix it without removing the plugin...I think Ive got a few js conflicts that I'm trying to work through...this link is a start?

    Any ideas much appreciated

    http://wordpress.org/extend/plugins/get-post-list-with-thumbnails/

  2. alvaron
    Member
    Plugin Author

    Posted 2 years ago #

    James, It's related to the pagination beta function.

    If you are familiar to php, you can comment the call for the js on the plugin file.

    I'll be working on a permanent solution on the next week.

    Also you can download the last version,or even create this js file on the folder.

    The newer versions of gplwt brings this file on the download zip.

    Best regards

  3. bizint
    Member
    Posted 2 years ago #

    @alvaron Yes my pagination is broken too...only showing page 1 (wont click through to pages 2 ro 3) so hopefully that will that fix too.

    I'm not that familiar with php....just basic changes. My version of your plug-in is showing as 9.01 ..... the zip file download is also 9.01.....bit nervous about deleting and re-activating a new download of 9.01 because I dont want to lose all the news settings I've already downloaded so will wait for the update I think!

    "comment the call for the js" gulp.....I can make changes to php but not sure what to do... perhaps just changing editing some text in the php is do-able?

    Looking forward to getting the fix! Waaayy to deep to change now so many thanks!

    James

  4. bizint
    Member
    Posted 2 years ago #

    I dont know if this will work...but I'm going to download th zip file and place the ajazhandler file into my upload folder? Hope this will work? Is it that simple?...gulp

  5. bizint
    Member
    Posted 2 years ago #

    weird I'm looking in the file....now and the file is there...and I've just replaced it with the zipped file.../ajaxhandlergplwt.js in the zip file...so its def downloaded and in the get=post plug in folder.... does that mean its something else? I've got themlatest version 9.01 running....

  6. alvaron
    Member
    Plugin Author

    Posted 2 years ago #

    James,

    I'm sorry to say it must be a issue relate with plugin conflicts or your theme.

    On my site, using 9.0.1, the file is found http://www.wpworking.com/wp-content/plugins/get-post-list-with-thumbnails/ajaxhandlergplwt.js

    on other sites too:

    http://ballerwives.com/wp-content/plugins/get-post-list-with-thumbnails/ajaxhandlergplwt.js

    http://www.rockateca.com/wp-content/plugins/get-post-list-with-thumbnails/ajaxhandlergplwt.js

    If the file is on the plugin folder, maybe there's something on the theme or htaccess, because it's the first time somebody reports this issue.

    The pagination is a beta feature, so its not 100% ready to work...

    Are you using widgets or shortcodes?

    I can promisse a quit solution, we will have to take a good look on your case

    Best regards

  7. bizint
    Member
    Posted 2 years ago #

    Hi! I'm using widgets in the sidebars, not shortcodes...and using widget logic plug in to display on different pages...

    ....I have a sneaky suspicion widget logic is conflicting somewhere...I had a server 500 error that has since cleared up (think it was something to do with W3 Total Cache and Java minification or something which I've now disabled and now working)

    Mmm many thanks for helping clear up because I think my set up is pretty standard...

  8. alvaron
    Member
    Plugin Author

    Posted 2 years ago #

    James,

    There's a way to check if it is a conflict. You may disable the widget plugin and test gplwt working alone.

    Best regards,

    Alvaro

  9. bizint
    Member
    Posted 2 years ago #

    Hi @Alvaron,

    I disabled the Widget Logic plugin and its still showing as 404 not found that...still problem...

    Mmm...is it a case of going plug in by plug in...or can I look to see where the conflict is? I have no idea how the website can say 404 not found on a file that's so clearly there... mmm

    James

    [No bumping, thank you.]

  10. alvaron
    Member
    Plugin Author

    Posted 2 years ago #

    James,

    I think is the case of going plugin by plugin, since this error was never reported to gplwt.

    Best Regards

  11. bizint
    Member
    Posted 2 years ago #

    Hi Alvaron, I've gone plug in by plugijn....and also disabled all the plug ins except yours...and still when I trawl the site I get 100's of broken links to your js file....

    Its a little frustrating, because I know google doesnt link broken links...and I dont like any of my site not functioning spot on....this is very strange...could it be something to do with the installation not being root? I have it in a file below root called wp but the permalinks get rid of wp so its businessinteriors.co.uk/wp/your file rather than businessinteriors.co.uk/your file....

    So the actual real location of the file is in fact http://www.businessinteriors.co.uk/wp/wp-content/plugins/get-post-list-with-thumbnails/ajaxhandlergplwt.js Maybe your widget isnt picking up on the permalink structure or something?! I dont know....

    Cheers! (Also why is the thumbnail not showing...see that one at the top on the front page of my site?! thanks!)

    James

  12. bizint
    Member
    Posted 2 years ago #

    Right! Temporary fix...I created a folder at businessinteriors.co.uk/wp-content/get-post blah...and put the file in the folder...now the page is at least finding it in the location its looking....so temp fix! Still...any idea why that thumnail isnt showing?! on the left?!

    http://www.businessinteriors.co.uk thanks!

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic