WordPress.org

Ready to get started?Download WordPress

Forums

  1. marikamitsos
    Member
    Posted 1 year ago #

    Hello,
    We are trying out your plugin
    On a single site we installed, created an account, activated and pasted the CLOUDINARY_URL

    cloudinary://826344492135642:KxVyg7QZaH8pPaZeoyQrJO4Zcd8@n2543wer

    updated settings and went over to the library.
    What we get is

    Error
    We're sorry, something went wrong (error 400)
    Please try again.

    We keep on getting the same error even after updating the CLOUDINARY_URL.

    Btw, shouldn't the settings "stick"? Because when we hit the update button nothing seems to happen. Not even a message that the options are saved.
    Could this be the issue?

    http://wordpress.org/extend/plugins/cloudinary-image-management-and-manipulation-in-the-cloud-cdn/

  2. cloudinary
    Member
    Plugin Author

    Posted 1 year ago #

    Hi,

    Thank you for reporting this issue.

    First of well, please make sure not to paste your CLOUDINARY_URL in public pages like this one. This URL includes your private API Secret that should not be shared with anyone.

    The issue you described is caused before the CLOUDINARY_URL is not saved correctly in the Settings page.

    Can you please specify the versions of the Cloudinary plugin and WordPress you use?

    In addition, do you see any Javascript errors while saving your Settings? (e.g., in Chrome select 'Javascript Console' from the 'Developer' submenu of the 'View' menu)

    Thanks!

  3. haleeben
    Member
    Posted 1 year ago #

    I'm having the same problem.

    Cloudinary Version 1.0.2
    WordPress Version 3.5.1

    Add there is no Javascript errors showing in Chrome console when saving my url.

  4. cloudinary
    Member
    Plugin Author

    Posted 1 year ago #

    Hi,

    We are trying to reproduce this problem.

    Did you get any success message or error after clicking on the 'Update Settings' button? (sharing a screenshot would be great)

    In addition, can you please share the list of plugins or themes you use in your WordPress server?

    Thanks!

  5. cloudinary
    Member
    Plugin Author

    Posted 1 year ago #

    Hi,

    We wanted to update that this issue was fixed in v1.0.3 of the Cloudinary plugin.

    Please upgrade your plugin and verify that it works well now.

    Thanks!

  6. hakonzen
    Member
    Posted 1 year ago #

    Hi!
    Got much of the same problem.
    I updated to Cloudinary 1.0.3. Run MU on WP 3.5.1

    I have updated the CLOUDINARY_URL in settings, went to new post, clicked the Cloudinary icon, got this message;

    "Cannot connect to Cloudinary's Media Library
    Please verify that you have CLOUDINARY_URL defined correctly in the Settings page of Cloudinary's WordPress plugin.
    (Status 400, Missing required parameter - api_key)
    Please contact our support if you need any help."

    Went back to settings, updated again, got this message;

    "Congratulations! You can now open Cloudinary's media library to start managing your images.
    Use the new "Cloudinary Upload/Insert" option to embed photos into your posts directly from the cloud."

    Tried new post again, same error; status 400...

    When selecting the Cloudinary button in the dashboard left menu, I get a blank page, and the url is; http://digglitt.no/wp-admin/admin.php

    When pushing the Media Library button under Cloudinary, I end up with the status 400 message again.

  7. mcmikemn
    Member
    Posted 1 year ago #

    When selecting the Cloudinary button in the dashboard left menu, I get a blank page, and the url is; http://digglitt.no/wp-admin/admin.php

    I get this error, too. In my experience, a blank page (no source code - nothing!) usually means that PHP threw an error and prohibited anything from being sent to the browser. But I get no errors in my error log.

  8. cloudinary
    Member
    Plugin Author

    Posted 1 year ago #

    @hakonzen, @mcmikemn - Thank you for reporting this issue and sharing the details.

    We identified this issue. It happens in Multisite WordPress environments. Sorry about that.
    We are working on a solution and will update you when we have something ready.

    Thanks!

  9. cloudinary
    Member
    Plugin Author

    Posted 1 year ago #

    @hakonzen, @mcmikemn - Thanks again for reporting this issue.

    v1.0.4 of the plugin that was just released fixes Cloudinary's plugin for Multisite WordPress environments. It fixes both the 'blank page' issue and the non-saved settings.

    Please update to v1.0.4 and see that it works for you now (you might need to re-enter the CLOUDINARY_URL in the settings page).

  10. marikamitsos
    Member
    Posted 1 year ago #

    v1.0.4 of the plugin that was just released fixes Cloudinary's plugin for Multisite WordPress environments

    Well... I don't know what happens on a multisite but the issue seems to be fixed for a single site (where we test it).

    You should still do something though about the "success" message:

    Congratulations! You can now open Cloudinary's media library to start managing your images.
    Use the new "Cloudinary Upload/Insert" option to embed photos into your posts directly from the cloud.

    It makes no difference what you put on the settings page. The message is always displayed after an update. Even if you put:

    mama loves me and papa loves me too
    82ILOVEYOU92135642:DOYOU LOVEMETOO???@yesido

  11. mcmikemn
    Member
    Posted 1 year ago #

    Thanks for the fast response. I'm using WPMU and 1.0.4 did indeed fix the problem (if "fixing" the problem means removing the options page that caused the problem - it's no longer there - I hope it wasn't necessary or useful, because I don't have it any more :) ).

  12. cloudinary
    Member
    Plugin Author

    Posted 1 year ago #

    @mcmikemn: Sorry about that. The issue was related to permissions issues of the Multisite environment (administrator vs. super administrator).
    We've just released v1.0.5 of the plugin that solves this issue (Settings is available to each site's administrator).
    Can you please verify if it works for you now?

    @marikamitsos: Thanks for your feedback (and for the original examples :-). v1.0.5 of the plugin performs validations of the CLOUDINARY_URL being saved. We validate that the URL is of a valid format and that it passes the actual authentication to Cloudinary's service.

    Thanks!

  13. mcmikemn
    Member
    Posted 1 year ago #

    I'm not sure I understand what 1.0.5 does, but it does not break anything since 1.0.4. :) I noticed no change.

  14. cloudinary
    Member
    Plugin Author

    Posted 1 year ago #

    This issue was already fixed in previous versions of the plugin. Marking this topic as resolved.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.