WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] 404 error when adding new page or post... (17 posts)

  1. djwesterfield
    Member
    Posted 4 years ago #

    whenever i make a new post at: http://www.theowler.com and go to the site the new posts dont show up. when i go back to my dashboard i can see all my posts but when i want to "view" them i get a 404 error.
    and...
    i noticed if i even make another new page, it gives me the same error:

    Not Found: The requested URL /life/ was not found on this server. Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.

    any help please?

  2. Shane G.
    Member
    Posted 4 years ago #

    Hi,

    Set your desired permalink from wordpress admin area and add this code in htaccess of your blog/site:

    # BEGIN WordPress
    
    <IfModule mod_rewrite.c>
    ErrorDocument 404 /index.php?error=404
    RewriteEngine On
    RewriteBase /
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>
    
    # END WordPress

    Thanks,

    Shane G.

  3. djwesterfield
    Member
    Posted 4 years ago #

    where can i find the permalink page on my wordpress?

    do i make a .htaccess file in my wp-admin folder or where?

  4. djwesterfield
    Member
    Posted 4 years ago #

    hello?

  5. djwesterfield
    Member
    Posted 4 years ago #

    please, all i need is to find out how to do this and then i will be done with this blog and i can move on.

  6. brandnewaquarium
    Member
    Posted 4 years ago #

    WordPress automatically creates your .htaccess file. In order to edit it, on whatever SFTP/FTP client you're using, you'll need to enable view -> hidden objects.

    This page should help you further:

    http://codex.wordpress.org/Using_Permalinks

  7. djwesterfield
    Member
    Posted 4 years ago #

    so i made a .htaccess file in the folder(s) where my index.php file was with:

    # BEGIN WordPress
    
    <IfModule mod_rewrite.c>
    ErrorDocument 404 /index.php?error=404
    RewriteEngine On
    RewriteBase /
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>
    
    # END WordPress

    and i still havent gotten any of my pages/posts to post on the site :(

  8. djwesterfield
    Member
    Posted 4 years ago #

    any other code i need instead?

  9. djwesterfield
    Member
    Posted 4 years ago #

    pleaseee i really need this help. its the last thing i need to make the blog live.

  10. internalkernel
    Member
    Posted 4 years ago #

    I was banging my head against the wall for the past two days because of the same issue. I moved servers and every page underneath my domain was returning a 404 error. Very frustrating...

    In my case, it was an Apache directive in my virtual hosts file:
    AllowOverride FileInfo

    There is, of course, many reasons why you could get this error... that was the reason for mine. If you have control over that part of your server, you may want to check it again. Hopefully this helps...

    ( And the .htaccess should go in the root folder, the same folder as the wp-config.php file. Check the permissions on it as well. )

  11. bh_WP_fan
    Member
    Posted 4 years ago #

    Also make sure your Permalinks have been updated and saved. Settings > Permalinks (select the desired format) > Save Changes

  12. djwesterfield
    Member
    Posted 4 years ago #

    i'll check in a little bit about my host & Apache.

    but right now i dont see where my permalink settings are.
    i went to my settings and it just shows: Writing, Reading, Discussion, Media, Privacy, Delete Blog, OpenID, and Domains.

    i then looked through each one and none of them tell me about my permalink settings.

  13. Rev. Voodoo
    Volunteer Moderator
    Posted 4 years ago #

    you should have a menu called settings->permalinks

    default options in settings menu are, in this order:
    general
    writing
    reading
    discussion
    media
    privacy
    permalinks
    miscellaneous

  14. djwesterfield
    Member
    Posted 4 years ago #

    this is weird. i tried logging into wordpress on my office computer and it popped up with permalinks.

    well cool beans. it all works fantastically.
    all i did was go into my FTP and deleted my .htaccess file and it all worked.

    now my NEW problem is that my main page will be used for new posts, but i want people to be able to go into one of my other pages to read posts that i make for those specific topics once they leave my new posts.

  15. JeffreyPia
    Member
    Posted 4 years ago #

    Big thanks to bh_WP_fan and RVoodoo. I just ran into this issue today when restoring my wp db from backup. The Settings > Permalinks > Save Changes fix did the trick!

  16. gurubobnz
    Member
    Posted 4 years ago #

    Hi guys - my issue was quite different but seemed similar. Here were the symptoms:

    1. Moved WP site from host A to host B (including DB etc)
    2. Configured new username and password for mysql in wp-config.php.
    3. Went to home page, old posts showed, no new ones???
    4. Logged into back end, everything looked fine.
    5. Changed a post that was showing on the front page, no visible change.
    6. WTF / GOOGLE / HAIR PULLING / etc etc
    7. Discovered that there was an index.html file in my WP root that contained a static version of my site.

    I don't know how this index.html file got created, but the difference was that the DirectoryIndex order on host B listed index.html BEFORE index.php so it wasn't an issue on my old host.

    Hope this keeps the amount of global hair pulling to a minimum.

    Cheers,

    - Bob -
    http://www.guru.net.nz/

  17. Bart1977
    Member
    Posted 3 years ago #

    Thank you very much for this post, esp Shane G, your solution worked for me finally after a couple of hours of wrestling with this issue.

    ***** MANY THANKS!!! *****

Topic Closed

This topic has been closed to new replies.

About this Topic