WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] 404 error: sub-domain install (9 posts)

  1. idowu
    Member
    Posted 2 years ago #

    i am getting 404 error when i try enter my new sub-domain site dashboard,i.e, */wp-admin/ folder. everything appeared error at first; separates tables were created in the database, but the 'blogs.dir' is still empty. i have added 'options followsymlinks' to the start .htaccess file, as step 4 of 'create a network' indicates we may need to add that.
    my host confirmed to me that 'allow override all' is enabled on 'http.conf', and i have wildcard subdomain set.
    please i need clue into what may be wrong. may be it is with the 'wp-config.php' file.

  2. dgilmour
    Member
    Posted 2 years ago #

    I don't think you need to worry about blogs.dir being empty. That's where directories, identified by blog ID, get created to hold uploaded files. If you haven't uploaded any files for your blog, it may not have been needed.

    If you can get to the main site OK, but not the new sub-domain site, I'd check that the rewrite rules in your .htaccess file are correct and accessible (file readable).

  3. idowu
    Member
    Posted 2 years ago #

    ok dgilmour, thanks for the response.
    this is my .htaccess file 'as is' below:

    Options FollowSymlinks
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    
    # uploaded files
    RewriteRule ^files/(.+) wp-includes/ms-files.php?file=$1 [L]
    
    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule ^ - [L]
    RewriteRule . index.php [L]

    as an aside, im thinking of, may be, a plugin may fix the problem.
    thanks for the support.

  4. blogs.dir stays empty until you upload videos. No worries.

    If you have wildcard subdomains set correctly, try going to fakesubdomain.yourdomain.com

    If that DOES NOT redirect you to your real domain, you did it wrong.

  5. idowu
    Member
    Posted 2 years ago #

    yeah, it seems im getting more light. if i try 'anything.mydomain.com', it redirects to a 'cPanel' page, which first two lines read:

    Great Success !
    Apache is working on your cPanel® and WHM™ Server.

    so if this is where the problem lies, how do i fix it.
    thank you very much everybody.

  6. You didn't set up wildcards correctly. They need to point to the root HTML location of wherever WordPress is installed.

    I can't tell you exactly how to fix it, because I don't know what exactly you did wrong. It's in how you set up the wildcards, though, so look at that.

  7. idowu
    Member
    Posted 2 years ago #

    please, can somebody out there show me how i should point wildcards to the root html location of where i installed wordpress. i am a little bit frustated and confused. i need help. i have tried all i know through .htaccess, all to no avail. the wildcard keeps pointing cpanel page

  8. It's not in WordPress. This issue isn't even AT the point where it's WP yet.

    Use your eyes. Go in and look at the cpanel setup for your subdomain. It will tell you where the path is pointing.

    Does it say /public_html/ and ONLY THAT? If not, that's the problem.

    If you don't understand how to do that, contact your webhost.

  9. idowu
    Member
    Posted 2 years ago #

    thanks so much Ipstenu, i have OPENED my eyes, and I have SEEN and CORRECTED my mistake. i set the wildcard under DNS zone editor earlier ,which has no field for setting the path. i corrected myself by setting the wildcard subdomain under 'subdomains' menu.

    thanks for the time and patience

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.