WordPress.org

Ready to get started?Download WordPress

Forums

WordPress HTTPS (SSL)
[resolved] 404 error. Possibly related to permalink (2 posts)

  1. TecBrat
    Member
    Posted 2 years ago #

    I am working on this site: http://www.artisaninsurance.com/
    I want the contact page to be SSL It was "http://artisaninsurance.com/contact-us/"

    This is shared SSL so I set it up as https://secure.jhstudios.net/~artisa/

    When I have it enabled and click the nav button, It takes me to this URL https://secure.jhstudios.net/~artisa/contact-us/

    This looks right, but instead of displaying the contact us page, it displays a 404 message from my apache server. If I remove the "/contact_us" to make sure I have the server and username correct, it displays the site as well as would be expected since it is not properly invoking the plugin.

    I'll have to uncheck Force SSL until I get an answer so that my customer's page isn't broken.

  2. Mvied
    Member
    Plugin Author

    Posted 2 years ago #

    Hi TecBrat,

    This is generally an issue with Shared SSL and WordPress permalinks. Try going to https://secure.jhstudios.net/~artisa/contact-us/ without the plugin and I'm willing to be the page is still 404. If that is the case, you will have to disable pretty permalinks and use the default WordPress permalinks for it to work properly.

    Thanks,
    Mike

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic