WordPress.org

Ready to get started?Download WordPress

Forums

[closed] 404 error on 2nd page of blog after 3.4 upgrade (28 posts)

  1. mikaelajoy
    Member
    Posted 2 years ago #

    Hello, I just upgraded to the latest version of wordpress and now when I click through to go to the 2nd page of my blog (there are only 2 pages), I get a 404 error, page not found. I'm super new to wordpress, so not really sure where to even start looking to resolve this issue. Any help would be greatly appreciated!

    Thanks,
    Mikaela

  2. RichardWPG
    Member
    Posted 2 years ago #

    Do you have the most recent backup of your files?

  3. mikaelajoy
    Member
    Posted 2 years ago #

    I do!

  4. CptOVERLORD
    Member
    Posted 2 years ago #

    i have the same error, so guys what do you do with this problem?

  5. CptOVERLORD
    Member
    Posted 2 years ago #

    my problem is about:
    when i click on the 3rd page of my blog i get 404 error, i have 5 pages full of posts

  6. esmi
    Forum Moderator
    Posted 2 years ago #

    @CptOVERLORD: It is impolite and contrary to forum policy to interrupt another poster's ongoing thread with a question of your own. Please post your own topic.

  7. CptOVERLORD
    Member
    Posted 2 years ago #

    i would like to give a shot who has the same problem and who does not have the latest database export file:

    -keep .htaccess, wp-config.php, wp-content/plugins, wp-content/themes, wp-content/uploads
    -delete the other files
    -copy the old wordpress's files (and overwite the ones [for example: wp-contet/themes/index.php and so on] which already exists)

    Hey @esmi, you are right [,i was rude], but it is much easier for us to discuss a better solution for this problem.

  8. brazley
    Member
    Posted 2 years ago #

    a lot of things could be causing this.

    heres what i would try.
    1.go dashboard-settings-permalink and set permalink structure to posts name.
    2.go to the page or post thats not showing. click permalink edit ( just below your pages title)now clear everything from the box. click ok, then update.

    see if your page is showing properly now

    courtney
    :end

  9. mikaelajoy
    Member
    Posted 2 years ago #

    hi there! thank you for your response. the permalink structure is already on posts name...

    the issue is with clicking on "Next Page" to see the 2nd page of posts. if i click on the post links themselves (via categories, as that's the only way to see the posts that are beyond the 6 that are on the main page), i have no problem. but when I click "Next Page" or "2," I get the 404 error.

    thanks again!

  10. brazley
    Member
    Posted 2 years ago #

    can your provide a link to the site?

    courtney
    :end

  11. mikaelajoy
    Member
    Posted 2 years ago #

  12. brazley
    Member
    Posted 2 years ago #

    ok mikaelajoy

    i notice this url http://www.simplyemjoy.com/page/2/ is set as "2" and "next page" as you hover over them. does this page/post exist? is the permalink structure correct on the "page or post"?

    i also notice the other pages are displaying properly, but they have different urls.. ie. http://www.simplyemjoy.com/its-not-easy-being-green/

    some are also set under http://www.simplyemjoy.com/category/
    make sure you placed the page/post in the correct category also.

    also, can you define "next page" in your theme? id try that too.

    its hard to say without seeing the front end but id double check those things first

    hope this helps

    courtney
    :end

  13. mikaelajoy
    Member
    Posted 2 years ago #

    my theme is set up to display only 6 posts on each page and i have a total of 8 posts, so the subsequent pages should show on page 2/the next page.

    i don't know much about the wordpress platform and how it works, so i'm not sure where/when/how that page 2 is created, but it was working just fine on saturday before upgrading.

    i only placed each post in one category, and they are categorized correctly. the permalink is set to "Post name" under common settings ( http://www.simplyemjoy.com/sample-post/)

    the only option i have in the theme is to set up the navigation type (numeric, older/newer, previous, next)

  14. esmi
    Forum Moderator
    Posted 2 years ago #

    I'm sorry but as you are using a commercial theme, you need to seek support from the theme's vendors.
    http://www.studiopress.com/support

  15. mikaelajoy
    Member
    Posted 2 years ago #

    i see. thank you

  16. eduguytoo
    Member
    Posted 2 years ago #

    This is not a studio press issue this is WP issue, it happens from time to time there should be a patch out soon

  17. cmfcom
    Member
    Posted 2 years ago #

    I have the same problem. It's WP 3.4 that's causing the 404 errors on pages beyond page 1. My 404 error appears on page 4. Hopefully they'll have a fix for it soon, as it seems to be affecting a lot of people.

  18. mikaelajoy
    Member
    Posted 2 years ago #

    Oh that's good to know! Thank you, I'll keep my eyes up for a fix.

  19. babu_fu
    Member
    Posted 2 years ago #

    I have a problem to install wordpress ..
    it shows

    "Forbidden"

    You don't have permission to access /wordpress/wp-admin/setup-config.php on this server.

    Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request."

    How Can I solve it

  20. cmfcom
    Member
    Posted 2 years ago #

    babu_fu, I think you should make a new topic regarding your issue. It's not nice to hijack a thread.

    I found a solution to this issue. The solution comes from a previous topic.

    You need to add this to the theme’s functions.php file:

    function my_post_queries( $query ) {
    // not an admin page and it is the main query
    if (!is_admin() && $query->is_main_query()){
    if(is_home()){
    $query->set(‘posts_per_page’, 1);
    }
    }
    }
    add_action( ‘pre_get_posts’, ‘my_post_queries’ );

    It worked for me, and now my page 4 is showing up fine. Good luck!

  21. KennyThemap
    Member
    Posted 2 years ago #

    I have the same issue.

  22. growland
    Member
    Posted 2 years ago #

    I am also having the same issue. When I click NEXT PAGE on a category with more than one page I get a 404 error.

    If I use the default permalink structure it seems to work fine though but I want to use custom permalinks for SEO purposes.

    UPDATE: The issue seems to only happen when I use the /%category%/%postname%/ permalink structure and works with all other permalink structures.

    Anyone know a fix for this?

  23. KennyThemap
    Member
    Posted 2 years ago #

    I have a solution for at least some of you. I just started deactivating plugins one by one to see if any were the cause. Very first plugin I deactivated resolved the 404 on Blog pages issue.

    That plugin is WP Super Cache. Go try it - just deactivate, not delete.

    Probably useful if you report back so WP Super Cache people ca get a handle on extent of issue.

  24. jointplan
    Member
    Posted 2 years ago #

    I'm experiencing the same issue and have implemented near on all code examples and modified versions of them with no luck.

    I've posted the details on this post

  25. faranakysf
    Member
    Posted 2 years ago #

    hi I have pronlem instaling word press I guess I ve done every thing exactly like the documantation said now I want to run instal.php I get this msg :

    Not Found
    The requested URL /info.php was not found on this server.
    Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.
    Apache/2 Server at 87.247.179.95 Port 80
    Im have no experience in web design or so ... can anybody help me please .....

  26. mikaelajoy
    Member
    Posted 2 years ago #

    Initially, my issue had fixed itself when I added a new post, but now that I'm on to a 3rd page, it's rearing its ugly head again.

    I looked into the WP Super Cache plugin and it's already deactivated. I also tried adding the extra code to the functions.php file suggested above. Nothing seems to work this time (not even adding a new post).

    Back to the drawing board, I suppose.

    Thanks again for all the help & suggestions!

  27. faranakysf
    Member
    Posted 2 years ago #

    hi
    this is what I v found .,... there was no problem at all I was just writting the urls wrong .... the url you must use is exactly what is written in docs ... I did so and so far site is up and no problem ....

  28. TechDaddyK
    Member
    Posted 1 year ago #

    Real quick, I had a similar problem and after a lot of Googling, hacking, trying, retrying, and a bit of swearing, I figured out the cause in my case.

    I had created the website with a section of pages without a parent. Then, we decided to move the entire section under a parent to organize the site better. A couple of weeks after launch, I got ONE report of a user with IE 8 that they couldn't get to any of the pages that had been moved.

    Changing the permalinks from custom (/%category%/%postname%/) to Default worked but was undesirable. Eventually, I moved the entire section under "No Parent" again and it solved the problem.

    Just thought I would pass this information on as a possible solution for others in the same situation. Good luck, and thanks for the great discussion that helped me solve my problem!

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.