WordPress.org

Ready to get started?Download WordPress

Forums

404 error - not sure how to troubleshoot (8 posts)

  1. meeble
    Member
    Posted 1 year ago #

    Hello,

    I have a directory of downloads that used to work fine, but one of the updates or plugin updates has now caused these zip and mp3 files to trigger 404 errors. Example URL:

    http://meeble.com/downloads/NAMMEMS.zip

    gives a 404, but that file is absolutely there. You can see the files in the directory:

    http://meeble.com/downloads/

    In the http error.log file, I see this error:

    File does not exist: /home/meeble/meeble.com/downloads/wp-content,
    referer: http://meeble.com/downloads/NAMMEMS.zip

    I have no idea why WordPress is trying to append wp-content to the URL - or doing a redirect of some sort?

    Here's what's in my .htaccess file:

    # make dreamhost stats visible
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteCond %{REQUEST_URI} ^/(stats|failed_auth\.html).*$ [NC]
    RewriteRule . - [L]
    </IfModule>
    
    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>
    
    # END WordPress

    Any ideas?

  2. Paul Kaiser
    Member
    Posted 1 year ago #

    First, try disabling all plugins on your site and try the download link.
    Paul

  3. meeble
    Member
    Posted 1 year ago #

    good idea - i wish WP had a safety mode or something that would disable all enabled plugins and then you could revert back to normal with one click. I have a ton of plugins installed, so it's quite the task...

  4. Paul Kaiser
    Member
    Posted 1 year ago #

    You could do this:

    Go to Plugins and go to "recently active."
    Clear the list.
    THEN deactivate your plugins. All those you deactivate will go into the "Recently Active" list.
    Then you can test etc.
    Then go to "Recently Active" list and reactivate all those.

    Good Luck,
    Paul

  5. meeble
    Member
    Posted 1 year ago #

    nice - thanks for the tips!

  6. meeble
    Member
    Posted 1 year ago #

    even with all plugins disabled, I am getting the 404 error. Strange. Any other ideas?

  7. Krishna
    Volunteer Moderator
    Posted 1 year ago #

    I find that you still have plugins, especially SEO and facebook plugins. Try to disable or remove them and see the results. Even inactive plugins can interfere with your site functions.

  8. meeble
    Member
    Posted 1 year ago #

    no, there are no plugins enabled. That Facebook code is just manually placed in my header.

Topic Closed

This topic has been closed to new replies.

About this Topic