WordPress.org

Ready to get started?Download WordPress

Forums

Google XML Sitemaps
404 erroe when I submit my sitemap to google from my webmaster dashboard (26 posts)

  1. Backroadsliving
    Member
    Posted 1 year ago #

    When I submit my sitemap.xml to Google I get a 404 error. I downloaded the Google XML Sitemap Plug-in through WordPress. When I go to the settings there the sitemap is http://www.backroadsliving.com/sitemap.xml When I click that it gives me a 404 error also. I am using a Child theme for my Twenty Eleven WordPress that seems to work fine at this point. Any suggestions?

    http://wordpress.org/extend/plugins/google-sitemap-generator/

  2. Geoff Panek
    Member
    Posted 1 year ago #

    I am getting the same problem. In fact, it even says the following in the Settings:
    "The URL to your sitemap index file is: http://puresync.com/sitemap.xml.
    Google was successfully notified about changes.
    Bing was successfully notified about changes."

    However I get page not found. Frustrating as I don't seem to see any response to this problem which numerous people have posted.

  3. Andrew Bartel
    Member
    Posted 1 year ago #

    Try actually going to google's webmaster tools: webmaster.google.com.

    They will provide you with step by step instructions for authenticating yourself as the site owner and you can manually submit your sitemap there. If there's any issue, there are more sophisticated troubleshooting and reporting tools there as well.

  4. Geoff Panek
    Member
    Posted 1 year ago #

    I have authenticated my site in google webmaster tools previously. I am concerned tho that if I put in that sitemap url it will bounce and may cause problems. But I will check out the trouble shooting. Thanks

  5. Geoff Panek
    Member
    Posted 1 year ago #

    Google webmaster also got 404 page not found. They really dont seem to have any WP plugin advice. However, I find google very difficult to find answers to anything.

  6. Backroadsliving
    Member
    Posted 1 year ago #

    I had my site ma wrong. When I fixed it everything worked ok.

  7. Geoff Panek
    Member
    Posted 1 year ago #

    whats "ma"??

  8. velezmaya
    Member
    Posted 1 year ago #

    Hello there, I'm receiving this messages. Your Sitemap appears to be an HTML page. Please use a supported sitemap format instead. Is it any problem with this plugin?, what I have to do now?

  9. rentosite
    Member
    Posted 1 year ago #

    Try this. After generating your Sitemap, create a web page with the same file name shown on the Sitemap, ie: sitemap.xml. Then you can submit http://yourdomain.com/sitemap.xml to Google Sitemap. This should fix the 404 error

  10. Backroadsliving
    Member
    Posted 1 year ago #

    Site map. Sorry.

  11. Backroadsliving
    Member
    Posted 1 year ago #

    Fixed.

  12. Beyond Creative
    Member
    Posted 1 year ago #

    @Backroadsliving - What did you do to fix it? I'm having the same exact issue ... Any help will be much appreciated. Thanks!

  13. Geoff Panek
    Member
    Posted 1 year ago #

    I used this one instead, very easy.
    http://wordpress.org/extend/plugins/google-xml-sitemap/

  14. Beyond Creative
    Member
    Posted 1 year ago #

    Thanks for the tip gpanek. I installed and activated but don't see settings on admin side. Does this plugin create the sitemap after being activated?

  15. Backroadsliving
    Member
    Posted 1 year ago #

    I installed WordPress SEO Plugin by Yoast and it generates your Site Map. You can sumit these to Google through the Google Webmaster Tools and they should be fine. Tha is what I did anyway nad it has worked fine for me. Hope this helps.

  16. Geoff Panek
    Member
    Posted 1 year ago #

    yes, its very simple. no settings but the site map is created and sent out to google and bing, i believe.

  17. Backroadsliving
    Member
    Posted 1 year ago #

    I think so gpanek, you can also submit them to Google through the Webmaster tools section. I think this may get your page / pages indexed faster. WordPress SEO has a place in the settings that you can get your site maps. Not positive of anything with Google but I think they get indexed faster.

  18. Geoff Panek
    Member
    Posted 1 year ago #

    Yes of course you have to submit thru google webmaster. I did do that, and was indexed pretty darn quick.

  19. Backroadsliving
    Member
    Posted 1 year ago #

    Yes, mine got indexed pretty quick also. I am a newbie and it has taken some time to learn a lot of this stuff and I am still learning about Google. Sooooo much to learn!

  20. Geoff Panek
    Member
    Posted 1 year ago #

    I use ithemes.com builder parent theme. its amazing. they have a ton of free videos on all aspects of wordpress here http://ithemes.com/tutorials/

  21. sunlight1976
    Member
    Posted 1 year ago #

    how did you fix it Backroadsliving ?
    how can i generate a .xml file in wordpress rentosite?

  22. Backroadsliving
    Member
    Posted 1 year ago #

    @ sunlight1976, I installed WordPress SEO Plugin by Yoast and it generates your Site Map. I also use Google XML Sitemap generator and it submits my sitemap to Google, Bing etc. You can find you sitemap in the WordPress SEO and submit it to Google through the Google Webmaster Tools and get your site indexed faster sometimes. You can find the WordPress SEO and I think XML Generator also in your Plug-In search feature..Good lluck and let us know how it goes for you.

  23. Daithy
    Member
    Posted 1 year ago #

    @rentosite That totally worked!!! Thanks!!

  24. pleydesigns
    Member
    Posted 1 year ago #

    @Everyone who has this problem and is using the "XML Sitemap Generator for WordPress 3.2.9" or earlier. I found the problem to be in the "Location of your sitemap file" area. All of the file locations were missing the "sitemap" part of the "sitemap.xml" file name. I added this into the fields for both of them (AKA use the bottom option which has 2 fields) and presto my sitemaps started to work again.

  25. CreditCoach
    Member
    Posted 1 year ago #

    Hi BackRoadsLiving,

    How did you get your URLs to be the full path? ie. hhttp://www.backroadsliving.com/elisha-the-prophet/ and not /elisha-the-prophet/

    Thank you.

  26. fanwar111
    Member
    Posted 7 months ago #

    Hi,

    I have added my website to google webmaster tools but when i am trying to added my website xml sitemap given in Yoast WordPress Plugin, google webmaster tool gives error Your Sitemap appears to be an HTML page. Please use a supported sitemap format instead., can anyone tell me what to do in this situation!

    Regards

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic