WordPress.org

Ready to get started?Download WordPress

Forums

404 after save or publish a post (80 posts)

  1. JPigford
    Member
    Posted 8 years ago #

    Did anybody ever figure out this issue as it relates to post length? That seems to be my problem. After I try to post something that's to long, it gives me the 404 error...if I shorten it, it will post.

  2. nimrod_abing
    Member
    Posted 8 years ago #

    For what it's worth, the culprit in my case seems to be mod_security. The server I am hosting my blog on shows this WP-generated 404 error everytime a post is of a certain length and contains multiple instances of the word "curl".

    Since my blog is hosted on a virtual hosted environment, I cannot deactivate or change the mod_security rules. The work-around I have found is to wrap the offending word(s) with <span> tags.

  3. GaryKing
    Member
    Posted 8 years ago #

    Same problem here, now. I'm glad I found this thread. Any definite solutions?

    I've been using a desktop blog editor to publish posts, so I never noticed this problem until now.

  4. wbednarski
    Member
    Posted 8 years ago #

    Problem is mod_security.

    I had the same problem. I solved him for replace / on &#47; (utf8 in other encoding is difrent code)

    example:
    /var/ to &#47;var&#47;

    or

    /var/ to /<!-- -->var/

    or

    /var/ to /<span />var/

  5. Ruby Sinreich
    Member
    Posted 8 years ago #

    Wbednarski, can you explain the solution a little more? In which file do you replace the "&#47;" with "/"?

  6. pickled
    Member
    Posted 8 years ago #

    I have this prob too, would love to know the answer. It's NOT post length for me as my posts are short.

  7. Jonathan Landrum
    Member
    Posted 8 years ago #

    For reference, the patch rdsmes proposed is on line 1403. I put in the patch and posted to my site. No more 404.

  8. pickled
    Member
    Posted 8 years ago #

    For reference, the patch rdsmes proposed did not work for me.

  9. cpoteet
    Member
    Posted 8 years ago #

    After much frusturation, I was able to circumvent the problem by adding the following to my .htaccess file.

    SecFilterEngine Off
    SecFilterScanPOST Off

    It turns of the mod_security word filtering. Hoover Dam!

  10. Dominios
    Member
    Posted 8 years ago #

    I am having this same problem when i try to create pages.

    i tried the patch -line 1413- on funtions.php but nothing.

    I keep getting the following error, any idea? what can i do? : (
    ---------my error------

    Not Found

    The requested URL /contact/ was not found on this server.

    Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.

    Apache/1.3.36 Server at http://www.dominiosidn.com Port 80

  11. nimrod_abing
    Member
    Posted 8 years ago #

    I've documented this error, it's most probable cause (mod_security), and some of the work-arounds in an article on my site:

    http://abing.gotdns.com/2006/07/06/40/

    The article is based on my personal experience with this problem along with the solutions I've found in this thread and through experimentation.

    I hope someone finds it helpful.

  12. api123
    Member
    Posted 8 years ago #

    In my case, if i remove my ping list from the Update Services ie Options>>Writing, my publish,Save and edit, Save buttons work fine, But when i give more than 7 or 8 urls in the ping list. i get that 404 error. If my ping list is empty or not more than 4-5 urls, i don't get 404 error.

    Is there any limitation to the number of urls in the ping list?????

    Waiting for your guidance.
    Thx in advance.

  13. om
    Member
    Posted 7 years ago #

    Problem: 404 Error of old Pages

    Recently upgraded to 2.0.4 WordPress from 2.0.1. When posting new Pages everything is ok.

    However, the prior About and Contact Pages give 404 error.
    ex: http://www.fionasze.com/about/

    I've tried turning off plug-ins, updating permalinks with .htaccess (664) and nothing happens. Also tried rdsmes' suggestion and updated the wp-admin/function.php file with:

    if ( !$posts || !$posts[0]->ID )
    return;

    I've gleaned the database and the data appears to get updated. Should I do a complete reinstall? Any suggestions? Merci buckets.

  14. om
    Member
    Posted 7 years ago #

    Disregard the above. I'm going to try a reinstall.

    Thanks.
    om

  15. Aleister
    Member
    Posted 7 years ago #

    I just wanted to say that I recently started experiencing this problem. Also, I had recently installed mod_security on my server! :)

    I tried the .htaccess fix mentioned above, and it worked great. Nice work!

  16. gsiebengartner
    Member
    Posted 7 years ago #

    I have the same problem - save, edit, etc. all cause a page error. I then refresh the page, and the command completes successfully. I'm eager to try the .htaccess solution proposed above, but I'm quite certain that I don't even have an .htaccess file. If I didn't create one myself, should I still have it, and where? Thanks.

  17. Dalby
    Member
    Posted 7 years ago #

    Just got the this error for the first time and only on one page (all the other pages and posts work fine) and the .htaccess fix above worked.

    Just don't understand why it would suddenly start happening.

  18. belinep
    Member
    Posted 7 years ago #

    I have this problem when editing php files using WP and when saving setting to some plug-ins, but not when publishing.

  19. gailbean
    Member
    Posted 7 years ago #

    I was getting 404 error for any pages outside of home. After reading this post, I went to Options/Permilinks and reset to default. No more 404s!

    Thanks for the help.

  20. theplayahata
    Member
    Posted 7 years ago #

    Anybody still having this issue and running 2.0.5 see this thread.
    http://wordpress.org/support/topic/98678?replies=10

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags