WordPress.org

Ready to get started?Download WordPress

Forums

All In One WP Security & Firewall
[resolved] 403 Forbidden issue when activating the blacklist feature (6 posts)

  1. iSaumya
    Member
    Posted 9 months ago #

    Hi, I have installed this plugin yesterday and I'm loving its functionality, but today I got one spam comment, so I just thought that to use your IP blacklist feature for spam comments. Now when I have activated the blacklist feature it start showing me 403 forbidden issue on every page so I have to delete the following htaccess code from my htaccess file:
    #AIOWPS_IP_BLACKLIST_START
    Order allow,deny
    Allow from all
    Deny from 74.125.191.23
    #AIOWPS_IP_BLACKLIST_END

    I have also contacted my hosting provider and they are saying the code will be

    <Limit GET HEAD POST>
    order allow,deny
    deny from 74.125.191.23
    allow from all
    </Limit>

    Anyways I have deactivated that feature on my site and now its working fine, So I would appreciate if you fix this issue or help me to solve this.

    Thanks

    http://wordpress.org/plugins/all-in-one-wp-security-and-firewall/

  2. mra13
    Member
    Plugin Author

    Posted 9 months ago #

    Just to confirm. Does it work correctly if you manually enter the following in your .htaccess file?

    <Limit GET HEAD POST>
    order allow,deny
    deny from 74.125.191.23
    allow from all
    </Limit>

  3. iSaumya
    Member
    Posted 9 months ago #

    No brother it is not resolved, I have also tried the htaccess code provided by my host. I think something else is happening on my htaccess file when I'm ading that feature/line. beside I think it would be best if you take a look on my htaccess file. But as you know I cant share it here publicly for my site security reason, could you please give me your email id, so that I can mail you my htaccess file and you take a look on the culprit.

    Thanks for your fast response.

  4. mra13
    Member
    Plugin Author

    Posted 9 months ago #

    The rule that our plugin adds is correct. Which why I told you to try the one your hosting provider recommended. Now, you can see that no matter what you put, it doesn't work. So you can go back to your hosting provider and ask them again why it doesn't work. This time you are using their suggested code so they can't say that our rule was wrong.

  5. iSaumya
    Member
    Posted 9 months ago #

    I did, but the are saying that this is happening because of some other htaccess code conflict in my htaccess file. That is why I was aking for your email id so that you can check my htaccess code.

  6. wpsolutions
    Member
    Plugin Author

    Posted 9 months ago #

    You can clear all the rules which were added by our plugin to your .htaccess file by going to the Settings menu and then clicking the Disable All Firewall Rules.

    This way you can try your tests again using the rule your host provider recommended knowing that there will be no All In One Security rules to interfere.

Reply

You must log in to post.

About this Plugin

About this Topic

Tags