WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] 403 Forbidden Error (33 posts)

  1. ceo
    Member
    Posted 9 years ago #

    Ok, this is so weird that I had to post about it. I just posted this post:
    http://purple-lilacs.com/archives/2005/01/13/clean-dog-bed-think-again/

    And the original had this paragraph in place of the fourth one down (not counting the edit as a paragraph):

    "When I had fully vacuumed the dog hair beneath where the bed had been and replaced it back in the prominent spot next to my bed, she wouldn't come near it. Rather she decided to curl up in a ball in the corner of the room."

    With that paragraph, I received a 403 Forbidden error when posting. So I removed all the text (because I knew I could post, I had not that long before with not a problem) and then added in each paragraph one by one....

    Anyway, it seems so random and weird and I can't explain it. I tried it on another WP install I have running and it wouldn't post there either.

    Strangest thing ever....
    EDIT: and for clarification (in case you don't click over to the post), I was referring to my dog.

  2. Mark (podz)
    Support Maven
    Posted 9 years ago #

    I copied and pasted that and it displayed.
    Did you write it in a wordprocessor ? It's the only possible thing I can think of - that a strange character has set wp off.

  3. ceo
    Member
    Posted 9 years ago #

    Nope, I wrote it right in the admin panel - in both blogs that I tried it on. I have no explanation...it's just incredibly weird.

  4. luxfx
    Member
    Posted 9 years ago #

    I've had the same thing happen to me on a couple of occassions. I can't figure it out! Have you had any luck?

  5. ceo
    Member
    Posted 9 years ago #

    Nope, no idea what caused it. It happened again with another post a few days ago actually. But no one's been able to give me a reason why. *shrugs*

  6. chuckblue
    Member
    Posted 9 years ago #

    maybe its the permissions ?

    I get a 404 not found message for that page.

  7. ceo
    Member
    Posted 9 years ago #

    I posted the initial question ages ago - I since changed my permalink structure to leave off the /archives/
    It's not permissions or anything I can truly understand. It's just some random weird error that dislike some portion of the text in that sentence.

  8. adeydas
    Member
    Posted 9 years ago #

    You can try putting this in your .htaccess:

    DirectoryIndex index.php

    This will force Apache to accept nothing but index.php as your default file.

  9. ceo
    Member
    Posted 9 years ago #

    I never saw this reply, sorry.

    Uh, how does that help me? My index.php is fine...I mean I don't get errors viewing my site, it's trying to post things that WP seems to dislike for no intelligent reason that I can understand, I don't see how altering a file that is perfectly fine would help me solve a problem that apparently happens in post.php - and effects ANYTHING I try to do after posting the unpostable text, since I get a 403 in any direction, sans back, where I can then re-edit the post and try again.

    (Wow, that was so wordy.)

  10. tauquatrino
    Member
    Posted 9 years ago #

    Hey my friends blog is having the smae problem as well. short posts go through but longer ones just don't. they get the 403 forbidden and 404 error.

    I have chmodded post.php as was suggested here

    http://wordpress.org/support/topic.php?id=19392
    . i have also had the host upgrade the zend php thing as it worked for some people.

    any ideas? it seems like alot of people are getting this error recently. she was posting fine when it suddenly happens.

  11. Skraut
    Member
    Posted 9 years ago #

    I'm getting the exact same problem. Posts under 130 words or 776 characters post just fine. Anything over that number generates a 403. Any help fixing this would be greatly appreciated.

  12. Skraut
    Member
    Posted 9 years ago #

    I'm continuing to get this same problem and it's frustrating. I'm able to use an external program to post to my blog (ecto for the mac) but I can't post through the normal web interface

  13. Skraut
    Member
    Posted 9 years ago #

    I'm still getting the same problem, and have tried enableing and disableing permalinks, deleting and changing .htaccess, I've changed permissions all the way up to 777 for /wp-admin, and still getting the exact same error as above.

  14. Kelson
    Member
    Posted 9 years ago #

    This sounds like it might be related to mod_security rules. Some of the example rules block anything that looks like an attempt to fire up a common downloader called curl via a malicious web request.

    Ask your host whether they're using mod_security, and if so, whether they have any (overly-simplistic) rules that look for curl.

  15. ceo
    Member
    Posted 9 years ago #

    Apologies for the sort of double posting (but in case someone finds this later I wanted to report in the original thread). I contacted my host regarding the issue and Kelson is correct that it is a mod_security thing.

    My host, however, is not willing to alter anything, but now that I know it's the word "curl" that was causing the issue, I'll just refrain from using it. (Not like it's that common of a word for me anyway!)

    Thanks again, Kelson.

  16. tauquatrino
    Member
    Posted 9 years ago #

    it is confirmed... the post that triggered the 403 had the word "curl" in it too!

  17. chst
    Member
    Posted 8 years ago #

    "curl u" in fact triggers errors for me as well on an online app i've created. PHP 4ish and apache.

    in textareas or inputs.

  18. chst
    Member
    Posted 8 years ago #

    My host told me this:

    "Mod_security is restricting this and blocks all url's with C-url. This is done because of some php worms that are spread using c-url. I would recommend trying to work around this. It will be a major security issue for us to allow this."

  19. TravisBenning
    Member
    Posted 8 years ago #

    I have no problems with Curl or C-url and Mod_security on my server, but still get a 403. I've found that it does not matter how long the post is, just if I'm sending a trackback or if I have a link in the post. The second I take the link out of the post and hit publish or save or take any action of that sort it works. Works in so far as I can't actually publish anything but do avoid the 403... Any thoughts on this?
    Also had issues with my permalink structure just recently. Two days ago it was fine with year/month/day/postname. It started to break earlier yesterday morning so I changed it without the day part and it worked fine... again, any thoughts on this would be great.

    Thanks everyone.

  20. James
    Happiness Engineer
    Posted 8 years ago #

    Are you blocking referrers with keywords via .htaccess? Sometimes we block referrers with keywords and we don't even think that it may catch and interfere with our own actions (such as editing posts).

  21. TravisBenning
    Member
    Posted 8 years ago #

    I'm blocking 5 ip addresses. I know they are spammers, so I didn't think there would be a problem.

    The only thing in my .htaccess file is my mod_rewrite data that wordpress put in there.

    It seems like if the url I'm putting in a post is even somewhat long it 403's it. It used tinyurl for a few links recently because of this. Is there some setting on that that I have overlooked?

    Thanks for the reply by the way.

  22. James
    Happiness Engineer
    Posted 8 years ago #

    I believe that controlling the length of URLs is either an Apache or PHP setting, but I'm not sure. Have you brought up the fact that posting long URLs causes a 403 to your hosting provider's support yet?

  23. TravisBenning
    Member
    Posted 8 years ago #

    I will post a ticket about it in a moment, just finishing up a final project for class...
    Would it possibly be just the content of certain URLs or the fact that they are long? Seems like the boundary is 32 char. But I have posted some that were over 42. Very odd, it works sometimes and not others. Has anyone else had this on/off permissions error before? Is it a bug in WordPress?
    Thanks for your help.

  24. TravisBenning
    Member
    Posted 8 years ago #

    Actually it seems to work fine right now. I haven't changed anything, but I can now post longer links and haven't had a 403 for about 16 hours now... Odd.

    Thanks again for your help, I'll be back on here if it changes. Still not sure why it did this.

  25. Xander
    Member
    Posted 8 years ago #

    So bizarre... I just have to give up the use of the word "curl"? But how will I live?

  26. songfta
    Member
    Posted 8 years ago #

    I must admit, this blocking of the word "curl" is really annoying. you'd think that the code could be made elegant enough to allow basic grammar in a post.

    Ugh.

  27. James
    Happiness Engineer
    Posted 8 years ago #

    The problem is actually caused by over-zealous server-side security (such as mod_security) which blocks PHP executables (such as "curl") from being sent via POST requests.

  28. RyanMarcus
    Member
    Posted 8 years ago #

    I actualy needed to have the string "curl" in a post (referring to the UNIX command) and I just replaced all curl with c<!-- -->url. Works great.

    Prehaps it would be a good idea to add a JavaScript replace all to look for curl and replace it with c<!-- -->url? I will write the code if nobody else wants to.

  29. Eric Amundson
    Volunteer Moderator
    Posted 8 years ago #

    I had the same thing happen. I'd written a poem that had the word curl in it and it wouldn't post. I changed it to curled and it worked fine. Thanks for the other tips, though.

  30. com-winnercom
    Member
    Posted 8 years ago #

    empfehlenswert: g├╝nstige notebooks http://www.com-winner.com auf dieser seite
    ausserdem viele n├╝tzliche links auf http://samsungnotebooks.sa.funpic.de und
    http://notebookshop.no.funpic.de aber auch auf http://gebrauchtepc.ge.funpic.de !!!

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags