WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] 403 Forbidden after enabling permalinks (7 posts)

  1. seoguru
    Member
    Posted 6 years ago #

    I installed WordPress and everything worked fine.

    Then I activated permalinks (date and name based). This resulted in the message "You should update your .htaccess now.". The pages also showed which code I had to place in the .htaccess:

    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /seo-blog/
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /seo-blog/index.php [L]
    </IfModule>

    I did so and did a chmod 666 on the .htaccess-file.

    But when I go to the homepage of my weblog now, I get the following message:
    "
    403
    Forbidden
    You don't have permission to access /seo-blog/ on this server."

    /seo-blog/ is the directory of my blog. The chmod of this directory is 755.

    According to my hostingprovider mod_rewrite is enabled.

    What am I doing wrong? Please help.

  2. moshu
    Member
    Posted 6 years ago #

    And where did you put the htaccess file? In the seo-blog directory?

  3. seoguru
    Member
    Posted 6 years ago #

    yes!

  4. Samuel Wood (Otto)
    Tech Ninja
    Posted 6 years ago #

    Try adding Options +FollowSymLinks to the top of the .htaccess file.

    If that doesn't work, verify that the host has AllowOverride enabled. Verify what they have the AllowOverride set to.

  5. seoguru
    Member
    Posted 6 years ago #

    I'm amazed. The extra line works!

    Thank you very much!

  6. Samuel Wood (Otto)
    Tech Ninja
    Posted 6 years ago #

    For reference, if anybody else wants to know:
    mod_rewrite can be used to simulate a symbolic link. This is why mod_rewrite requires FollowSymLinks to be enabled, because it's a similar security thing. So if your host doesn't enable FollowSymLinks, and you try using mod_rewrite, you'll get the 403 error. Adding Options +FollowSymLinks will override it for your directory, allowing mod_rewrite to work.

    But, if you have this problem and you add Options +FollowSymLinks and then get a 500 error instead, then your host is disallowing the use of the Options directive in .htaccess files, and there's little you can do but complain to them.

  7. scooly
    Member
    Posted 6 years ago #

    But, if you have this problem and you add Options +FollowSymLinks and then get a 500 error instead, then your host is disallowing the use of the Options directive in .htaccess files, and there's little you can do but complain to them.

    I'm in that situaction. What can I do? Is that my provider mistake or mine? Can I fix it?

Topic Closed

This topic has been closed to new replies.

About this Topic