WordPress.org

Ready to get started?Download WordPress

Forums

W3 Total Cache
403 Forbidden access to minified javascript (7 posts)

  1. Macaromix
    Member
    Posted 1 year ago #

    Hi,

    First of all thanks for this great plugin that works great. I recently discovered a bug and was wondering if anyone could help.

    So here is the scenario :

    I load the website for the first time (as a new visitor - empty cache and everything).
    The homepage loads perfectly. I navigate in all the pages, everything works fine. When I come back to a page already visited it is super fast... I must precise that I use browser caching for html/css/js that are all minified and gziped.

    BUT (using firefox) after I empty all cache data / recent history, and when I reload the website, the minified js is not accessible. I get this kind of message :

    You don't have permission to access /wp-content/cache/minify/000000/blbalabalablaabalabla.js
    on this server.

    But everything else works ! ie minified css, html etc... how could I solve this specific JS issue ?

    Thanks for your help,

    Best regards,

    Laurent

    http://wordpress.org/extend/plugins/w3-total-cache/

  2. Macaromix
    Member
    Posted 1 year ago #

    Small precision : when I access the relative url for the first time it loads with no issue. I only get this 403 error after clearing browser cache and reloading...

    Thanks for your help

  3. Macaromix
    Member
    Posted 1 year ago #

    I tried with google chrome and safari and it is worse. The minified js is never loaded ! I always get the 403 error...

    thanks for your cooperation

  4. jeroen-1978
    Member
    Posted 1 year ago #

    I have the same problem but not only for JS but also for CSS.

    My PHP logs shows an error message; (36)File name too long. Reducing the filename seems to be the solution for this problem. How simple life can be :)

    I will wait for a update and in the meantime I've disabled minify for JS and CSS.

  5. Macaromix
    Member
    Posted 1 year ago #

    Apparently the URL generated is longer than 255 chars which is not accepted by many apache configs.

    I am surprised that we are the only ones to face this issue. All basic apache configs should have the same problem.

    It is maybe working for me with the minified css since the url length is 225.

  6. Frederick Townes
    Member
    Plugin Author

    Posted 1 year ago #

    Right, this issue is known and being sorted in the next release.

  7. abdullalodhia
    Member
    Posted 10 months ago #

    Hey,

    Can you try this and let me know if it helps.

    In the minify settings --> look for "Rewrite URL structure"
    If disabled, CSS and JS embeddings will use GET variables instead of "fancy" links.

    Just uncheck it, push for clearing the cache and try. Let me know if it works. I though I had similar problem as described by you above and got solved by this change.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic