WordPress.org

Ready to get started?Download WordPress

Forums

Leaflet Maps Marker (Google Maps, OpenStreetMap, Bing Maps)
[resolved] 403 forbidden acces to some marker icons? (8 posts)

  1. photocoen
    Member
    Posted 1 year ago #

    Hello Robert,

    I had a look the other day at the Leaflet site. Very interesting things they are talking about... :-) Hope to see some of them implemented in the future.

    But for now, we are test-driving our site, and I came across a strange thing.

    Some icons are showing with the famous broken image icon. The images are all in place on the server. If I try to access an image directly, it gives me a 403 error.

    When I go over the icons that are not showing, I see that the permissions are not set read/write for everyone, and the icons that are showing have that. I think it has something to do with the OSX Lion that my wife uses [this is giving me headaches with the permissions across our little network of two.]

    So I reset the permissions, uploaded the file again, reload, and nothing. I even downloaded the file anew from the mapicons server and uploaded it to my server. And again no luck.

    any ideas?

    http://www.landcruisingadventure.com/information-south-america/

    icons in particular: http://www.landcruisingadventure.com/wplca/wp-content/uploads/leaflet-maps-marker-icons/wildderness_camping.png

    Adventurous greetings,
    Coen

    http://wordpress.org/extend/plugins/leaflet-maps-marker/

  2. photocoen
    Member
    Posted 1 year ago #

    Hmmm, one brilliant idea, and it solved itself. Instead of replacing the already file on the server, I now removed it and then uploaded it again. Now it works. Keeps yourself busy!

  3. photocoen
    Member
    Posted 1 year ago #

    Can you tell me why those little grey lines are in my map?
    Where in the css can I delete those?

  4. RobertHarm
    Member
    Plugin Author

    Posted 1 year ago #

    the grey lines (Equator, Tropic of Cancer...) are part of the Mapquest basemap you are using and canĀ“t be turned off via css. You would have to switch to another basemap if you dont want them I guess.
    regards,
    Robert

  5. RobertHarm
    Member
    Plugin Author

    Posted 1 year ago #

    BTW: clicking on your photos on the frontpage of your site, I get an error by calling the following URL: http://localhost:8888/landcruising/about/

  6. photocoen
    Member
    Posted 1 year ago #

    Hmmm I wasn't refering to those lines, but the little grey square box around the markers that show up on Safari and on Chrome in my Mac. FireFox doesn't show them.

    grey boxes

    Thanks Robert for pointing out that error.

  7. RobertHarm
    Member
    Plugin Author

    Posted 1 year ago #

    Hi Coen,
    the problem is, that the marker shadow images dont get loaded at all - if you analyse the boxes with chrome F12 and copy the url, you`ll get an 404-link: http://localhost:8888/landcruising/wp-content/plugins/leaflet-maps-marker/leaflet-dist/images/marker-shadow.png

    Please check the setting "Shadow URL" under "Settings" / "Map Defaults" / "Default values for marker icons" - if localhost is entered there, you should change it to your url.

    Will try to find out, why localhost was entered here at all & if I can prevent this somehow...
    regards,

    Robert

  8. photocoen
    Member
    Posted 1 year ago #

    My bad! When I went live I changed the new location in the database manually, I didn't think about the shadow I guess.. Thanks for pointing me in the right direction!

    Adventurous greetings,
    Coen

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic