WordPress.org

Ready to get started?Download WordPress

Forums

All In One WP Security & Firewall
403 forbidden (3 posts)

  1. Bakkie
    Member
    Posted 8 months ago #

    Hey,

    I use this plugin on many of my websites. For a customer I also wanted to use this plugin.. I created the website in a subfolder http://www.site.com/sitev2/, I already turned on the plugin.. I had no problems then.

    Then the website was ready to go live, and I changed the index and permalinks etc so that when going to http://www.site.com it loads the website without anyone seeying 'sitev2'.. just like i did on a other website that also has this plugin running..

    But now when i turn on the plugin again I keep getting this 403 forbidden error.. that i dont have permission to /sitev2/

    I thought it probably has to do with turning this plugin on to early.. since i changed the website from subfolder to root (kinda). So I deleted the plugin, deleted all the settings in .htaccess, installed the plugin again.. but still the problem is there.

    I dont have access to the menu, or to the website (frontend) itself... Help is very much appreciated!

    http://wordpress.org/plugins/all-in-one-wp-security-and-firewall/

  2. Bakkie
    Member
    Posted 8 months ago #

    I had 2 htaccess files apparently..

    One in the root, that only contains w3 cache settings and

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>

    The other one was in the subfolder http://www.site.com/sitev2/

    That one contained the All In One WP Security & Firewall settings that i deleted and

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /sitev2/
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /sitev2/index.php [L]
    </IfModule>
    
    # END WordPress

    Also tried with deleting the second one completely but still no luck..

  3. wpsolutions
    Member
    Plugin Author

    Posted 8 months ago #

    If you deleted all of the directives pertaining to the AIOWPS plugin in your .htaccess file and you still see the "403 forbidden" problem then your issue does not lie with the AIOWPS plugin.

    Just to confirm this, try deactivating the AIOWPS plugin and check if you still see the same behaviour.

    You should also contact your host provider because they will be able to help you resolve this more easily.

Reply

You must log in to post.

About this Plugin

About this Topic