WordPress.org

Ready to get started?Download WordPress

Forums

403 Error when using permalinks (9 posts)

  1. morph2k2
    Member
    Posted 9 years ago #

    Good Evening, i have a really big problem, and all the faqs and posts in this forum didnt help :( I want to use Permalinks and have mod_rewrite activated, but i always get an 403 Error when trying to acces the page.
    Here is my .htacces i hope you can help me getting it right:

    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /weblog/
    RewriteCond %{REQUEST_FILENAME} -f [OR]

    [Moderated - Rewrite rules reduced to the above. Only about 3 people understand them here :) ]
    MoRpH2k2

  2. Mark (podz)
    Support Maven
    Posted 9 years ago #

    What is your permalink structure ?

  3. morph2k2
    Member
    Posted 9 years ago #

    /archives/%year%/%postname%/

  4. Mark (podz)
    Support Maven
    Posted 9 years ago #

    Do you use IRC ?
    If so, I'd suggest popping into #wordpress on irc.freenode.net as the guys there know tons about rewrite rules (well... a few of them do).

    One possible drawback with what you have though is that over a year, you cannot have the same post title twice. It might be wise to add something else into that structure.

  5. rjjm
    Member
    Posted 9 years ago #

    I had a similar problem. On changing the the permalink structure I received the 403 error and was unable to access any of my site (as by now I had put WP in the root).

    Once I deleted all the WordPress additions in the .htaccess file I was able to access the site again and the admin pages. However, I had to change the permalink structure back to the default (blank) as the links for my posts were wrong.

    Any further attempts to modify the permalink structure, other than to the default, seems to result in the same 403 error.

    Did you guys manage to resolve the issue? I would really like to use permalinks.

  6. rjjm
    Member
    Posted 9 years ago #

    Further adventures: I found that the permalinks had been set to the wrong links on all my posts. The issue seemed to be unresolveable and I have had to remove WordPress from my server.

    Would be nice to have a solution to this critical bug since it's stopped me using this otherwise excellent piece of software for the moment. How many more people has/is/will it it screw up? Is it just me?

  7. fadedpictures
    Member
    Posted 8 years ago #

    I've had the same issues as most here, here is what i found on:
    http://faq.wordpress.net/view.php?p=20

    Try adding the following line at the top (the very first line) of .htaccess :
    Options +SymLinksIfOwnerMatch

    It seemed to work for me.

  8. vkaryl
    Member
    Posted 8 years ago #

    I had all the same troubles as above. What worked for me was putting the .htaccess file IN THE RIGHT FOLDER: the WP root folder.... after that, no more problems (well, had to make it server writeable of course....)

  9. rjjm
    Member
    Posted 8 years ago #

    Hoorah and huzzah!

    It worked! The 'Options +SymLinksIfOwnerMatch' at the top of .htaccess did the trick. Excellent and fullsome article that you pointed me to, fadedpictures, thank you. (and I like your website!)

    Thanks also to vkaryl for your very practical advice. Did have .htaccess in the right folder, but it wouldn't be the first time that I missed something obvious.

    ~R

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags