WordPress.org

Ready to get started?Download WordPress

Forums

403 error on Windows 2008 64bit with IIS7 (11 posts)

  1. macncheesepro
    Member
    Posted 1 year ago #

    Hello!

    I'm a system admin and support a few sites including a wordpress site on a shared server.

    Basically, what's happening is when I try to make a new post in wordpress, I get a 403 Forbidden: Access Denied error message.

    When I try to do this from inside the web server, I get a wordpress page that says "Are you sure you want to do this?" with a link that says "Please try again"

    I'm at a loss. Only one module is installed and tried deactivating it with no results. I see tons of people saying to turn off "Mod_Security" but this is a windows server, so I can't do that. There is no Mod_Security.

    I've double checked the wp-config.php file, reset the MySQL DB password to the same password, made sure fastcgi is enabled, restarted the webserver, IIS, made sure the application pool will support 32bit apps, turned off validaterequest in the web.config. Nothing has worked so far and I am at a loss.

    ANY help would be much appreciated.

    Here are the server specs:

    Windows Server 2008 R2 64bit
    IIS7 webserver
    PHP 5.3
    MySQL 5.5

    Thanks!

  2. Pioneer Valley Web Design
    Member
    Posted 1 year ago #

    Windows Server 2008 R2 was released only as x64. Review the many links at:

    http://www.microsoft.com/web/wordpress

    http://codex.wordpress.org/iis

    Once WP is installed and configured on your server, access it from a browser on a local PC (not the server)...or review restrictions of IE used on server.

  3. macncheesepro
    Member
    Posted 1 year ago #

    Hi,

    It's running as 64bit now in the application pool. Still no difference.

    Also, just to be more clear:

    1. I have been getting the 403 error from outside the server when trying to make a new post.

    2. Accessing the page from inside the server gives me the wordpress "Are you sure you want to do this?" error instead of the 403 error

    We just can't make a new post no matter what I've tried.

  4. macncheesepro
    Member
    Posted 1 year ago #

    Another thing I forgot to mention is that the wordpress site is in a subdirectory of the site. So it's like http://www.mysite.com/wordpress. Not sure if that makes a difference.

  5. Pioneer Valley Web Design
    Member
    Posted 1 year ago #

    Is the web.config in the root or in the WordPress folder?

  6. macncheesepro
    Member
    Posted 1 year ago #

    It is in the wordpress folder and it contains the following info:

    <?xml version="1.0" encoding="UTF-8"?>
    <configuration>
    <system.webServer>
    <rewrite>
    <rules>
    <rule name="wordpress" patternSyntax="Wildcard">
    <match url="*" />
    <conditions>
    <add input="{REQUEST_FILENAME}" matchType="IsFile" negate="true" />
    <add input="{REQUEST_FILENAME}" matchType="IsDirectory" negate="true" />
    </conditions>
    <action type="Rewrite" url="index.php" />
    </rule></rules>
    </rewrite>

    </system.webServer>
    </configuration>

  7. Pioneer Valley Web Design
    Member
    Posted 1 year ago #

    The web.config above moves to root and then follow this:

    http://blog.discountasp.net/root-redirection-to-subdirectory/

    If you have another site at root, you need to make specific rules for each sub

  8. macncheesepro
    Member
    Posted 1 year ago #

    Tried that too. Didn't work. I even temporarily changed the wordpress directory to being the root and still didn't work.

    Here is the exact error message I'm getting when I try to post:

    403 - Forbidden: Access is denied.
    You do not have permission to view this directory or page using the credentials that you supplied.

    Tried temporarily changing the security to allow "Everyone" permissions and still didn't work.

  9. Pioneer Valley Web Design
    Member
    Posted 1 year ago #

    Everyone is for local auth, review the web user permissions

    http://stackoverflow.com/questions/2532079/iis7-folder-permissions-for-web-application

    may help

  10. macncheesepro
    Member
    Posted 1 year ago #

    I made sure all the permissions are ok. Tried using local service, network service and tried using the application pool identity. I changed the setting in the App pool as well as the folder permissions and made sure the IUSR was set to whatever account I was using. Nothing has worked. Could there be something wrong with this page?

    http://www.mysite.com/wordpress/wp-admin/post.php

    Thank you for all your help so far! I really appreciate it!

  11. Pioneer Valley Web Design
    Member
    Posted 1 year ago #

    Have you set any required router permissions, ports etc?

    Can you see error logs, are you reaching the site or being blocked at network/router?

Topic Closed

This topic has been closed to new replies.

About this Topic