WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] 403 error for custom permalinks (6 posts)

  1. winterglow
    Member
    Posted 1 year ago #

    Website: http://http://www.angelhair.ca/

    I'm getting a 403 error when changing the permalink structure to anything other than the default setting. I'm guessing the problem is server-side as this site worked fine on my testing server.

    The exact error message in the browser is:

    ----
    Access forbidden!
    You don't have permission to access the requested directory. There is either no index document or the directory is read-protected. If you think this is a server error, please contact the webmaster.

    Error 403:
    angelhair.ca
    Mon Jun 17 16:13:28 2013
    Apache/2.0.54 (Debian GNU/Linux) FrontPage/5.0.2.2635 mod_ssl/2.0.54 OpenSSL/0.9.7e
    -----

    My permissions must not the problem because I've changed the entire WordPress directory to 777 without success (including the htaccess file). WordPress is also writing to the .htaccess without any trouble, and I've tried various changes to it according to other forum posts on this topic.

    Right now the file includes:

    Options +FollowSymLinks
    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>
    # END WordPress

    I've confirmed with the host (netnation) that the mod_rewrite module is installed.

    The only abnormal part of this install for me is that I've had to install phpmyadmin myself to create the database. The other thing is that although WP is installed in the root html directory, there are some existing folders on there that contain .htaccess files which I don't have permission to tamper with, such as _vti_bin. Could these be overriding my own .htaccess file, I don't know.

  2. kmessinger
    Volunteer Moderator
    Posted 1 year ago #

  3. Tara
    Member
    Posted 1 year ago #

    I'm getting a 403 error when changing the permalink structure to anything other than the default setting.

    - Try reading Using_Permalinks before setting a custom permalink structure again.
    If clearing your Permalinks does not alleviate the issue, this could be attributed to anything from a web server configuration to a bad WordPress install.

    My permissions must not the problem because I've changed the entire WordPress directory to 777

    - From asecurity standpoint, risky to do that.

    - Try contacting your hosting provider about the permission issue.

  4. winterglow
    Member
    Posted 1 year ago #

    Fixed! I had to add /index.php/ to the beginning of the permalink structure, thanks to the link on Using_Permalinks. No .htaccess file was required at that point; WordPress took care of it.

    I believe this must be a Windows server because I've encountered this problem before where URLs had to contain index.php. I was under the impression it was Linux based on the phpinfo file. I learned a lesson to always find out these details from the host first.

    Thanks for the security tips!

  5. Tara
    Member
    Posted 1 year ago #

    You are welcome. :-)

  6. reszelo
    Member
    Posted 2 months ago #

    Dear Guys!

    I have been searching the solution for days. Let me tell you the solution I found. Whenever I cahnged the permalinks to other than default it always errored 403 problem.

    The solution is very easy. Delete the .htsccess file from the root of your website html directory and make a new file, named: .htaccess

    Leave it blank, just make it. It will work. I think my host provider has got problem, but it is a very big online company so might happen to any of you.

    All the best!

Topic Closed

This topic has been closed to new replies.

About this Topic