WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] 403 Access Forbidden to admin and blog (11 posts)

  1. HettyGreen
    Member
    Posted 6 years ago #

    Hi all:
    I have spent the day installing WordPress and uploading a theme - which all was working just fine UNTIL I tried to configure permalinks.

    The permalinks page told me to add the code it produced to the htaccess file. I did not find a htaccess file in the directory where WP is installed so I created one with the required code and uploaded it. At that point I was no longer able to access any of my pages, including admin.

    This is the error:

    ______________________________
    Forbidden
    You don't have permission to access /news/wp-admin/ on this server.
    Additionally, a 403 Forbidden error was encountered while trying to use an ErrorDocument to handle the request.
    ______________________________

    So I deleted the htaccess file I had just placed in the directory, but am still not able to access any of my pages. I am at a loss as to how to fix this.

    Any help greatly appreciated. I can't bear the thought that I will have to spend another day installing this all over again!

    Thanks in advance!

  2. HettyGreen
    Member
    Posted 6 years ago #

    Update:

    Today I can access the admin pages (mysteriously) and also my blog start page, but any other pages I try to add give me a Not Found error. I'm thinking I must have messed up the write permissions somehow but don't know where to begin looking to sort this out. help please?!

    here's the blog-site: http://ernestina.org/news/

  3. alexleonard
    Member
    Posted 6 years ago #

    Definitely sounds like a .htaccess issue.

    As far as I can tell you probably have the following working on your server:

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>
    
    # END WordPress

    as going to domain/news/index.php/about/ automatically rewrites to domain/news/about/

    Perhaps you need to update your Permalinks by selecting "Date and Name Based" in Options > Permalinks.

    Also, what are your WordPress and Blog addresses set as in Options > General?

  4. HettyGreen
    Member
    Posted 6 years ago #

    alexleonard - thanks so much for your quick response.

    I think the first time I tried to create the htaccess file (since there wasn't one in the WP directory) I may not have created the file properly (not txt) and so caused all these subsequent problems.

    I've just tried again (a little more carefully this time) and fixed it! By creating a blank txt file called htaccess.txt, uploading it to the WP directory, renaming it to .htaccess and changing the permissions so that the dashboard can write to it. Then went back to the permalink options page and set them again. Did not get the Change Your Htaccess message from the dash this time round so I'm pretty certain it was able to do what it needed to do. Also - can access my other pages again!

    Thanks again for your reply!

  5. alexleonard
    Member
    Posted 6 years ago #

    Ah great! I'm glad to have been able to help out.

    You can mark this topic as resolved now :)

    Hope it all works smoothly from here on in.

  6. massam
    Member
    Posted 6 years ago #

    I have installed wordpress in the directory: 'wordpress' and when i change permalinks, 403 error is shown on admin & front-end.

    My httaccess file is as:
    ----------------------------
    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /wordpress/
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /wordpress/index.php [L]
    </IfModule>

    # END WordPress
    ----------------------------

    I used '+FollowSymLinks' in .htaccess file and got 500 internal server error. Any body have the solution for it?
    If there exist any alternate solution? if yes then can anybody provide the code for htaccess file?

    Thanks!

  7. lausianne
    Member
    Posted 6 years ago #

    Hi,

    I've got exactly the same problem. I installed WP yesterday, writing posts works. Uploading images doesn't (wrong path, I believe, described in other post).
    As soon as I create .htaccess in the wordpress root folder and enable write access, wordpress fills it automatically and I have no more access to anything, 403 everywhere.

    I tried what I found here: http://wordpress.org/support/topic/189058?replies=1
    Not sure if that's actually related to this problem. Anyway, no go.

    How is this supposed to work? Thanks for your help.

  8. alexleonard
    Member
    Posted 6 years ago #

    Please provide a URL for your wordpress install so we can see what's going on.

  9. lausianne
    Member
    Posted 6 years ago #

    Oh, you're working on Sundays ... thanks for the reply.

    I'd like to keep the current url private. But I will reinstall WP under a different url tomorrow and post it here.
    If you send me your email address, I'll send you the private url and admin login right away: lausianne gmx net

  10. lausianne
    Member
    Posted 6 years ago #

    Ok, here you go.
    New installation: http://wp.longwitz.ch/

    Currently the only problem is permalinks, where creating .htaccess blocks all access. I don't think you can see that from outside.
    I'm happy to send you the admin password, alexleonard, if you think you can help.

    .htaccess looks like this:

    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>
  11. alexleonard
    Member
    Posted 6 years ago #

    Hey. Days of the week seem to have no meaning anymore ;)

    I guess it would be helpful to get the admin password, then at least I can have a look around.

    You can send it to me at alexleonard2003
    at
    gmail.com

    I can see that at the moment any page outside of your homepage/admin area is bringing up an apache forbidden message. Hopefully it's something minor.

    Fingers crossed we can work this out and then you can apply the fix to your proper installation :)

Topic Closed

This topic has been closed to new replies.

About this Topic