WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] 3rd request for help (21 posts)

  1. KathrynBassett
    Member
    Posted 5 years ago #

    http://wordpress.org/support/topic/225607
    http://wordpress.org/support/topic/224084
    and now a repeat:
    I use rssfwd.com to get various feeds via email. Most of the blogs I received have something like [Randy Cassingham's Blog] or [New Urban Legends] affixed to the subject line. However, the blogs that I have setup for a friend and for my church etc, just come as []. How do I get something between the [] marks?

  2. reflexionstudios
    Member
    Posted 5 years ago #

    I'm afraid you'll have to give more specifics on the relationship between http://www.rssfwd.com, your blog(s), and your email. I'm assuming you're referring to the RSS feeds created by WP. Are you copy+pasting the correct feed URL into http://www.rssfwd.com?

  3. KathrynBassett
    Member
    Posted 5 years ago #

    Yes, the feeds created by WP. One example of what I pasted in to rssfwd.com is http://altadenabaptist.org/wordpress/ - I don't know what else there would be to paste. Is that wrong? I've just figured that there is some setting in WP that I've not got set since none of the three blogs give me anything in the [], but all the others I subscribe to do. Any ideas?

  4. reflexionstudios
    Member
    Posted 5 years ago #

    The link http://altadenabaptist.org/wordpress/ points to your blog, not to your RSS feed. Try putting this in:

    http://www.altadenabaptist.org/wordpress/feed/

  5. kmessinger
    Volunteer Moderator
    Posted 5 years ago #

    Your blog has errors in it which causes your feed at http://altadenabaptist.org/wordpress/feed to be unreadable.

    The errors are in your content which you must be cutting and pasting. If you are pasting from Word it will not work. You can look at your code with view source in your browser and see the bad characters.

    Also, you are using an old version of WordPress that may leave your site vulnurable to hackers.

  6. SimonJ
    Member
    Posted 5 years ago #

    There is something broken in your feed

    The <title>someting</title> is missing...

    You just have <title/>...

    Same thing for the <description>...

    <!-- generator="wordpress/2.3.1" -->
    −
    <rss version="2.0">
    −
    <channel>
    <title/>
    <link>http://www.altadenabaptist.org/wordpress</link>
    <description/>
    <pubDate>Mon, 15 Dec 2008 03:46:16 +0000</pubDate>
    <generator>http://wordpress.org/?v=2.3.1</generator>
    <language>en</language>

    When you troubleshoot something, looking at your file source is sometime a great idea...

    This is likely to be your problem...

    Replace the wordpress rss core file with a fresh one (from the version 2.3.1, as you use this version)

    S.

  7. KathrynBassett
    Member
    Posted 5 years ago #

    Before I worry about troubleshooting kmessinger's mention of errors, I'll fix the titles. Simon J said:

    Replace the wordpress rss core file with a fresh one (from the version 2.3.1, as you use this version)

    What would that file name be? I don't know what to look for. I can see what you mean, but there is no folder called feed. In /wordpress/ I've looked at index.php, wp-feed.php, and wp-blog-header.php and don't see the <title/>. I even used Dreamweaver's search routine to look for <title/> in the entire /wordpress/ folder/subfolders and it checked over 400 files and didn't find it. So what is the name of the file that has it? I know how to do titles and descriptions if I'm writing the code myself, but not with WordPress. Appreciate the help.

  8. kmessinger
    Volunteer Moderator
    Posted 5 years ago #

    I think SimonJ meant your wp-feed.php file in the WordPress root directory.

  9. SimonJ
    Member
    Posted 5 years ago #

    Non non...

    The file used to generate the 2.0 RSS feed is in :

    wordpress/include/feed-rss2.php

    You sould find there something like this, around line 16 :

    <channel>
    	<title><?php bloginfo_rss('name'); wp_title_rss(); ?></title>
    	<link><?php bloginfo_rss('url') ?></link>
    	<description><?php bloginfo_rss("description") ?></description>
    	<pubDate><?php echo mysql2date('D, d M Y H:i:s +0000', get_lastpostmodified('GMT'), false); ?></pubDate>
    	<generator>http://wordpress.org/?v=<?php bloginfo_rss('version'); ?></generator>
    	<language><?php echo get_option('rss_language'); ?></language>
    	<?php do_action('rss2_head'); ?>
    	<?php while( have_posts()) : the_post(); ?>

    So, replace this file with a fresh download of the version 2.3.1

    And consider to upgrade soon... :-)

    S.

  10. mrmist
    Forum Janitor
    Posted 5 years ago #

    You may be better off doing a site upgrade and then trying to fix your feed. Otherwise you could fix it, upgrade, and then have to fix it again.

  11. KathrynBassett
    Member
    Posted 5 years ago #

    SimonJ, thanks for telling me the name of the file I need to look at. Lines 16-26 show this:

    <channel>
    	<title><?php bloginfo_rss('name'); wp_title_rss(); ?></title>
    	<link><?php bloginfo_rss('url') ?></link>
    	<description><?php bloginfo_rss("description") ?></description>
    	<pubDate><?php echo mysql2date('D, d M Y H:i:s +0000', get_lastpostmodified('GMT'), false); ?></pubDate>
    	<generator>http://wordpress.org/?v=<?php bloginfo_rss('version'); ?></generator>
    	<language><?php echo get_option('rss_language'); ?></language>
    	<?php do_action('rss2_head'); ?>
    	<?php while( have_posts()) : the_post(); ?>
    	<item>
    		<title><?php the_title_rss() ?></title>

    Where do I put [ABC Messenger] (what I want to show in the rssfwd)? In line 16 or 26 or both? If line 16, do I put it in place of name in that line? or the_title on line 26? Or what?

    I didn't know there was a place that had to have the title put in. It's not in the instructions, or I would have done it before this.

    BTW, I *have* upgraded one of the blogs and have the same problem. The others (including this one) I plan on upgrading after Jan 8th when I'm having surgery and will have some "chained to the computer" time to do it. Just no time until then. Thanks for the concern in this matter - I really do plan to upgrade, I'm not being lazy, just lack of time. One of the things that is forcing me to find time for this version is this paragraph re 2.7:

    Last, but certainly not least, this may be the last time you ever have to manually upgrade WordPress again. We heard how tired you were of doing upgrades for yourself and your friends, so now WordPress includes a built-in upgrade that will automatically notify you of new releases, and when you’re ready it will download them, install them, and upgrade your blog with a single click.

  12. KathrynBassett
    Member
    Posted 5 years ago #

    Also, what is the difference between wp-rss and wp-rss2? Do I need to change both?

  13. KathrynBassett
    Member
    Posted 5 years ago #

    I found something that sheds light on my problem.
    http://wordpress.org/support/topic/149688?replies=4
    I have no "blog title" for the same reason that microclesia mentions. moshu says to add display: none; and I know about that when using a .css file, but like davidjpio, I don't know where to add it for WordPress. In the general options Blog Title field, do I put ABC Messenger display: none; all on that line or does the display: none; go someplace else? If so, where?

  14. Dgold
    Member
    Posted 5 years ago #

    I've just read thru this thread. Good to see we're getting somewhere at last with this issue.

    Your RSS backend code is calling-in your Blog Title, and puts in in the <title> field for your RSS. So if your blog has no title, that's why it's blank.

    I agree with the strategy of, do Not hard-code your title into the RSS generating php file. Leave it calling-in your blog title, and begin to use a Blog title. If you don't want the blog title to appear in your theme's frontend, use the display: none technique that you found out about. This is done in your CSS. Your theme's CSS is within your theme's folder, and is called "style.css". Make the display: none change there, to hide your title yet have a title.

  15. KathrynBassett
    Member
    Posted 5 years ago #

    Well shoot. The only thing in the css with title is

    h2.pagetitle {
    	font-size: 1.6em;
    	display: none;
    	}

    and as you see, I added the dsiplay: none; and uploaded it, and put the blog title in options, but as you can see
    http://altadenabaptist.org/wordpress/
    the display: none; is not working. What next?

  16. SimonJ
    Member
    Posted 5 years ago #

    KathrynBassett wrote:I have no "blog title" for the same reason that microclesia mentions. moshu says to add display: none; and I know about that when using a .css file, but like davidjpio, I don't know where to add it for WordPress. In the general options Blog Title field, do I put ABC Messenger display: none; all on that line or does the display: none; go someplace else? If so, where

    Well well well... If you do not have any blog title nor description, how could you imagine where wordpress should find this information for your CSS feed in the database???

    Nowhere indeed...

    The <?php bloginfo_rss('name'); wp_title_rss(); ?> in your rss file try to find the information "title" for your blog in the database. If there is nothing there, it will return nothing. So your RSS feed will not have any title. Same thing for the description.

    you *should* have a blog title and a blog description. If you do not want these information to be displayed in your site is totally another topic.

    As you ask where the display: none should be written, it's in your css style sheet (style.css in your theme directory) for the element relative to your blog title. In fact, it's a styling shortcut to "hide" this information.

    You could also edit your theme header to get rid of these information (title and description) wherever they are displayed.

    But the blog title and blog description in the options and settings of your blog are not there for esthetic purpose... They are there to be written in the database, whenever they are required... Just like in your RSS feed...

    S.

  17. KathrynBassett
    Member
    Posted 5 years ago #

    Hi Simon, I suspect that your cache hasn't caught up with my posts since I've already changed the style.css but the display: none; is not hiding the title.

  18. SimonJ
    Member
    Posted 5 years ago #

    KathrynBassett wrote :
    Well shoot. The only thing in the css with title is

    h2.pagetitle {
    font-size: 1.6em;
    display: none;
    }

    and as you see, I added the dsiplay: none; and uploaded it, and put the blog title in options, but as you can see
    http://altadenabaptist.org/wordpress/
    the display: none; is not working. What next?

    h2.pagetitle is nowhere in your header for the blog title to be displayed.

    Did you look at your header.php to see where your blogtitle is displayed?

    I guess not.

    "Page title" is not what you are looking for...

    1 - Open header.php in a decent text editor.
    2 - find this :

    <div id="headerimg">
    		<h1><a href="<?php echo get_option('home'); ?>/"><?php bloginfo('name'); ?></a></h1>
    		<div class="description"><?php bloginfo('description'); ?></div>
    	</div>

    3 - And change this for this :

    <div id="headerimg">
    	</div>

    So, just delete these two lines :

    <h1><a href="<?php echo get_option('home'); ?>/"><?php bloginfo('name'); ?></a></h1>
    		<div class="description"><?php bloginfo('description'); ?></div>

    That's all. Now, the name oh the blog and the description are no longer in the header.

    S.

  19. KathrynBassett
    Member
    Posted 5 years ago #

    HOORAY!!! Thanks a bunch to all who helped. Of course the final proof of this exercise will be after the next post is sent via rssfwd, but since the ABC Messenger shows up on the title bar in my browser and does NOT show up over my header graphic, I will assume that it will work correctly now. I think I can now say this is resolved.

  20. SimonJ
    Member
    Posted 5 years ago #

    I feel you should know something, although your problem is resolved...

    having your blog title in a link in your header is not only a fashion option... It is also a good way to get some ranking in google and other search engine. Your site will get more visibilty in the search engine with a link.

    Also, the search engine can't read the text in a jpg...

    It's also a navigation issue for your visitors... Now, in the header of your theme, there is no way to get back to your home page with a link...

    If I read a single post page, how can I get back to your home page?

    You should consider to imbed your image in a href link to your home page in your header.

    S.

  21. KathrynBassett
    Member
    Posted 5 years ago #

    Simon, you bring up some good points I hadn't thought of. If you don't mind my having your email address for some one on one help after I update in January, would you please email me off the forum? If you go to http://altadenabaptist.org/ and click on Contact Webmaster, that's me. I'm guessing that putting my email directly here in the forum is not "the thing to do", even though I'm all over the internet. If you aren't comfortable doing that, just say so, and I'll not take offense.

Topic Closed

This topic has been closed to new replies.

About this Topic