WordPress.org

Ready to get started?Download WordPress

Forums

WooCommerce SagePay Direct Payment Gateway
3D Secure Handshake (5 posts)

  1. Strawbsp
    Member
    Posted 6 months ago #

    Hi Steve

    We are having a slight issue, the plugin is awesome by the way. Just a little issue involving the 3D secure handshake between the site on the customers bank, we are using the latest version of the plugin 0.1.6.6 with woocommerce v. 2.0.10. 3D secure is setup and working on our Sagepay account, however when we went through a batch of live payments on the site, all of them failed, so we got in touch with Sagepay and they picked up that the 3D secure handshake wasn't connecting and failing each purchase attempt. When the purchase failed it was picked up on our Sagepay account and the sites checkout page simply refreshed with no error message.

    We saw in a previous thread that you mentioned that the issue has been fixed since version 0.1.6.5? Also you mention that one has to setup rules within the Sagepay 3D security section, any inclination as to what might be needed as a set of rules? and if this could possibly help resolve the issue?

    Thanks in advance Steve
    R

    http://wordpress.org/plugins/sagepay-direct-for-woocommerce-payment-gateway/

  2. swicks
    Member
    Plugin Author

    Posted 6 months ago #

    Hi
    The only issue I'm aware of was where the hosting company hadn't set up permissions correctly on the plugins folder - you should be able to access the 3DCallBack.php file from a browser (it's not designed to run through a browser, as it will keep trying to autoload ) to prove you have access - no 404 errors, etc.

    Setting up 3D Secure rules see this
    http://devicesoftware.com/setup-3d-secure-rules-2/

    regards

    Steve

  3. Strawbsp
    Member
    Posted 6 months ago #

    Thanks Steve

    Had a quick go at accessing 3DCallBack.php through the browser, which I could do, i.e no 404 or any other errors, like you said it just kept trying to auto load. Bit a strange one cause going through the steps we did when trying to purchase a product on the site I recall that once all info, card details where entered and the purchase button was pressed it didn't even reach the 3D secure screen that kinda looks like its iframed as it does with most 3D secure payment solutions, it just kinda hung for a little as if it was trying to connect and then refresh the page with no error messages yet still on the cart page, then like 10-15mins later when checking the Sagepay Live payments admin panel we could see that it was the 3D secure feature which was failing from the issuing bank.

    When you say permissions for the folder, what should they be if they were to be incorrect?

    Again thanks in advance for getting back to us
    R

  4. swicks
    Member
    Plugin Author

    Posted 6 months ago #

    'Other'/'Group' should have read access - in the instance we had the issue is was only the owner having access.

    Are you seeing the same symptoms running in Test?
    What theme are you using and can you switch to a standard wordpress theme to test?

    The steps the plugin takes to display this page:-

    • Validates the form
    • Posts info to SagePay
    • If 3D Secure is enabled - SagePay will return with a request
    • The plugin then displays an iframe with 3DRedirect as the source - this in turn has an autoload to submit a post asking the issuing bank to display their authentication page (ACSURL)

    If you can run the plugin in 'test' mode - we might be able to understand more from the debug email.

    regards

    Steve

  5. Strawbsp
    Member
    Posted 6 months ago #

    Will put it to the test and see what we get, will keep you updated.

    Thanks Steve
    R

Reply

You must log in to post.

About this Plugin

About this Topic

Tags

No tags yet.