WordPress.org

Ready to get started?Download WordPress

Forums

[closed] 3.9 Visual Editor (31 posts)

  1. orl
    Member
    Posted 4 months ago #

    Visual editor is no longer usable. It doesn't have a toolbar, nor can you type in it. We really need this function to work. Since it is vital we are able to view what we are typing in a word format, not text format, we ask that WordPress please provide a "fix".

  2. rizwp
    Member
    Posted 4 months ago #

    Some people say the problem is realted to the MailPoet plugin, try to disable it.
    In my case, part of the problem, was realted to "WordPress SEO" plugin

  3. Rijo Abraham
    Member
    Posted 4 months ago #

    I have two websites with same plugins. One worked after reactivating all plugins and the other one is still not working(both in different hosting). I 'm unable to add content in text, visual mode ( the content box where we add content is not showing anymore)

  4. orl
    Member
    Posted 4 months ago #

    I found a solution for us. In reading through the other threads, someone had said deactivate "Sound Cloud". When we did that, it worked. Visual editor is back on track now.

  5. Rijo Abraham
    Member
    Posted 4 months ago #

    Sound cloud plugin ? I dont use it.

    As i noted earlier for some people reactivating plugins will do the trick but others it wont. I dont think it has anything to do with the plugins we have installed in the first place.

    A issue with javascript/jquery code ? Since switching b/w text and visual editors isn't working either.

  6. simonlange
    Member
    Posted 4 months ago #

    its not plugin related its core related. please release asap a patch with a rollback for the visual editor.

    tyvm

  7. its not plugin related its core related. please release asap a patch with a rollback for the visual editor.

    OK. How did you come to that conclusion? I'm not saying you are incorrect but you'll need more than "it's broken" to make that determination.

    Give the whole 3.9 Master list a read.

    https://wordpress.org/support/topic/wordpress-39-master-list?replies=4

    The information that you gather can not only solve your problem but possibly others as well. Jumping on multiple threads without providing steps to reproduce or any error messages really isn't productive.

    If you only do one bit of troubleshooting then this really helps get to the bottom of visual editor issues.

    http://codex.wordpress.org/Using_Your_Browser_to_Diagnose_JavaScript_Errors

  8. I found a solution for us. In reading through the other threads, someone had said deactivate "Sound Cloud". When we did that, it worked. Visual editor is back on track now.

    Can you provide a link to that plugin? When a plugin is verified as being a problem it gets added to the list and the plugin author can be notified.

  9. orl
    Member
    Posted 4 months ago #

    I agree a patch is needed. Although deactivating "Sound Cloud" which is a plug in we use, solved our problem, we recognize not everyone uses this plugin. I think WordPress will need to release a "fix"

  10. Rijo Abraham
    Member
    Posted 4 months ago #

    Hi Jan,

    I dont think that plugin is causing the issue with visual editor. I deactivated all my plugins on a website and its still have the same issue.

    On the other hand i have a website with different hosting where i just deactivated and reactivated some plugins. The problem is no longer in that website.

  11. simonlange
    Member
    Posted 4 months ago #

    Jan wrote

    OK. How did you come to that conclusion? I'm not saying you are incorrect but you'll need more than "it's broken" to make that determination.

    its plain logic.
    3.8.x worked
    refering the reports just in this forum (or even just in this thread) it does not matter if u:
    - have default theme or not
    - plugins installed or not
    - mutisite or not

    the only factor they all have in comon is that they did upgrade frmo 3.8.x to 3.9.

    a hotfix for the visual editor (rollback and maybe upgrade at a later stage) would be the best solution rght now.
    guess u had reason to upgrade the VE but since its more unstable than stable it should not used in a stable branch.

    m2c

    Simon

  12. [quote] doesn't work here and I've fixed your post.

    its plain logic.

    Is that like Common Senseā„¢? It's not really that common. ;)

    There are plugins that have been doing_it_wrong() and those tend to break with major version updates. Saying that it worked before doesn't mean it's a core problem. It does mean something broke and by taking the time to do those steps I linked to above you can help get that sorted out.

    Or not. These are volunteer forums and no one has to do anything. But just saying it's a core problem won't get any traction. It could be a core problem but more information really is needed to make that determination.

    Edit:

    refering the reports just in this forum (or even just in this thread) it does not matter if u:
    - have default theme or not
    - plugins installed or not
    - mutisite or not

    That's not helpful either. This version was contributed to by a lot of people and it was tested. Again that doesn't mean people are not having problems but information to what those problems are can help solve it.

  13. simonlange
    Member
    Posted 4 months ago #

    as said. the bug is always the same and it does not matter if u got 3rd party plugins installed or any installed or not.

    you may find cases where a plugin may triggered the bug. as you find pretty easy cases where its not plugin related (just by the fact that they dont have any installed), which is destroying the theory that its plugins to blame. ;)

    same for themes or multisite/single.
    the only common factor is the upgrade itself.

    just read this thread even here we got (including me) ppl who got this bug with standard theme and no plugins running. i got plenty sites and all sites except one got this bug. funny. they all using the same configuration in the backend. same fpm configuration same php.ini same webserver. so right now i dont have any clue what is triggering this bug.

    Simon

  14. Bet Hannon
    Member
    Posted 4 months ago #

    I have a handful of sites affected by what seems to be the same issue. I have discovered that this has worked for me (although I don't understand why): deactivate all plugins (after which the Visual editor reappeared), then reactivate them.

    Initially, I was reactivating one by one to troubleshoot, but found no offenders, so on the last couple, I've just reactivated all at once, and the visual editor remained "fixed". Maybe this will help someone-- at least I don't think it will hurt anything to try.

  15. AnotherOpus
    Member
    Posted 4 months ago #

    In our case the Styles with Shortcodes plugin for WordPress (CodeCanyon) caused the problem. As soon as we deactivated it the editor started working.

  16. rawalex
    Member
    Posted 4 months ago #

    For what it's worth, you may want to check if you are using an up to date browser. From what I can see, this new editor won't work with older browsers.

    I am almost not upgrading (or is it downgrading) to 3.9 until the editor situation gets resolved. Losing too many features and perhaps running afoul of other plugins seems like a giant leap, but not forward!

  17. RSRescue
    Member
    Posted 4 months ago #

    I have tried all of the suggestions above and my editors still do not work as well switching between visual and text also do not work. is there a simple and safe way to downgrade back to older version which seemed to work for me? any help would be greatly appreciated.

  18. Bet - Your method implies that your site needed to forcibly have jquery reloaded, and the normal methods weren't working.

  19. RSRescue
    Member
    Posted 4 months ago #

    ?????

  20. jhobrlant@web.de
    Member
    Posted 4 months ago #

    For me, turning off WPML fixed it temporarily. So I could use the editor as usual.

    With WPML activated it threw this:
    Failed to load resource: the server responded with a status of 404 (Not Found) http://xxx.xxx.xxx/wp-includes/js/tinymce/tiny_mce.js?ver=3.9
    Uncaught ReferenceError: tinyMCE is not defined

  21. jamesm84
    Member
    Posted 4 months ago #

    please notice that I had the same problem with WP 3.9 Plugin:
    WP Admin Custom Page

    Once i disabled it the visual editor is working again

  22. Can you post a link to that plugin? I'd like to add it to the list if it can be confirmed that it's causing problems.

  23. AnotherOpus
    Member
    Posted 4 months ago #

    @Jan Dembowski, not sure who you are asking for a plugin link.

    The link to Styles with Shortcodes is:

    http://codecanyon.net/item/styles-with-shortcodes-for-wordpress/142221

    The developer released a new version today which they said resolves the issue for their plugin. I have not tested it yet.

  24. tidanielsdw
    Member
    Posted 4 months ago #

    Deactivating the SoundCloud plugin worked for us too. However as the plugin hasn't updated in a long while (if, from memory, ever) I think this is related to the recent update and needs to be fixed.

    This is the plugin: https://wordpress.org/plugins/soundcloud-is-gold/

    NB a WordPress SEO plugin update came out the other day and we updated before I noticed the visual editor problem, so it's possible this is also causing users issues. You should update to see whether that fixes things for you.

  25. @Jan Dembowski, not sure who you are asking for a plugin link.

    Well anyone really and thanks for the report. But I really meant jamesm84 in that instance. ;)

  26. ksteff0815
    Member
    Posted 4 months ago #

    sorry guys, but I have the easy photoalbum plugin, which was recently updated. and my visual editor shows the same symptons ...

    so what now? deactivating the photo gallery is out of the question.

    anybody any other thoughts?

    thanks is advance
    steff

  27. bemdesign
    Member
    Posted 4 months ago #

    @ksteff0815 - try disabling all plugins and custom themes. Then enable your custom theme - if it works, great, if not contact the theme developer. Then start enabling plugins one at a time. Check to see if everything works after enabling a plugin. If everything works, great. If not, note which was the last plugin enabled before things stopped working and contact the plugin developer.

    You can also use your browsers web developer tools to check for any JavaScript conflicts. See https://wordpress.org/support/topic/wordpress-39-master-list?replies=4 for the current list of known issues in regards to 3.9 and certain plugins.

  28. sorry guys, but I have the easy photoalbum plugin, which was recently updated. and my visual editor shows the same symptons ...

    The Visual Editor relies heavily on JavaScript. Give this a read and try those steps. It may help identify where/what's broken.

    http://codex.wordpress.org/Using_Your_Browser_to_Diagnose_JavaScript_Errors

  29. ksteff0815
    Member
    Posted 4 months ago #

    thanks found the error and fixed it:

    Failed to load:
    wp-content/plugins/easy-photo-album/js/tinymce/pluginmin.js

    it was named:
    plugin.min.js

    I renamed it and everything is back to normal. Thanks to firebug error console

    thx
    steff

  30. dmoniquesmith
    Member
    Posted 4 months ago #

    The WordPress update completely took away my ability to edit my text in html and I can't even change the size of the fonts. All of my pages are created via a plugin -- funnelKit. Any idea how to edit my text?

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.