WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] 3.9 Update TinyMCE disappeared (9 posts)

  1. bdario
    Member
    Posted 4 months ago #

    After updating my wordpress to version 3.9, TinyMCE editor disappeared. Firebug catches the following error:

    "TypeError: tinymce.dom.Event.add is not a function
    tinymce.dom.Event.add(editButton, 'mousedown', function(e) {"
    editor_plugin.js (row 147)

    This error occour even if I disable other plugins such "TinyMCE Advanced" or "Ultimate TinyMCE"

    Please, I'll appreciate any hint helping me to solve this problem, thank you in advance.

    Dario

  2. Hi bdario,

    Have you tried disabling all of your plugins?

    Also, 3.9 shipped with the new TinyMCE 4.0.x version so you may need to wait for your TinyMCE plugins to catch up.

  3. Bet Hannon
    Member
    Posted 4 months ago #

    The Tinymce/Visual editor disappeared for me on some sites too!

    I tried disabling ALL my plugins and activating TwentyTwelve, but still have the error. Suggestions?

    Drew, are you suggesting that some plugins using older versions of TinyMCE might be keeping any version of it from working?

  4. Andrew Ozz
    WordPress Dev
    Posted 4 months ago #

    @bdario can you post the path (URL) to that editor_plugin.js file. Should be visible if you hover over it in the console. This looks like a part of an outdated TinyMCE plugin, disabling it should bring the editor back.

  5. bdario
    Member
    Posted 4 months ago #

    Hi Drew, thank you for your suggestion, it helped me a lot. Infact, I first disabled all plugins and the editor magically appeared again.
    Then I start enabling every single plugin, one at time, and found that the problem was caused by "MailPoet Newsletters" version 2.6.3 (by Wysija)! If I try to enable it again the editor disappear.
    I'll try to contact their developer team hoping to get a solution soon.
    Thank you for your help,
    Dario

  6. bdario
    Member
    Posted 4 months ago #

    Hi Andrew,

    the link is the following:
    http://timeforequality.org/wp-content/plugins/wysija-newsletters/mce/wysija_register/editor_plugin.js

    I re-enabled "MailPoet Newsletter" so the error happens again,
    thank you for your help,
    Dario

  7. Bet Hannon
    Member
    Posted 4 months ago #

    My error does not seem to be related to plugins or theme-- I've deactivated all plugins & changed to a base theme, but still no TinyMCE.

    Any ideas about what I could try next?

  8. MailPoet Staff
    Member
    Posted 4 months ago #

    Hi Guys, we are already working on a fix for the TinyMCE issue, rest assured, those fixes will be out on the next versions 2.6.4 (for post editor screen) and 2.6.5 (for our own newsletter editor).

  9. Thanks, MailPoet! I updated the master list with that info.

    Bet - You've heard this one before :) Please do your own topic. List exactly what you tried (don't say 'I tried everything!', please do spell it out). Check your error logs, etc.

    Everyone - If a post is marked Resolved and you're not the plugin/theme dev, please don't add on your issues. In general people ignore resolved threads for our own sanity.

Reply

You must log in to post.

About this Topic