WordPress.org

Ready to get started?Download WordPress

Forums

3.7.1 Update installation failed (6 posts)

  1. underclass
    Member
    Posted 8 months ago #

    Updating any of my wordpress sites returns a variation of the following error through the dashboard update;

    Downloading update from https://wordpress.org/wordpress-3.7.1-no-content.zip

    Unpacking the update…

    Could not copy file.: wordpress/wp-admin/includes/class-pclzip.php

    Installation Failed

  2. underclass
    Member
    Posted 8 months ago #

    UPDATE
    I have contacted the site host as sites on different servers have updated successfully.

  3. mikeill
    Member
    Posted 8 months ago #

    My automatic update of:
    Downloading update from http://wordpress.org/wordpress-3.7.1-no-content.zip…

    stalls out at:
    Unpacking the update…

  4. mikeill
    Member
    Posted 8 months ago #

    I was able to solve this problem by having the hosts rename the php.ini file in your public_html directory to php.ini_bak.

    In addition, they increased the Apache timeout on the server hosting the account to 60 seconds.

    Automatic update working now.

  5. Dzynit
    Member
    Posted 7 months ago #

    In my case it was permission issues on some of the files and folders on the site. Hosting had to correct that for me. Still unsure of what caused the permission problem though because all previous automatic upgrades worked perfectly fine. When this happened, even manual uploading wasn't working.
    Since your error says permission denied in it, it might be worth putting in a ticket to your hosting and see if that could possibly be your problem too.

    My hosting support initially told me that the upgrade was timing out and wordpress was at fault. But they eventually dealt with taking care of the permission problems on all the files and folders and the upgrade worked correctly. Even plugins were failing to complete upgrade and a single plugin timing out just didn't seem logical.

  6. mikeill
    Member
    Posted 7 months ago #

    RLKBarry - might want to check with your web hosting company. it could be a memory setting in the php.ini or possibly an issue with permissions.

    A workaround might be to download the latest version of WP and manually upload the files with an FTP program. If the web host provides a CPANEL that can often be used for transferring and manipulating files, as well as database and file back-ups.

Reply

You must log in to post.

About this Topic