WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] [closed] 3.7.1 Media Library not working properly (11 posts)

  1. snowbelly
    Member
    Posted 8 months ago #

    Just upgraded to 3.7 and had a problem with the media library - I heard there were some image bug fixes in 3.7.1 so I installed that fix, but our media library problems are still there.

    Here is what we are seeing:
    * go to media library
    * add a new image
    * upload the image --> appears to upload fine; no errors reported
    * attempt to embed the image in a post/page -> does not show, only a blank box is visible
    * attempt to view the image via the direct URL -> does not load, says file does not exist
    * attempt to view the shortlink page - page loads, image is blank (not even with the proper dimensions, just completely not loaded)

    However:
    * attempt to "edit" the image, we can see it and rotate/zoom, etc, then save it - but still it does not show up when we attempt to embed it or view it directly via the image URL.

    Anyone else seeing problems like this? Any thoughts on any settings we might have wrong?

    Thanks!

  2. snowbelly
    Member
    Posted 8 months ago #

    Found it!

    The problem was my settings - under Settings --> Media, there's a path for saving images. It should be set by default to wp-content/uploads, but for some reason it had been corrupted.

    Fixed!

  3. benjlawton
    Member
    Posted 8 months ago #

    I have this exact problem but when i go to settings - media - the only options i have are changing the dimensions of the images

  4. esmi
    Forum Moderator
    Posted 8 months ago #

    @benjlawton: As per the Forum Welcome, please post your own topic.

  5. tommy banana
    Member
    Posted 8 months ago #

    In Media >Settings I unchecked the 'organise my images in month- and year based folders' box and the problem went away.

  6. Michael56J
    Member
    Posted 7 months ago #

    under Settings --> Media, there's a path for saving images

    I don't have this box.

    In Media >Settings I unchecked the 'organise my images in month- and year based folders' box and the problem went away.

    This doesn't work for me.

  7. shancat
    Member
    Posted 7 months ago #

    I have the same problem. I'm new to wordpress and feel very frustrated with this issue.

  8. snowbelly
    Member
    Posted 7 months ago #

    Are you sure you are running 3.7.1? If not, best to upgrade first.

  9. shancat
    Member
    Posted 7 months ago #

    Yes i have 3.7.1 installed. Just installed it yesterday.

  10. esmi
    Forum Moderator
    Posted 7 months ago #

    @shancat: As per the Forum Welcome, please post your own topic. This topic has been resolved.

  11. Michael56J
    Member
    Posted 7 months ago #

    Hello Esmi.

    I'm not so sure that this topic has been resolved by the WordPress community, yet.

    However, my hosting provider has changed the permissions of the uploads folder to 755 and the permissions of all the image files to 644. This seems to have worked.

    I hope that this helps others in the same position.

    Michael

Topic Closed

This topic has been closed to new replies.

About this Topic