WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] [closed] 3.7 Upgrade Loses wp-admin/*.php Pages (25 posts)

  1. questions4wp
    Member
    Posted 9 months ago #

    I just upgraded to 3.7 on a couple of non-essential sites (cleared caches, disabled all plugins, backed up database + files, made sure none of the plugins are the ones mentioned in the Master List post), and for some reason now any WordPress files stored in /wp-admin/ are inaccessible.

    For instance, upon finishing the update, I click on the "Return to updates" page, which should bring me to mydomain.com/wp-admin/update-core.php, but when visiting that page, I get the standard WordPress 404 error page, with my site's theme. Similarly, going back into the dashboard and clicking on the Plugins tab should bring me to mydomain.com/wp-admin/plugins.php, but instead I get the same 404 page.

    I can confirm that all the files are actually on the server (and are their most updated versions). Any advice?

  2. bemdesign
    Member
    Posted 9 months ago #

    Assuming your backups are good and you're running on Apache, can you replace the code of your .htaccess file with the following:

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>
    # END WordPress

    and see if that fixes things?

  3. leejosepho
    Member
    Posted 9 months ago #

    Also, maybe see this at the end of Otto's recent post elsewhere:

    "check in the wp-admin folder" for an .htaccess file. WordPress does not create an .htaccess in the wp-admin folder, but some security plugins do, and those have been shown to cause problems...
    http://wordpress.org/support/topic/featured-image-not-working-since-36-37?replies=8#post-4807727

  4. questions4wp
    Member
    Posted 9 months ago #

    The low-traffic websites which I updated to 3.7 do not have any security plugins (though some of the higher-traffic sites do). There is also no .htaccess file inside the wp-admin folder, or anywhere else in the site's directory. My host's root directory is for my main domain, and there are a number of subdirectories for other domains and subdomains. Only the root directory and the higher-trafficked sites with security plugins have .htaccess files. I am indeed running Apache, though, and my backups are fine - however, there's nothing to replace with the code that bemdesign posted.

    Thanks though! Anything else I can try?

  5. Are there any errors on your server's error log?

  6. questions4wp
    Member
    Posted 9 months ago #

    None, unfortunately

  7. miss cast
    Member
    Posted 9 months ago #

    Bemdesign, the same thing has happened to me after upgrade.
    I checked my htaccess file and it looks just like what you posted, just with my name on rewrite base.
    I am not savvy in this stuff so where do I get help getting back online?
    Thanks

  8. cubecolour
    ɹoʇɐɹǝpoɯ
    Posted 9 months ago #

    miss cast, please start your own topic

  9. miss cast
    Member
    Posted 9 months ago #

    this thread is closed?

  10. cubecolour
    ɹoʇɐɹǝpoɯ
    Posted 9 months ago #

    no, but your issue may not have the same cause as the one currently under discussion. http://codex.wordpress.org/Forum_Welcome#Where_To_Post

  11. questions4wp - Remove the .htaccess (or rename it .htaccess-old) for kicks...

    Also did you turn off ALL plugins? Renaming the folder usually works.

  12. questions4wp
    Member
    Posted 9 months ago #

    I am sure that I turned off all the plugins (I renamed the plugin folder plugins-old), and I renamed the .htaccess file located in my site root as well. Renaming the plugins folder did nothing, although renaming the .htaccess file made mydomain.com/wp-admin/update-core.php return a 500 error instead of a 404. The 500 error was handled by my server (as opposed to the 404, which was handled by WordPress).

    Interestingly, I can edit pages just fine, and the URL for the page editor is mydomain.com/wp-admin/edit.php?post_type=page

  13. questions4wp
    Member
    Posted 9 months ago #

    I figured it out! Well, really, the tech support people figured it out =)

    After confirming all file permissions were correct, .htaccess looked normal (similar if not identical to bemdesign's post), that all the files were on the server and were their most updated versions, and that all the plugins were fine (or even disabled/deleted), I contacted my host for support (I prefer not to contact them for WordPress-related issues, since it's an external application).

    I use InMotionHosting, but the solution might be relevant for others. WordPress 3.7 requires PHP version 5.3. The cPanel on my host shows that it is indeed running a 5.3.* release, so I didn't think anything of it. It turns out that there are multiple versions available for different applications. To force that domain to use PHP 5.3, the tech person added the following line to the top of my .htaccess file:

    AddHandler application/x-httpd-php5 .php

    It now works fine. I can confirm that all pages are accessible (both administrative and content), and I can update everything. I have gone around making this change to all of my domains, and they all seem to work.

  14. Clarence Johnson
    Member
    Posted 9 months ago #

    Thank you questions4wp.

    Adding that line to the .Htaccess file worked for me too.

  15. chriscob
    Member
    Posted 9 months ago #

    I just found this and it solved my inMotion problem as well.

  16. babalu_52
    Member
    Posted 8 months ago #

    questions4wp: Excellent, thanks. That worked for me as well. Inmotion would be fantastic if they sent out this helpful suggestion to all of their wordpress customers.

    AddHandler application/x-httpd-php5 .php

  17. epicdiyom
    Member
    Posted 8 months ago #

    Adding this line to .htaccess solved my problem, as well:

    AddHandler application/x-httpd-php5 .php

    It would be nice if future WordPress releases included a fix for this, because it took a while to stumble across this solution.

  18. embrownny
    Member
    Posted 8 months ago #

    I have been searching high and low to find a resolution to this problem. I added that line of code to the .htaccess file but I'm still getting the Error-4o4 message on the archive page...http://www.mediastarpro.com/page/2/

    The home page is fine and all the other pages. But when you click and the "next" link from the homepage video gallery the Error-404 message still comes up. Any other ideas?

    Did I not put the
    AddHandler application/x-httpd-php5 .php in the right place?`

  19. greginnd
    Member
    Posted 6 months ago #

    Thank you!! I put this line at the top right below the # BEGIN line and it fixed the problem. Appreciate the help.

  20. MagicPlants
    Member
    Posted 6 months ago #

    SOLUTION

    Edit the .htaccess file in your ROOT (/) not WordPress folder (/public_html/) to force PHP 5.5 instead of 5.2

    CHANGE:

    # Use PHP52 as default
    AddHandler application/x-httpd-php52 .php

    TO:

    # Use PHP52 as default
    AddHandler application/x-httpd-php55 .php

    FINAL ANSWER! (;

  21. erumHannan
    Member
    Posted 2 months ago #

    hy my site with php5.3 was working fine in localhost and in server as well but when i upgrade my wamp with php5.5.12 now my site is not working in localhost even i am just able to login in admin panel ie wp-admin and no tabs of admin panel is working they are just clickable and nothing displayed there i have also followed same sugeestions prvided by other here but still no luck can someone please help me

  22. erumHannan
    Member
    Posted 2 months ago #

    my htaccess file is : # BEGIN WordPress

    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /AlFerdous/admin/
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /AlFerdous/admin/index.php [L]
    
    </IfModule>
    
    # END WordPress

    when i changed it to:

    # BEGIN WordPress
    
    AddHandler application/x-httpd-php54.php
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /AlFerdous/admin/
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /AlFerdous/admin/index.php [L]
    
    </IfModule>
    
    # END WordPress

    now its giving me error:

    Internal Server Error

    The server encountered an internal error or misconfiguration and was unable to complete your request.

    Please contact the server administrator at admin@example.com to inform them of the time this error occurred, and the actions you performed just before this error.

    More information about this error may be available in the server error log.
    Apache/2.4.9 (Win64) PHP/5.5.12 Server at localhost Port 80

  23. majo013
    Member
    Posted 2 months ago #

    I had a same issue, thanks

  24. erumHannan
    Member
    Posted 2 months ago #

    wp-admin side tabs are failed to work in php5.4 when i was using php5.3 with wordpress $wp_version = '3.3.2'; it was working fine while right now trying to use php5.4 with same wp version now my admin-panel links are not working

  25. esmi
    Forum Moderator
    Posted 2 months ago #

    If you require assistance then, as per the Forum Welcome, please post your own topic instead of tagging onto someone else's topic.

    I am now closing this 6 month old, resolved, topic

Topic Closed

This topic has been closed to new replies.

About this Topic