WordPress.org

Ready to get started?Download WordPress

Forums

3.5.2 Media Button No Longer Works (8 posts)

  1. helena.qurfew
    Member
    Posted 1 year ago #

    I updated to 3.5.2 just now - the "add media" button on the pages no longer works and I can no longer edit pages on the visual tab.

    ?!

  2. helena.qurfew
    Member
    Posted 1 year ago #

    Just cleared the cache to make sure that wasn't causing the issue. It is not. Basically, when I click on the visual editor button on a page it does nothing. When I go to upload media the upload button does nothing.

  3. Krishna
    Volunteer Moderator
    Posted 1 year ago #

    Deactivate all plugins and revert to Twenty Twelve theme and see if it helps. You can revert to your current settings after these basic troubleshooting steps.

  4. helena.qurfew
    Member
    Posted 1 year ago #

    Actually, I have been working with the TwentyTwelve functions.php file tonight and was editing it and uploaded the version I was working with after the update and am now getting an error:

    Fatal error: Call to undefined function add_action() in /home/helena/public_html/wp-includes/functions.php on line 79

    Which contains the line:

    add_action( 'after_setup_theme', 'twentytwelve_setup' );

    My site is now completely unusable. Is there a way to reupdate or download the functions.php file that came with the update?

  5. helena.qurfew
    Member
    Posted 1 year ago #

    I downloaded the twentytwelve theme again from:
    http://wordpress.org/themes/twentytwelve
    and replaced the functions.php. Same error.

    I cannot deactivate plugins as I cannot even get into my admin panel,

  6. Krishna
    Volunteer Moderator
    Posted 1 year ago #

    Use FTP/ hosting control panel and add -old to your plugins folder to deactivate all plugins. Similarly, add -old to your current theme. You will be able to login to your admin again.

  7. helena.qurfew
    Member
    Posted 1 year ago #

    Krishna - thank you for all the help. Actually, after your last post I realized that the last time I replaced the functions.php file I accidentally replaced the one in /wp-includes rather than the one in the theme folder (!). Apologies for that confusion. After I replaced that with the core file I was able to get into admin.

    It still was not functioning in the way I mentioned earlier, so I did as you suggested and disabled all plugins and reactivated them and it worked! Thank you so much! Why does this occur?

    Honestly, everytime a wordpress update appears I'm like "Oh shit". Are they working on anything to reduce the "Oh shit" factor involved in updates? I've seen countless posts of people who have difficulties when an update occurs.

    Thanks again for your kind assistance!

  8. Krishna
    Volunteer Moderator
    Posted 1 year ago #

    I updated one of my sites just before I attended to your question. I had no problems. What I generally do is as follows:
    -deactivate all plugins
    -revert to the default WordPress theme
    -create backup of my database
    -and then update WordPress
    I have been following these steps always. I never had any problems while updating. Once WordPress is updated, I revert to my previous settings and ensure that I update all installed themes and plugins. Try these steps. If I could avoid problems, you too can!

Topic Closed

This topic has been closed to new replies.

About this Topic