WordPress.org

Ready to get started?Download WordPress

Forums

3.5 Custom image sizes broken (3 posts)

  1. deurtje
    Member
    Posted 1 year ago #

    Not sure if this has been handled before or not, but I'm losing my mind here.

    I'm using a couple of custom image sizes for thumbnails on my page. Since the 3.5 update I've encountered a problem with at least one of them so far.

    When I upload an image and set it as featured image and don't edit the thumbnail all works fine. However, if I use the WordPress media editor to change the way the thumbnail looks, one of my custom image sizes stops working.

    What previously happened was that WordPress added '-60x40' to the image link. It still does this when I don't crop or edit the thumbnail, but when I do, it just uses the original link (so without '-60x40'), resulting in it showing the full image. This breaks my custom image size, because when I use an image of, let's say, 500x500 pixels, it will show it on my page as 40x40 pixels.

    Has anyone noticed this same problem or does anyone know a solution to this?

    Thank you very much!

  2. lewismcarey
    Member
    Posted 1 year ago #

    I have the same issue.

    This appears to be a problem with cropping/editing only thumbnails.

    When I add an image to the media library it creates a full array containing all the urls to the various sizes in _wp_attachment_metadata.

    However when I crop the thumbnail it only saves the thumbnail reference in _wp_attachment_metadata and all references to the other sizes disappear.

    This actually includes the media default sizes in settings, such as medium and large, so all images referenced at any other size than thumbnail display as full.

    I believe the reverse of this happens when I update all but the thumbnail. Thumbnail seems to disappear.

    I am running WordPress 3.5. I have GD enabled. It seems to be more of an issue with wp_generate_attachment_metadata or something?

    Any help would be appreciated.

  3. lewismcarey
    Member
    Posted 1 year ago #

    There is a ticket on this now:

    http://core.trac.wordpress.org/ticket/22985

Topic Closed

This topic has been closed to new replies.

About this Topic